View Issue Details

IDProjectCategoryLast Update
0021349AI War 2[All Projects] GUISep 9, 2019 4:51 pm
ReporterAnnoyingOrangeAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.872 Supply and Control 
Fixed in Version0.888 Astro Examination 
Summary0021349: Selection boxes in the Build menu are seriously glitchy
DescriptionScreenshot attached.
The wrong selection is surprisingly stable, it will not only persist after small cursor movements but also reappear if the cursor is moved slightly outside the glitched area and then back inside it.
Steps to reproduce:
1 - Mouse over any entry in the build menu with one entry directly above it, for example you can mouse over "matter converter" as there's "factory" directly above it.
Double check that you're actually selecting the right entry, and that you don't have a wrong selection already.
2 - Move the mouse to the right, out of the build menu, without passing over any other entry in the menu.
3 - Move the mouse over the build menu entry right above the one selected in step 1, you need to move the mouse to the left and without passing over any other entry but the intended one.
4 - Wiggle the mouse a bit without leaving the selection box, the glitch tends to happen near the small metal icon but not always there.
TagsNo tags attached.

Relationships

related to 0021230 resolvedx4000Bughunter A tiny section of each button on the sidebar actually selects the option below it 

Activities

AnnoyingOrange

Jul 4, 2019 11:52 am

reporter  

bugged selection box.png (1,258,839 bytes)

x4000Bughunter

Sep 9, 2019 4:51 pm

administrator   ~0052953

Thanks!

* Fixed several super-annoying glitches with any pieces of text we were using that had icons in them, mainly in parts of the sidebars, where the clickable area of buttons would be absurdly large and obscure part of the button below them. This often led to clicks and hovers actually selecting the wrong button, which was rightly infuriating.
** Turns out this was actually a bug/oversight in TextMeshPro itself, and we've fixed it per the notes we left here: https://forum.unity.com/threads/cant-disable-raycasting-on-tmp-submesh.548500/#post-4948295

Issue History

Date Modified Username Field Change
Jul 4, 2019 11:52 am AnnoyingOrange New Issue
Jul 4, 2019 11:52 am AnnoyingOrange File Added: bugged selection box.png
Sep 9, 2019 4:20 am AnnoyingOrange Relationship added related to 0021230
Sep 9, 2019 4:51 pm x4000Bughunter Assigned To => x4000Bughunter
Sep 9, 2019 4:51 pm x4000Bughunter Status new => resolved
Sep 9, 2019 4:51 pm x4000Bughunter Resolution open => fixed
Sep 9, 2019 4:51 pm x4000Bughunter Fixed in Version => 0.888 Astro Examination
Sep 9, 2019 4:51 pm x4000Bughunter Note Added: 0052953