View Issue Details

IDProjectCategoryLast Update
0021282AI War 2[All Projects] Gameplay IssueJun 27, 2019 8:58 pm
ReporterRocketAssistedPuffinAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 0.867 Smarter AI, Better Mark Spread, Player Economic Boom 
Fixed in Version0.872 Supply and Control 
Summary0021282: Unit Movement Stutter
DescriptionEssentially the Steam Discussion. I have a save showing the Movement Stuttering that Ecthelon mentioned, with the new targeting code in place.

Simply spawn an AI Wave with the Debug option and watch.
TagsNo tags attached.

Activities

RocketAssistedPuffin

Jun 6, 2019 1:06 pm

developer  

UnitAttackMovementStutter.save (309,716 bytes)

x4000Bughunter

Jun 6, 2019 4:52 pm

administrator   ~0051883

Thanks!

* More debug info has been put into the tooltips for ships when that toggle is turned on in the personal settings debug section. This is revealing to us at the moment how often the targetPriorityList is empty (for some reason!) when ships are trying to pursue enemies. Not sure yet why that is the case, but this is the cause of the "movement stutters" reported by Ecthelon and RocketAssistedPuffin relating to units in pursuit mode.

BadgerBadger

Jun 8, 2019 1:19 pm

manager   ~0051900

Here's another save game you can use to get lots of units with empty target lists. Just start the superterminal hack. Save originally provided by major domo

1.save (884,220 bytes)

BadgerBadger

Jun 27, 2019 8:58 pm

manager   ~0051986

Should be fixed (or at least, significantly improved)

Issue History

Date Modified Username Field Change
Jun 6, 2019 1:06 pm RocketAssistedPuffin New Issue
Jun 6, 2019 1:06 pm RocketAssistedPuffin Status new => assigned
Jun 6, 2019 1:06 pm RocketAssistedPuffin Assigned To => x4000Bughunter
Jun 6, 2019 1:06 pm RocketAssistedPuffin File Added: UnitAttackMovementStutter.save
Jun 6, 2019 4:52 pm x4000Bughunter Note Added: 0051883
Jun 6, 2019 4:52 pm x4000Bughunter Status assigned => confirmed
Jun 8, 2019 1:19 pm BadgerBadger File Added: 1.save
Jun 8, 2019 1:19 pm BadgerBadger Note Added: 0051900
Jun 27, 2019 8:58 pm BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Jun 27, 2019 8:58 pm BadgerBadger Status confirmed => resolved
Jun 27, 2019 8:58 pm BadgerBadger Resolution open => fixed
Jun 27, 2019 8:58 pm BadgerBadger Fixed in Version => 0.872 Supply and Control
Jun 27, 2019 8:58 pm BadgerBadger Note Added: 0051986