View Issue Details

IDProjectCategoryLast Update
0021265AI War 2[All Projects] Graphical BugJun 20, 2019 11:55 am
ReporterAnnoyingOrangeAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product VersionBETA 0.864 Humanity Strikes Back 
Fixed in VersionBETA 0.868 Fleet EXP Level-Ups and Starting Battlestations 
Summary0021265: Some icons in the Local tab are sometimes broken
DescriptionIn the first attached screenshot, one can see that quite a few icons are broken or distorted, most notably the Armored Golem icon and the neutral Transport icon are clearly displayed incorrectly.
The second screenshot shows a much more extreme case, with most icons being affected.
The issue appears seemingly at random, but usually not immediately after starting a new campaign.
TagsNo tags attached.

Relationships

duplicate of 0021216 resolvedx4000Bughunter Bugged icons are frustrating me 
duplicate of 0021147 resolvedx4000Bughunter Sidebar Icons are rather...messed up? 

Activities

AnnoyingOrange

Jun 4, 2019 10:48 am

reporter  

bugged icons.jpg (304,093 bytes)
buggier icons.jpg (280,899 bytes)

x4000Bughunter

Jun 4, 2019 11:50 am

administrator   ~0051823

This is something that is apparently a bug in the current version of unity, but which was fixed in the latest version from what I can tell. I'll be upgrading to that (it just came out I think yesterday) soon, but the sidebar icons style will be changed a lot soon, anyway.

x4000Bughunter

Jun 20, 2019 11:55 am

administrator   ~0051932

Thanks!

* Upgraded unity from 2019.1.0 to 2019.1.7.
** This has a number of bugfixes, most of which aren't relevant to us, but if you were getting double keystrokes on linux that should now be fixed.
** Additionally, this issue that was fixedin 2019.1.5: UI: removing sprite mesh caching optimization as it was causing too many issues.
*** This is, best guess, going to fix the sidebar issue with the icons going crazy for no good reason. Things like certain icons drawing too large, etc, was probably this. If you see that again, please let us know!

Issue History

Date Modified Username Field Change
Jun 4, 2019 10:48 am AnnoyingOrange New Issue
Jun 4, 2019 10:48 am AnnoyingOrange File Added: bugged icons.jpg
Jun 4, 2019 10:48 am AnnoyingOrange File Added: buggier icons.jpg
Jun 4, 2019 11:04 am x4000Bughunter Relationship added duplicate of 0021216
Jun 4, 2019 11:50 am x4000Bughunter Note Added: 0051823
Jun 20, 2019 11:55 am x4000Bughunter Relationship added duplicate of 0021147
Jun 20, 2019 11:55 am x4000Bughunter Assigned To => x4000Bughunter
Jun 20, 2019 11:55 am x4000Bughunter Status new => resolved
Jun 20, 2019 11:55 am x4000Bughunter Resolution open => duplicate
Jun 20, 2019 11:55 am x4000Bughunter Fixed in Version => BETA 0.868 Fleet EXP Level-Ups and Starting Battlestations
Jun 20, 2019 11:55 am x4000Bughunter Note Added: 0051932