View Issue Details

IDProjectCategoryLast Update
0021218AI War 2[All Projects] Bug - GameplayMay 21, 2019 10:44 am
Reporterwm46Assigned ToBadgerBadger 
Severitymajor 
Status resolvedResolutionfixed 
Product VersionBETA 0.861 Strength Of Remains 
Fixed in VersionBETA 0.862 Lobby Overhaul, Knockback, Nanocaust, Final Battle 
Summary0021218: Normal waves are completely broken
DescriptionNormal waves never seem to spawn anymore, the only waves I can get to spawn in normal gameplay are reprisal waves.

CPAs work fine
The debug command to spawn a wave works too
The debug command to add wave budget doesn't help

To test, just make a campaign with a level 10 AI sentinel, set your AIP to 30 with increase AIP, and just wait. Nothing will happen.

Then send your fleet to any planet and let them die, a reprisal wave will spawn just fine in a few minutes.
TagsNo tags attached.

Activities

BadgerBadger

May 20, 2019 11:07 am

manager   ~0051703

I'll look into this tonight unless someone else wants to tackle it first

x4000Bughunter

May 20, 2019 11:20 am

administrator   ~0051704

Thanks, I appreciate it. I'm sure it was in the new struct that I added that I fouled up something. Diffing that one version and having a second pair of eyes on it ought to reveal it pretty quickly, I hope. Sorry about that!

BadgerBadger

May 21, 2019 10:44 am

manager   ~0051711

Actually this was a regression caused by my "Don't send a wave that's too weak" code. Fixed

Issue History

Date Modified Username Field Change
May 20, 2019 3:59 am wm46 New Issue
May 20, 2019 11:07 am BadgerBadger Assigned To => BadgerBadger
May 20, 2019 11:07 am BadgerBadger Status new => assigned
May 20, 2019 11:07 am BadgerBadger Note Added: 0051703
May 20, 2019 11:20 am x4000Bughunter Note Added: 0051704
May 21, 2019 10:44 am BadgerBadger Status assigned => resolved
May 21, 2019 10:44 am BadgerBadger Resolution open => fixed
May 21, 2019 10:44 am BadgerBadger Fixed in Version => BETA 0.862 Lobby Overhaul, Knockback, Nanocaust, Final Battle
May 21, 2019 10:44 am BadgerBadger Note Added: 0051711