View Issue Details

IDProjectCategoryLast Update
0020974AI War 2[All Projects] Bug - GameplayMar 8, 2019 9:27 pm
ReporterAnnoyingOrangeAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product Version0.816 Aggressive Busting and Stacking 
Fixed in VersionBETA 0.850 The Arrival of Fleets 
Summary0020974: Space and starship docks can no longer rally to a point.
DescriptionThe "rally" button correctly displays the red rally point, but clicking on a point does not result in the rally point being set.
Selecting the dock and right clicking on a point does not work either.


0020957: Setting dock to rally to a point does not work
Setting a dock to rally to a point on the system instead of a control group just straight up doesn't work.
It will say "Set rally order for ship(s) to no longer go to control group.", but the rally point isn't set; the rally tooltip continues to say "Currently not active". If there is a group rally point set, it is indeed cleared, but no point rally point is set.

I have tried right clicking while the dock is selected, clicking the rally button and left clicking, and clicking the rally button and right clicking. All of them have the same issue of no rally point being set.
TagsNo tags attached.

Relationships

duplicate of 0020957 resolvedx4000Bughunter Setting dock to rally to a point does not work 

Activities

wm46

Mar 6, 2019 9:09 pm

reporter   ~0050909

Rally works perfectly fine for me, on both the fleetship dock and the starship dock. I can point rally ships, switch to group rally, then switch back to point rally with no issues at all.

TechSY730

Mar 6, 2019 9:26 pm

reporter   ~0050911

This may be a platform specific thing. I am on Linux and am not able to rally to a point.

BadgerBadger

Mar 6, 2019 9:43 pm

manager   ~0050912

I am on linux and it worked fine for me last time I tried it.

AnnoyingOrange

Mar 7, 2019 3:38 am

reporter   ~0050916

I guess it's a Windows only issue, then

RocketAssistedPuffin

Mar 7, 2019 7:37 am

developer   ~0050919

I'm on Windows and it works. Huh.

TechSY730

Mar 7, 2019 4:57 pm

reporter   ~0050924

Well, let me attach a save where I can't rally.

Try setting a point rally for the space dock, building v-wings, and then watch them not rally.

1.save (1,018,776 bytes)

Jannik2099

Mar 8, 2019 5:08 am

reporter   ~0050931

Rally to point not working for me either, Windows10

Rally to control group does work, but it doesn't keep stuff like Pursuit mode enabled

DeathMetallic

Mar 8, 2019 7:51 am

reporter   ~0050933

Rally also not working for me. When I click the Rally flag it activates and the indicator appears in the world map for placement, but when I click to place (left or right click), it does not place the rally point/flag

DeathMetallic

Mar 8, 2019 7:52 am

reporter   ~0050934

** Windows 10 x64

DeathMetallic

Mar 8, 2019 7:55 am

reporter   ~0050935

Merged info from duplicate 0020957. Technically that one was made first but there seems to be more information in this ticket

x4000Bughunter

Mar 8, 2019 9:27 pm

administrator   ~0050951

This feature is going away in the next build anyhow (yes I know that sounds crazy, but it's actually way better -- whole new system), so this is implicitly fixed coming up. One of the many many things that was broken with the old system!

Issue History

Date Modified Username Field Change
Mar 6, 2019 1:32 pm AnnoyingOrange New Issue
Mar 6, 2019 1:56 pm TechSY730 Relationship added duplicate of 0020957
Mar 6, 2019 9:09 pm wm46 Note Added: 0050909
Mar 6, 2019 9:26 pm TechSY730 Note Added: 0050911
Mar 6, 2019 9:43 pm BadgerBadger Note Added: 0050912
Mar 7, 2019 3:38 am AnnoyingOrange Note Added: 0050916
Mar 7, 2019 7:37 am RocketAssistedPuffin Note Added: 0050919
Mar 7, 2019 4:57 pm TechSY730 File Added: 1.save
Mar 7, 2019 4:57 pm TechSY730 Note Added: 0050924
Mar 8, 2019 5:08 am Jannik2099 Note Added: 0050931
Mar 8, 2019 7:51 am DeathMetallic Note Added: 0050933
Mar 8, 2019 7:52 am DeathMetallic Note Added: 0050934
Mar 8, 2019 7:55 am DeathMetallic Description Updated View Revisions
Mar 8, 2019 7:55 am DeathMetallic Note Added: 0050935
Mar 8, 2019 9:27 pm x4000Bughunter Assigned To => x4000Bughunter
Mar 8, 2019 9:27 pm x4000Bughunter Status new => resolved
Mar 8, 2019 9:27 pm x4000Bughunter Resolution open => duplicate
Mar 8, 2019 9:27 pm x4000Bughunter Fixed in Version => BETA 0.850 The Arrival of Fleets
Mar 8, 2019 9:27 pm x4000Bughunter Note Added: 0050951