View Issue Details

IDProjectCategoryLast Update
0020908AI War 2[All Projects] Crash/ExceptionFeb 4, 2019 2:09 pm
ReporterQuicunqueAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.811 Transport Ships 
Fixed in Version0.812 Hunting Ninjas and Desyncs 
Summary0020908: Null Reference Exception
DescriptionI received the following error report (quoted below) after I made a new Hacker at my home system (Mesa) and sent it toward the Lorica system. I have no idea if the error had anything to do with my actions. I have included the pertinent portion of the ArcenDebugLog, and the most recent gamesave prior to the error report. The game continued to function as usual.

Error occurred in sim planning context specialFactionContext_2_AI
NullReferenceException
Object reference not set to an instance of an object
TagsNo tags attached.

Relationships

duplicate of 0020903 resolvedBadgerBadger Null Reference Exception in some faction related logic 

Activities

Quicunque

Feb 4, 2019 2:03 pm

reporter  

Qui1.save (1,047,043 bytes)
20190204133505 (5,703 bytes)
2/4/2019 1:35:05 PM	Current directory used: /home/ctrouten/.local/share/Steam/steamapps/common/AI War 2/
Process Count = 0 so PlayerDataDirectory used: /home/ctrouten/.local/share/Steam/steamapps/common/AI War 2/PlayerData/
2/4/2019 1:35:05 PM	Resolution changed to fullscreen 768x1024
2/4/2019 1:35:05 PM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
2/4/2019 1:35:05 PM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
2/4/2019 1:35:15 PM	ArcenAssetBundleCache.InstantiatedObjects: 777
2/4/2019 1:35:15 PM	Game Version: 0.811
graphicsDeviceType in use: OpenGLCore
graphicsDeviceVersion in use: OpenGL 4.5 (Core Profile) Mesa 18.2.2
graphicsMultiThreaded: False
graphicsShaderLevel: 50
operatingSystem: Linux 4.15 Ubuntu 18.04 64bit
graphicsDeviceName: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2) 
graphicsDeviceID: 22811
graphicsDeviceVendor: Intel Open Source Technology Center
graphicsDeviceVendorID: 32902
graphicsDeviceVersion: OpenGL 4.5 (Core Profile) Mesa 18.2.2
graphicsMemorySize: 512
maxTextureSize: 16384
npotSupport: Full
processorType: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
processorCount: 8
processorFrequency: 3695
systemMemorySize: 15792
supportsImageEffects: True
supportedRenderTargetCount: 8
supportsComputeShaders: True
supportsShadows: True
usesReversedZBuffer: False
2/4/2019 1:35:15 PM	10.8 seconds total load time.

LoadFinalSFXStuff (6.4s)
PlanetDefinitionTable (0.3s)
GameEntityTypeDataTable.InitVisualBits (1.4s)
SurrogateTableTable (0.4s)
2/4/2019 1:35:15 PM
Hello Steam user 'ctrouten'

  at System.Environment.get_StackTrace () [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at ArcenGameController.Update () [0x00000] in <2e2dcd579b104a688d65707e5c206ad7>:0 

2/4/2019 1:35:22 PM	Successfully opened host socket
2/4/2019 1:47:21 PM
Error occurred in sim planning context specialFactionContext_2_AI
NullReferenceException
Object reference not set to an instance of an object
===STACK FRAMES (with file info)===
FILE	METHOD	IL_OFFSET	NATIVE_OFFSET	LINE_NUMBER	COLUMN_NUMBER
	DoLongRangePlanning_OnBackgroundNonSimThread_Subclass	3155	6340	0	0
	DoLongRangePlanning_OnBackgroundNonSimThread	116	315	0	0
	Execute	33	106	0	0
	InnerRun	63	163	0	0
===RAW STACK TRACE===
  at Arcen.AIW2.External.SpecialFaction_AI.DoLongRangePlanning_OnBackgroundNonSimThread_Subclass (Arcen.AIW2.Core.Faction faction, Arcen.AIW2.External.ArcenLongTermIntermittentPlanningContext Context) [0x00c53] in <04947986abe7464b9bd27d59c5a80c38>:0 
  at Arcen.AIW2.External.BaseSpecialFaction.DoLongRangePlanning_OnBackgroundNonSimThread (Arcen.AIW2.Core.Faction faction, Arcen.AIW2.Core.ILongRangePlanningContext Context) [0x00074] in <04947986abe7464b9bd27d59c5a80c38>:0 
  at Arcen.AIW2.External.SpecialFactionPlanning.Execute () [0x00021] in <04947986abe7464b9bd27d59c5a80c38>:0 
  at Arcen.AIW2.External.ArcenSimPlanningContext.InnerRun () [0x0003f] in <04947986abe7464b9bd27d59c5a80c38>:0 

  at System.Environment.get_StackTrace () [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.Universal.ArcenDebugging.LogException (System.Exception e, System.String message, Arcen.Universal.Verbosity verbosity) [0x00000] in <371fc104c94a4724860239623ea95520>:0 
  at Arcen.AIW2.External.ArcenSimPlanningContext.InnerRun () [0x00000] in <04947986abe7464b9bd27d59c5a80c38>:0 
  at Arcen.AIW2.External.ArcenThread.InternalActualThreadFunction () [0x00000] in <04947986abe7464b9bd27d59c5a80c38>:0 
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 
  at System.Threading.ThreadHelper.ThreadStart () [0x00000] in <f826c2584fc94ec19a48a6576640bdc5>:0 

20190204133505 (5,703 bytes)

Quicunque

Feb 4, 2019 2:08 pm

reporter   ~0050772

This might be the same as 0020903, or related to it.

BadgerBadger

Feb 4, 2019 2:09 pm

manager   ~0050773

I would assume this is another instance of 0020903; If it's not then the next release will also include a bunch of debugging code in this area, so we'll get a clearer error message.

BadgerBadger

Feb 4, 2019 2:09 pm

manager   ~0050774

If you hit this again on the next build, open a new ticket.

Issue History

Date Modified Username Field Change
Feb 4, 2019 2:03 pm Quicunque New Issue
Feb 4, 2019 2:03 pm Quicunque File Added: 20190204133505
Feb 4, 2019 2:03 pm Quicunque File Added: Qui1.save
Feb 4, 2019 2:08 pm Quicunque Note Added: 0050772
Feb 4, 2019 2:09 pm BadgerBadger Note Added: 0050773
Feb 4, 2019 2:09 pm BadgerBadger Assigned To => BadgerBadger
Feb 4, 2019 2:09 pm BadgerBadger Status new => resolved
Feb 4, 2019 2:09 pm BadgerBadger Resolution open => fixed
Feb 4, 2019 2:09 pm BadgerBadger Fixed in Version => 0.812 Hunting Ninjas and Desyncs
Feb 4, 2019 2:09 pm BadgerBadger Note Added: 0050774
Feb 4, 2019 2:09 pm BadgerBadger Relationship added duplicate of 0020903