View Issue Details

IDProjectCategoryLast Update
0020872AI War 2[All Projects] Bug - GameplayMar 20, 2019 5:55 pm
ReporterKahunaAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionno change required 
Product Version0.809 Divide By Human 
Fixed in VersionBETA 0.850 The Arrival of Fleets 
Summary0020872: Game selects wrong bonus ship
DescriptionWhen starting a new game the game remember which bonus ship I chose last time. In screenshot A last time I started a game I chose Raptors so the game remembers it. However when I start a game the game chooses wrong bonus ship as you can see in screenshot B. To work around this issue the player has to change the Raptor to some other ship and then to Raptor again to actually get Raptor as bonus ship.

Steps to reproduce
-Start a game with bonus ship X
-Start a new game without changing the bonus ship (so it still says X)
-Have Pike Corvettes chosen as your bonus ship (it always seems to be Pike Corvette)
TagsNo tags attached.

Activities

Kahuna

Dec 28, 2018 5:04 am

reporter  

A.jpg (314,529 bytes)
B.jpg (361,443 bytes)

BadgerBadger

Dec 29, 2018 6:38 pm

manager   ~0050689

This is a generic problem with the current dropdown menus. You can see it when choosing map subtypes as well. Probably waiting on Chris' lobby overhaul like any number of other issues.

RocketAssistedPuffin

Mar 20, 2019 5:55 pm

developer   ~0051006

Bonus ship choices are going the way of the dodo in 0.900.

Issue History

Date Modified Username Field Change
Dec 28, 2018 5:04 am Kahuna New Issue
Dec 28, 2018 5:04 am Kahuna File Added: A.jpg
Dec 28, 2018 5:04 am Kahuna File Added: B.jpg
Dec 29, 2018 2:23 pm Dune Assigned To => x4000Bughunter
Dec 29, 2018 2:23 pm Dune Status new => acknowledged
Dec 29, 2018 6:38 pm BadgerBadger Note Added: 0050689
Mar 20, 2019 5:55 pm RocketAssistedPuffin Status acknowledged => closed
Mar 20, 2019 5:55 pm RocketAssistedPuffin Resolution open => no change required
Mar 20, 2019 5:55 pm RocketAssistedPuffin Fixed in Version => BETA 0.850 The Arrival of Fleets
Mar 20, 2019 5:55 pm RocketAssistedPuffin Note Added: 0051006