View Issue Details

IDProjectCategoryLast Update
0020807AI War 2[All Projects] Bug - GameplayAug 11, 2019 1:34 pm
Reporterwm46Assigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.807 Cyber Command 
Fixed in Version0.881 AI Neighborhood Watch 
Summary0020807: Dark Spire energy harvest doesn't seem to function correctly
DescriptionIn the harvest ratio xml, its said that the harvest ratio for the dark spire is supposed to be a multiplication of the strength of the ship by two ratios. There seem to be discrepancies however, when the nanocaust kills AI units (0.5x AI Death, 0.5x Nanocaust kill), the dark spire doesn't charge at all.
TagsNo tags attached.

Activities

wm46

Dec 12, 2018 10:28 pm

reporter   ~0050605

New information: The bug doesn't seem to be related to the harvest ratio's at all. I have a save game with DarkSpire Diff 10, Nanocaust Diff 10, AI Diff 8, and none of the Dark Spires in this galaxy are generating charge

Save game uploaded here since I can't use your inline uploader: https://www.mediafire.com/file/15rh0181982x282/Joffrey_Jonesey.zip/file

wm46

Dec 12, 2018 10:29 pm

reporter   ~0050606

I can tell it wasn't related to the harvest ratios themselves because for this campaign I increased every harvest ratio to 1.5x of normal (2.25x harvest ratio increase)

wm46

Dec 16, 2018 10:20 pm

reporter   ~0050622

The modded XML files for this save: http://www.mediafire.com/file/xe6z8tcas5tcwp7/GameEntity.zip/file

BadgerBadger

Dec 16, 2018 10:54 pm

manager   ~0050623

Can you reproduce the problem without your mods?

BadgerBadger

Aug 11, 2019 1:34 pm

manager   ~0052535

This code has seen some very significant rework since the bug was opened. If this is still a problem please open a new ticket.

Issue History

Date Modified Username Field Change
Nov 30, 2018 4:35 am wm46 New Issue
Dec 4, 2018 4:27 pm Dune Assigned To => x4000Bughunter
Dec 4, 2018 4:27 pm Dune Status new => acknowledged
Dec 12, 2018 10:28 pm wm46 Note Added: 0050605
Dec 12, 2018 10:29 pm wm46 Note Added: 0050606
Dec 16, 2018 10:20 pm wm46 Note Added: 0050622
Dec 16, 2018 10:54 pm BadgerBadger Note Added: 0050623
Aug 11, 2019 1:34 pm BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Aug 11, 2019 1:34 pm BadgerBadger Status acknowledged => resolved
Aug 11, 2019 1:34 pm BadgerBadger Resolution open => fixed
Aug 11, 2019 1:34 pm BadgerBadger Fixed in Version => 0.881 AI Neighborhood Watch
Aug 11, 2019 1:34 pm BadgerBadger Note Added: 0052535