View Issue Details

IDProjectCategoryLast Update
0020762AI War 2[All Projects] Gameplay IssueNov 27, 2018 10:04 am
ReporterAvenger1649Assigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.806 Sabre Company 
Fixed in Version0.807 Cyber Command 
Summary0020762: Allied Marauders STILL Stack
DescriptionI've been playing through the 'Subverted' campaign using the newest update 'Sabre Company', which included a fix by the moderator BadgerBadger to stop the Marauder Outpost stacks on friendly worlds, so that they wouldn't drastically overpopulate and crash the game.

Unfortunately, that fix seems not to apply.

The neutral Marauder outposts have been capped at 7 on their worlds when they are allied to me, which is good and shows that the fix WAS implemented. However, the Marauders on my worlds STILL STACK, at least to over 20 Outposts (my home world has 24 Outposts currently), which is a problem, since this will happen on all of my worlds and means major lag and a crash in all but inevitable.

This needs to be remedied please if a cap on allied Marauder Outposts is to be implemented, I would suggest capping them at 10 Outposts (the old cap for Mark III Outposts).

Here are some files from my latest game, so you can see exactly where this fix is going wrong. Maybe its just a bug in that specific campaign mode, but it seems to me that the fix Badger implemented doesn't work properly.
TagsNo tags attached.

Activities

Avenger1649

Nov 10, 2018 10:49 am

reporter  

Autosave.13500.save (2,100,219 bytes)
Autosave.14400.save (2,230,171 bytes)
Nanites Hacked.save (2,736,548 bytes)

Dominus Arbitrationis

Nov 12, 2018 11:41 am

administrator   ~0050471

Just to verify, did you start the game in a previous update, then continue it in the new one? That may be the cause of some issues. Also, the number of outposts per planet can be customized in the XML files, so feel free to change it to whatever you like.

RocketAssistedPuffin

Nov 12, 2018 12:53 pm

developer   ~0050472

It's not to do with the number of outposts in the file, I believe. The Marauders are simply ignoring the cap entirely on friendly planets. I've had this as well.

Also ignoring the drone cap...I'll make a separate report for that soon. Funny to see over 20k ships from them alone, though.

Avenger1649

Nov 14, 2018 12:04 pm

reporter   ~0050480

Dominus Abitrationis.

I started with the current update at the time, which included Badger's fix, I made sure.
Also, I didn't realise I could edit the number of outposts per planet manually. Considering what happened last time I tried editing game files, though, it won't work for me or the game will break and I'll have to re-install.

Dominus Arbitrationis

Nov 15, 2018 5:55 pm

administrator   ~0050485

Hm okay. I'm not sure what could be causing this, so I'll leave it for Badger or someone else to fix, unless I suddenly get inspired.

Dominus Arbitrationis

Nov 20, 2018 8:59 am

administrator   ~0050514

It appears to be an issue with numOutposts, since that always returns either 1 or 2 in my testing.

BadgerBadger

Nov 20, 2018 12:11 pm

manager   ~0050515

Last edited: Nov 20, 2018 12:51 pm

View 3 revisions

Whenever I recompile my dev build it breaks, and I can't figure out why. So I'm currently pretty stuck at the moment, and I'm travelling so I can't test it.

That said, I'm pretty sure I know what's happening now, thanks to the "numOutposts is always 1 or 2" comment; C# is not being C++.

Here's a proposed fix; Dominus, give it a test and see if it works.
In HumanMarauders.cs, look at the AddOrUpgradeOutposts() function.
In a number of places, I do something like

                        MarauderOutpostData outpost = outpostData[entity.Planet];
                        outpost.numOutposts++;

Those two lines are a problem. Replace them everywhere with this line

outpustData[entity.Planet].numOutposts++;


EDIT: Per Dominus, that didn't work. Whoops. Back to the drawing board

Dominus Arbitrationis

Nov 20, 2018 2:36 pm

administrator   ~0050516

Nope. That throws the error I mentioned in Discord.

BadgerBadger

Nov 27, 2018 10:04 am

manager   ~0050557

Finally fixed this one!

Issue History

Date Modified Username Field Change
Nov 10, 2018 10:49 am Avenger1649 New Issue
Nov 10, 2018 10:49 am Avenger1649 File Added: Autosave.13500.save
Nov 10, 2018 10:49 am Avenger1649 File Added: Nanites Hacked.save
Nov 10, 2018 10:49 am Avenger1649 File Added: Autosave.14400.save
Nov 11, 2018 1:18 pm BadgerBadger Assigned To => BadgerBadger
Nov 11, 2018 1:18 pm BadgerBadger Status new => assigned
Nov 12, 2018 11:41 am Dominus Arbitrationis Note Added: 0050471
Nov 12, 2018 12:53 pm RocketAssistedPuffin Note Added: 0050472
Nov 14, 2018 12:04 pm Avenger1649 Note Added: 0050480
Nov 15, 2018 5:54 pm Dominus Arbitrationis Note View State: 0050472: private
Nov 15, 2018 5:54 pm Dominus Arbitrationis Note View State: 0050472: public
Nov 15, 2018 5:54 pm Dominus Arbitrationis Note View State: 0050480: public
Nov 15, 2018 5:55 pm Dominus Arbitrationis Note Added: 0050485
Nov 20, 2018 8:59 am Dominus Arbitrationis Note Added: 0050514
Nov 20, 2018 12:11 pm BadgerBadger Note Added: 0050515
Nov 20, 2018 12:50 pm BadgerBadger Note Edited: 0050515 View Revisions
Nov 20, 2018 12:51 pm BadgerBadger Note Edited: 0050515 View Revisions
Nov 20, 2018 2:36 pm Dominus Arbitrationis Note Added: 0050516
Nov 27, 2018 10:04 am BadgerBadger Status assigned => resolved
Nov 27, 2018 10:04 am BadgerBadger Resolution open => fixed
Nov 27, 2018 10:04 am BadgerBadger Fixed in Version => 0.807 Cyber Command
Nov 27, 2018 10:04 am BadgerBadger Internal Weight => New
Nov 27, 2018 10:04 am BadgerBadger Note Added: 0050557