View Issue Details

IDProjectCategoryLast Update
0020658AI War 2[All Projects] Gameplay IssueJun 5, 2020 12:39 pm
ReporterStormingKiwiAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionnot fixable 
Product Version0.804 Hack Me Quickly 
Fixed in Version 
Summary0020658: Group Movement Not Ideal
DescriptionWhen I group a selection of ships, I want all ships to keep together and move together as a unit, to engage targets in similar locales and protect each other on FRD. I don't want units to try soloing stuff and suiciding. In other words, I want to create a fleet which acts as a coherent unit, and I don't want units to all travel at the same speed all the time.

Let's say you are reinforcing unit A with unit B, which are faster but further away from where you want them to go, then unit B will be slowed down as they travel to unit A. Further the mode doesn't help out with e.g. shield starships, because there is no way to make the shield starship a part of a formation.
TagsNo tags attached.

Activities

BadgerBadger

Oct 21, 2018 10:43 am

manager   ~0050199

How do you suggest that units that move at different speeds should "move as a group" without moving at the speed of the slowest unit?

StormingKiwi

Oct 21, 2018 12:20 pm

reporter   ~0050200

I mean units should move as a group and stick together.

I suggest looking at the way Stardock does it, because the way fleets/armies work in their games is more what I expect.

Scenario:

If my Assault Starship spee d (600) is moving with my Ark (speed 400) and my Plasma Siege Starship (400), and they are together, I want them to move in formation. I.e. I want my Assault starship to remain in proximity to the Plasma Siege Starship.

Let's say you put them in Pursuit Mode.

Now the Assault Starship will pick a target and the PSS/Ark will pick a different target. They will head in two separate directions. Now they are no longer moving as a group, they are each doing their own thing individually. I want them to act as one coherent unit and move to similar places while attacking similar targets.

See attached screenshot: Pursuit and Group Move . You can clearly see that my Assault Starship, which is still in group move with my PSS, is further away from where I want it to move to. That means it will travel at speed 400, the speed of the slowest unit. However, it is further away from the target location, so it could move at its full speed of 600.

Further once they are together, I put them back into Pursuit mode, and my assault starship picks a target, my PSS picks a target, and both immediately starts travelling at 90° to the direction of the other because that's the geometry of the targets. What I want them to do is coordinate and be coherent, so that they don't go across the gravity well and solo one target that they could have taken on together. It's also a problem with fleet-ship swarms.

See screenshot: Different Targets

The issue is that units of different speeds don't move in a coordinated and coherent manner, and this rather detracts from the automation tool. I feel that units which stick together have increased chances of survival.

Pursuit and Group Move.png (125,990 bytes)
Pursuit and Group Move.png (125,990 bytes)
Different Targets.png (224,474 bytes)
Different Targets.png (224,474 bytes)

Dune

Oct 23, 2018 12:08 pm

administrator   ~0050263

Thank you for the suggestion on improving group actions.

x4000Bughunter

Jun 5, 2020 12:39 pm

administrator   ~0057187

We've made some adjustments to this to be better, but overall it's not something that fits with the style of how the units work.

Issue History

Date Modified Username Field Change
Oct 21, 2018 3:17 am StormingKiwi New Issue
Oct 21, 2018 10:43 am BadgerBadger Note Added: 0050199
Oct 21, 2018 12:20 pm StormingKiwi File Added: Pursuit and Group Move.png
Oct 21, 2018 12:20 pm StormingKiwi File Added: Different Targets.png
Oct 21, 2018 12:20 pm StormingKiwi Note Added: 0050200
Oct 23, 2018 12:08 pm Dune Assigned To => x4000Bughunter
Oct 23, 2018 12:08 pm Dune Status new => acknowledged
Oct 23, 2018 12:08 pm Dune Note Added: 0050263
Jun 5, 2020 12:39 pm x4000Bughunter Status acknowledged => closed
Jun 5, 2020 12:39 pm x4000Bughunter Resolution open => not fixable
Jun 5, 2020 12:39 pm x4000Bughunter Note Added: 0057187