View Issue Details

IDProjectCategoryLast Update
0020619AI War 2[All Projects] SuggestionDec 26, 2018 8:52 pm
ReporterKeniraAssigned ToBadgerBadger 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.804 Hack Me Quickly 
Fixed in Version0.810 
Summary0020619: Flashy combat
DescriptionIt's not a bug per se, but an issue with the graphics. Forgive me if this has been adressed, i tried searching for it:

As an autistic person, combat is extremely visually overwhelming. I would love to have a graphics option where you could make it so ships shooting is much less noticeable, otherwise this one issue makes me unable to play the game at all.

An example for how to improve it: The first game did it perfectly, or some might say it was the other extreme, but by comparing the games the difference / what i mean by visually overwhelming should be obvious.

To be a bit more specific about changes that would help make combat less visually overwhelming:
a) less colourful shots / shooting trails
b) smaller shots / shooting trails
c) less flashing

The first game may be not the best example because arguably you didn't see *enough* happening in combat there (even though personally i liked how it was), but right now the second game definitely takes it to the other extreme.
And i know most people either won't be bothered by it as much, if at all, but for some people, and i believe i can speak for many autistic people for a start, this can be extremely overloading and actually a big problem. Personally as said this makes me unable to play the game at all.

And again, i am not saying the default graphics needs to change, but just an additional option to tune things down by a lot would be very helpful for the people who want / need it less flashy. As a side effect, that may even help with the performance of big battles some as well?
TagsNo tags attached.

Activities

RocketAssistedPuffin

Oct 19, 2018 4:31 pm

developer   ~0050158

Last edited: Oct 19, 2018 4:39 pm

View 2 revisions

I'm autistic myself, but weirdly am not affected by this game. Still, it's a fair problem, and I understand it.

While I don't have the skill or ability to make new shot types for this option, it is possible to...I think change some of it for you, as a custom file set (it's just a copy/paste!). That is, if you don't mind not really seeing shots at all (there's a type that has no visual I can apply to most things. For some units that I think won't work, I can ban the AI from getting those, so you won't see them in large numbers, and do things like making them attack half as fast, etc. It's not perfect, but it'd maybe let you play the game).

If that sounds good enough, I can try it. It wouldn't take super long, though I'd have to make an updated version for you with each update, else you'll be stuck using old combat stuff. It's fairly simple to do, though.

EDIT: Even the things I thought wouldn't work, do. You'd hear the same sound over and over, but there's something in the options menu to disable the weapon sounds. I can't change the explosion visual, but that seems fairly hidden, but don't know if it's enough for you.

Kenira

Oct 19, 2018 4:55 pm

reporter   ~0050160

Thank you so much!

Making shots completely invisible would work too, i understand that making separate effects is extra work, and just flat out removing effects would still allow me to play the game and probably not be a big handicap. I don't know what units you referred to that would still keep the animations, so i don't know how bad that would still be, but most of the units not using them anymore may already be enough to allow me to play the game, but i can't say for sure.

Disabling weapon sounds i also wouldn't mind very much.

RocketAssistedPuffin

Oct 19, 2018 5:30 pm

developer   ~0050163

Okidoki, I'll get working on that.

As for the units I referred to, I thought some of their effects was actually tied to their visual (Tesla, specifically) but it's not, just a personal derp.

When it's done I'll upload it here for you, with the relevant instructions (which is simple).

RocketAssistedPuffin

Oct 19, 2018 6:00 pm

developer   ~0050166

Okay, here it is. You just download this, extract it, then go to the game in your Steam Library, right-click the name, click Properties, then Local Files, then Browse Local Files at the top.

Then go into GameData, then Configuration, and you'll see a folder called GameEntity. Delete the one in the game, and COPY the new one in. I say copy, because when an update releases, it'll override your version, and it'll go back to having shot visuals.

Weapons that fire a beam are still showing, but it's very thin. Sadly, I don't think i can get rid of ships doing their explosions on death, either.

GameEntity.zip (70,135 bytes)

Kenira

Oct 19, 2018 7:10 pm

reporter   ~0050169

Thank you so much :) You're awesome!

I have only barely started a game (1h into it) so i can't speak with certainty about big end game battles yet, but it does look like i can play it now. The beams probably aren't much of an issue, and i think i can deal with the explosions as well. It is orders of magnitude better now, that's for sure. I'll post again with more precise feedback when i've played some more during the weekend and have more experience playing.

Kenira

Oct 21, 2018 12:44 pm

reporter   ~0050201

After completing my first game (and winning) i can confirm that i can now play without issues :)
Thanks again.

Apthorpe

Oct 21, 2018 9:35 pm

reporter   ~0050211

I'm not autistic but have also had issues with the visuals of combat being irritating and even headache-inducing, so that I have to avoid zooming in to make it tolerable. This especially a problem when there's a high volume of fire onscreen. I think the tesla effect is the worst offender. I would recommend that the devs include options for toning down the combat visuals, especially the lighting effects. It may even be advisable to tone them down for the default.

UFO

Oct 22, 2018 1:12 pm

reporter   ~0050227

I totally agree with Apthorpe, same problem.

Exlium

Oct 22, 2018 6:02 pm

reporter   ~0050228

the flak effect and the tesla are literally blinding.

Dune

Oct 22, 2018 10:15 pm

administrator   ~0050233

Have the suggested changes RocketAssistedPuffin tamped things down enough, or should this case be kept open for review at some point?

Kenira

Oct 23, 2018 2:49 am

reporter   ~0050237

For me at least, the ideal solution would still be to have some effects because having no effects at all does make the game harder because you simply have no idea who is shooting or getting shot at. As i mentioned originally, effects similar to the first game would be a great example for a compromise between still seeing shots but them not being overwhelming, and that would still be the best solution since they would also avoid the handicap of not seeing shots at all.

Considering i'm not the only one having problems with the visuals, i would still be curious if that's something that might be considered down the line. This fix, as much as i appreciate it and as useful as it is to make the game playable, is still going a bit overboard.

Kenira

Oct 23, 2018 2:52 am

reporter   ~0050238

Also, explosion effects can still be moderately visually exhausting, although for me they are not as much of an issue as either not seeing any shots at all with the current fix, or them being too overwhelming without the fix.

RocketAssistedPuffin

Oct 23, 2018 6:30 am

developer   ~0050241

New one here, just containing some...of the balance stuff, so you have an up to date one. Won't be making any more changes in that area for the next release.

This should probably be kept open - I have to do this manually every time, and not everyone with such an issue will see this. Flak and Tesla can be a bit...lightshowy.

Incidentally, I know it was assigned to me but...I actually have no ability to do the C# or shot visual work for this - this was temporary just so they could play right now.

GameEntity-2.zip (70,114 bytes)

Kenira

Dec 25, 2018 8:21 am

reporter   ~0050659

I just wrote myself a Python script to remove the visuals myself. If anyone else wants it, i could upload it somewhere, assuming that's okay with the devs.

BadgerBadger

Dec 26, 2018 12:48 am

manager   ~0050660

I can give settings to disable explosions and shot visualizations entirely; will that do?

Kenira

Dec 26, 2018 10:58 am

reporter   ~0050661

That would work too.

BadgerBadger

Dec 26, 2018 8:52 pm

manager   ~0050664

I've added two new Settings to the Display section to allow you to explicitly disable Shot visuals and Explosion visuals. Let me know if that does the trick for you.

Issue History

Date Modified Username Field Change
Oct 18, 2018 3:05 pm Kenira New Issue
Oct 19, 2018 4:31 pm RocketAssistedPuffin Note Added: 0050158
Oct 19, 2018 4:39 pm RocketAssistedPuffin Note Edited: 0050158 View Revisions
Oct 19, 2018 4:55 pm Kenira Note Added: 0050160
Oct 19, 2018 5:30 pm RocketAssistedPuffin Note Added: 0050163
Oct 19, 2018 6:00 pm RocketAssistedPuffin File Added: GameEntity.zip
Oct 19, 2018 6:00 pm RocketAssistedPuffin Note Added: 0050166
Oct 19, 2018 7:10 pm Kenira Note Added: 0050169
Oct 21, 2018 12:44 pm Kenira Note Added: 0050201
Oct 21, 2018 9:35 pm Apthorpe Note Added: 0050211
Oct 22, 2018 1:12 pm UFO Note Added: 0050227
Oct 22, 2018 6:02 pm Exlium Note Added: 0050228
Oct 22, 2018 10:15 pm Dune Assigned To => RocketAssistedPuffin
Oct 22, 2018 10:15 pm Dune Status new => considering
Oct 22, 2018 10:15 pm Dune Note Added: 0050233
Oct 23, 2018 2:49 am Kenira Note Added: 0050237
Oct 23, 2018 2:52 am Kenira Note Added: 0050238
Oct 23, 2018 6:30 am RocketAssistedPuffin File Added: GameEntity-2.zip
Oct 23, 2018 6:30 am RocketAssistedPuffin Note Added: 0050241
Dec 25, 2018 8:21 am Kenira Note Added: 0050659
Dec 26, 2018 12:43 am BadgerBadger Assigned To RocketAssistedPuffin => BadgerBadger
Dec 26, 2018 12:48 am BadgerBadger Note Added: 0050660
Dec 26, 2018 10:58 am Kenira Note Added: 0050661
Dec 26, 2018 8:52 pm BadgerBadger Status considering => resolved
Dec 26, 2018 8:52 pm BadgerBadger Resolution open => fixed
Dec 26, 2018 8:52 pm BadgerBadger Fixed in Version => 0.810
Dec 26, 2018 8:52 pm BadgerBadger Note Added: 0050664