View Issue Details

IDProjectCategoryLast Update
0020539AI War 2[All Projects] Balance IssueOct 30, 2018 5:49 pm
ReporterExliumAssigned ToRocketAssistedPuffin 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.801 Hotfix 
Fixed in Version0.805 Mercs, Hacks, and, Drones, Oh My 
Summary0020539: AI Super Terminal seems over tuned
DescriptionI had only reduced the ai progress by about 3 or 4, and they had already spawned 500 strength worth of ships. Not to mention the salvage I'm getting from capturing the planet is extremely miniscule for how many ships I'm destroying. For reference I started hacking at about 0.7 AI response level and now it's at 4. I don't think it's supposed to spike that hard, or at least it should lower the progress faster if it's going to do that. I'll include an image of the crazy stack size generated.
TagsNo tags attached.

Activities

Exlium

Oct 15, 2018 9:41 pm

reporter  

AIWar2_2018-10-15_21-35-06.png (1,319,587 bytes)

Ovalcircle

Oct 15, 2018 10:04 pm

reporter   ~0050063

Wow. A stack of 994. I think that's a new record.

RocketAssistedPuffin

Oct 16, 2018 5:48 am

developer   ~0050065

Do you have a save of this, just before you started the hack?

BadgerBadger

Oct 16, 2018 8:02 am

manager   ~0050068

puffin, feel free to smite the hacking response in the xml

RocketAssistedPuffin

Oct 16, 2018 8:25 am

developer   ~0050071

That was the intent. Would just like to know the general settings for this case.

BadgerBadger

Oct 16, 2018 8:49 am

manager   ~0050072

hacking_cost_per_second="1"
        effect_per_second="0.5"
        hack_duration="-1"
        hacking_response_interval="10"
        response_strength_per_interval="1.0"
        cost_in_hacking_points="20"
        response_strength_on_completion="2.0"

so it's going to drop a full wave on you every 10 seconds. Note that this hack is actually a bit stronger because the C# hacking management code will make each subsequent wave a bit stronger, though that isn't represented in the XML because I was in a hurry.

RocketAssistedPuffin

Oct 16, 2018 9:04 am

developer   ~0050073

Last edited: Oct 16, 2018 9:06 am

View 3 revisions

Oh no, I meant the settings for their game, not the hacking. I've already looked at the hacking stuff before. Knowing what the Difficulty is, the waves etc would be useful.

Though I didn't know it got stronger each time, thanks.

BadgerBadger

Oct 16, 2018 10:03 am

manager   ~0050075

Puffin, see my comments in discord

Exlium

Oct 16, 2018 12:53 pm

reporter   ~0050081

my last save was after the hack else I would have just included that. The settings were just the basic quick start difficulty 6 vanilla. and like I said I started with a 0.7 hacking response.

RocketAssistedPuffin

Oct 16, 2018 1:51 pm

developer   ~0050087

Right, thanks anyway. There's some internal discussion on how Hacking should function, so it might work differently in a major way.

BadgerBadger

Oct 16, 2018 2:03 pm

manager   ~0050088

It's going to function the same way from the player's point of view (you start hacking, the AI attacks you), but there will be some modifications on how it works internally to help with balance and making a hack more interesting.

Kenira

Oct 23, 2018 8:45 am

reporter   ~0050248

I'm also not sure if the response i'm getting is quite normal.
To be fair, I'm at 460 AIP, Hacking response 4.0. But after 5 AIP ticks down the enemy fleet reaches 1000 strength already and i'm completely overwhelmed despite my full fleet, turrets built, and 5 golems. That i'm basically completely unable to use the super terminal feels a bit off.
Here's a savegame with everything set up for the hacking.

20181023143951_1.jpg (474,040 bytes)
02_011.save (1,371,233 bytes)
02_011.savemet (53 bytes)

RocketAssistedPuffin

Oct 23, 2018 9:29 am

developer   ~0050249

Last edited: Oct 23, 2018 9:30 am

View 2 revisions

* Super Terminal hacking AIP reduction now works as reducing your AIP by 15 every response interval, which is 30s, resulting somewhat in a 0.5 AIP reduction per second. Also slightly weaker responses.
** Slight error somewhere in how it works it seems, so this makes the reduction more or less work as intended.

It was meant to reduce by 0.5 every second, but for some reason that's not...working, was only doing it every response interval (30s).

Dune

Oct 23, 2018 10:26 am

administrator   ~0050250

Puffin - Is this essentially fixed for now even though the underlying issue might still exist ( and needs to be addressed at some point later )?

RocketAssistedPuffin

Oct 23, 2018 10:36 am

developer   ~0050253

Might be - I tried that save with the changes and the AIP lowers at a much more reasonable rate, the response is still nasty but it is one of the worst case scenarios.

Higher difficulties it'll be much more painful, but the strength values it uses as the "starting line" are already absurdly low. Otherwise...I guess it is sort of fixed, need feedback on it - Steam Discussions will likely mention it.

RocketAssistedPuffin

Oct 30, 2018 5:49 pm

developer   ~0050386

This was resolved properly last update.

Issue History

Date Modified Username Field Change
Oct 15, 2018 9:41 pm Exlium New Issue
Oct 15, 2018 9:41 pm Exlium File Added: AIWar2_2018-10-15_21-35-06.png
Oct 15, 2018 10:04 pm Ovalcircle Note Added: 0050063
Oct 16, 2018 5:48 am RocketAssistedPuffin Note Added: 0050065
Oct 16, 2018 8:02 am BadgerBadger Note Added: 0050068
Oct 16, 2018 8:25 am RocketAssistedPuffin Note Added: 0050071
Oct 16, 2018 8:49 am BadgerBadger Note Added: 0050072
Oct 16, 2018 9:04 am RocketAssistedPuffin Note Added: 0050073
Oct 16, 2018 9:05 am RocketAssistedPuffin Note Edited: 0050073 View Revisions
Oct 16, 2018 9:06 am RocketAssistedPuffin Note Edited: 0050073 View Revisions
Oct 16, 2018 10:03 am BadgerBadger Note Added: 0050075
Oct 16, 2018 12:53 pm Exlium Note Added: 0050081
Oct 16, 2018 1:51 pm RocketAssistedPuffin Note Added: 0050087
Oct 16, 2018 2:03 pm BadgerBadger Note Added: 0050088
Oct 23, 2018 8:45 am Kenira File Added: 20181023143951_1.jpg
Oct 23, 2018 8:45 am Kenira File Added: 02_011.save
Oct 23, 2018 8:45 am Kenira File Added: 02_011.savemet
Oct 23, 2018 8:45 am Kenira Note Added: 0050248
Oct 23, 2018 9:29 am RocketAssistedPuffin Note Added: 0050249
Oct 23, 2018 9:30 am RocketAssistedPuffin Note Edited: 0050249 View Revisions
Oct 23, 2018 10:26 am Dune Assigned To => RocketAssistedPuffin
Oct 23, 2018 10:26 am Dune Status new => assigned
Oct 23, 2018 10:26 am Dune Note Added: 0050250
Oct 23, 2018 10:36 am RocketAssistedPuffin Note Added: 0050253
Oct 30, 2018 5:49 pm RocketAssistedPuffin Status assigned => resolved
Oct 30, 2018 5:49 pm RocketAssistedPuffin Resolution open => fixed
Oct 30, 2018 5:49 pm RocketAssistedPuffin Fixed in Version => 0.805 Mercs, Hacks, and, Drones, Oh My
Oct 30, 2018 5:49 pm RocketAssistedPuffin Note Added: 0050386