View Issue Details

IDProjectCategoryLast Update
0020495AI War 2[All Projects] GUIOct 14, 2018 8:04 pm
ReporterBobtreeAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.783 Go Ahead And Shoot Me, Eyebot! 
Fixed in Version0.785 Controls Viewing And Editing 
Summary0020495: Many tab category bugs
DescriptionLabels drawn underneath some category headers (Beginner Tips in screenshot). These sometimes change when categories get collapsed or opened, appearing under new categories.

Stuff in the wrong categories (Critical Capturables and Critical Destructables in screenshot). Some of these move around when categories are collapsed or opened.

Categories that disappear when I collapse a different one. Closing Critical Destructables removes the Beginner tips, but still shows the wrong Hack entries. Closing Critical Capturables hides the Destructables AND Beginner tips, but then shows more wrong Destructables instead of Hacks.

Different saved games have different combinations of the above issues, in terms of which categories or labels are buggy. The ones below Beginner Tips in Objectives always work normally.

Enemy ship icons don't disappear when collapsed in the Ships tab.

"Mercenaries for Hire (4)" becomes "No Mercenaries Available" when collapsed.

I'm running at 2560 x 1440, but see the exactly same issues at lower resolutions.
TagsNo tags attached.

Relationships

parent of 0020505 resolvedDominus Arbitrationis Enemy ship icons don't disappear when collapsed in the Ships tab. 
parent of 0020507 resolvedDominus Arbitrationis "Mercenaries for Hire (4)" becomes "No Mercenaries Available" when collapsed. 

Activities

Bobtree

Oct 13, 2018 12:24 pm

reporter  

TabCategoryBugs.png (221,310 bytes)
TabCategoryBugs.png (221,310 bytes)

BadgerBadger

Oct 13, 2018 12:26 pm

manager   ~0049925

Do you have a save game that would allow for consistent recreation? Or does the problem only occur after playing for a while?

Bobtree

Oct 13, 2018 12:48 pm

reporter   ~0049926

It happens all the time, new games, old saves, but for different categories in the Objectives tab. I do see buggy categories below Beginner Tips on a new campaign, so maybe which ones are having issues is dependent on how they are currently populated or in what sequence the objectives were added. The Objectives tab can be buggy immediately, though usually it starts out looking normal.

x4000Bughunter

Oct 13, 2018 9:13 pm

administrator   ~0049953

I'll be curious if you still see this in the new version 0.784 that I'm about to push out. It's not explicitly trying to fix this issue (which I've not seen first-hand, but someone else also mentioned it IIRC), but it fixes a number of issues that are close to it. So it might have been fixed in the crossfire.

Bobtree

Oct 14, 2018 1:15 am

reporter   ~0049954

It's still buggy. I've noticed that the first time I load a save after launching AIW2 the Objectives tab works perfectly, but then it gets jumbled up on successive loads. This makes me suspect something like objects pooled for reuse that aren't being fully cleaned up or re-initialized properly or unlinked from those categories. The issues in other tabs remain too. Incidentally, Critical Destructables should maybe be renamed Critical Targets, since it includes Hack Super Terminal.

Example: I just tested fresh launch & load, and completing one objective caused one glitch. I killed a Destructible, so now Beginner Tips has an extra label underneath, as though the removed label picked up different text and is rendering underneath the next category header. Destructibles got one box shorter, and collapsing Destructibles hides that extra label. As in the screenshot I uploaded earlier, it's the yellow Agravic Pod text from the first New Fleetships objective which is rendering underneath Beginner Tips.

Interestingly, if I quit and reload the same save, I get the same Objectives tab state every time, whether it's correct or jumbled, down to the exact same wrong labels in the same wrong places. I also suspect that quitting to menu and loading a save, such that the Destructibles category for example goes from very long to very short, is part of the issue because the visual jumbling happens in the space that the previously-large category occupied, and it becomes visually fixed while that category is hidden. I've not tested it precisely, but to recreate the bugs I would try successive loading between saves from a new campaign, an explored galaxy full of objectives, and a late-game with semi-finished categories.

I'm not familiar with .NET or C#, but suspecting possible allocator or pooling mis-behavior makes me think I should mention that I'm on Windows 7 and my .NET updates are usually a month or two behind since I run Windows Update manually. One would hope the platform fundamentals are sound enough not to break games routinely, but naturally I don't take it for granted.

Dominus Arbitrationis

Oct 14, 2018 10:41 am

administrator   ~0049955

Fixed enemy ship icons not collapsing.

Dominus Arbitrationis

Oct 14, 2018 12:46 pm

administrator   ~0049963

Fixed mercenary tab collapse issue. Do note that I am making each issue into a separate one, rather than this big issue that we can't mark as resolved until everything is done.

x4000Bughunter

Oct 14, 2018 1:05 pm

administrator   ~0049976

We're manually pooling things, so you're not incorrect about that -- it's in our code, though, not the platform code, where the issue would be. Is there a savegame you have where there's a simple steps to go through for us to be able to quickly repro the objectives issue? I haven't been able to duplicate that with some casual attempts, and ideally I'd have a case where I can load the game and recreate it in under 10 seconds so that I can use it as a unit test.

Dominus Arbitrationis

Oct 14, 2018 1:11 pm

administrator   ~0049977

Just unpause and let it run for a second.

shouldReproduceObjectivesIssue.save (1,103,744 bytes)
shouldReproduceObjectivesIssue.savemet (54 bytes)

x4000Bughunter

Oct 14, 2018 1:17 pm

administrator   ~0049978

Thanks! I'll take care of that. Can you rename the critical destructibles thing?

x4000Bughunter

Oct 14, 2018 1:34 pm

administrator   ~0049979

Got it -- thanks! * Fixed a couple of bugs with buggy objectives tab display because of various pooled data not being cleared properly.

Dominus Arbitrationis

Oct 14, 2018 1:48 pm

administrator   ~0049980

Renamed Critical Destructibles to Critical Targets, and modified the description to say "... destroy or hack ...".

Bobtree

Oct 14, 2018 7:58 pm

reporter   ~0049995

It's all fixed. I can't seem to close the issue on Mantis.

RocketAssistedPuffin

Oct 14, 2018 8:04 pm

developer   ~0049996

Done that for you then.

Issue History

Date Modified Username Field Change
Oct 13, 2018 12:24 pm Bobtree New Issue
Oct 13, 2018 12:24 pm Bobtree File Added: TabCategoryBugs.png
Oct 13, 2018 12:26 pm BadgerBadger Note Added: 0049925
Oct 13, 2018 12:48 pm Bobtree Note Added: 0049926
Oct 13, 2018 9:13 pm x4000Bughunter Note Added: 0049953
Oct 13, 2018 9:13 pm x4000Bughunter Assigned To => x4000Bughunter
Oct 13, 2018 9:13 pm x4000Bughunter Status new => assigned
Oct 14, 2018 1:15 am Bobtree Note Added: 0049954
Oct 14, 2018 10:41 am Dominus Arbitrationis Description Updated
Oct 14, 2018 10:41 am Dominus Arbitrationis Note Added: 0049955
Oct 14, 2018 10:42 am Dominus Arbitrationis Relationship added parent of 0020505
Oct 14, 2018 12:41 pm Dominus Arbitrationis Relationship added parent of 0020507
Oct 14, 2018 12:42 pm Dominus Arbitrationis Issue Revision Dropped: Description: 0013816
Oct 14, 2018 12:46 pm Dominus Arbitrationis Description Updated View Revisions
Oct 14, 2018 12:46 pm Dominus Arbitrationis Note Added: 0049963
Oct 14, 2018 12:52 pm Dominus Arbitrationis Description Updated View Revisions
Oct 14, 2018 1:05 pm x4000Bughunter Note Added: 0049976
Oct 14, 2018 1:11 pm Dominus Arbitrationis File Added: shouldReproduceObjectivesIssue.save
Oct 14, 2018 1:11 pm Dominus Arbitrationis File Added: shouldReproduceObjectivesIssue.savemet
Oct 14, 2018 1:11 pm Dominus Arbitrationis Note Added: 0049977
Oct 14, 2018 1:17 pm x4000Bughunter Note Added: 0049978
Oct 14, 2018 1:34 pm x4000Bughunter Note Added: 0049979
Oct 14, 2018 1:48 pm Dominus Arbitrationis Note Added: 0049980
Oct 14, 2018 7:58 pm Bobtree Note Added: 0049995
Oct 14, 2018 8:04 pm RocketAssistedPuffin Status assigned => resolved
Oct 14, 2018 8:04 pm RocketAssistedPuffin Resolution open => fixed
Oct 14, 2018 8:04 pm RocketAssistedPuffin Fixed in Version => 0.785 Controls Viewing And Editing
Oct 14, 2018 8:04 pm RocketAssistedPuffin Note Added: 0049996