View Issue Details

IDProjectCategoryLast Update
0020468AI War 2[All Projects] Gameplay IssueOct 11, 2018 12:22 pm
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionduplicate 
Product Version0.781 Destruction Diversity 
Fixed in Version 
Summary0020468: Critiques from Bobtree
DescriptionBobtree from discord had a number of useful critiques that (s)he posted in a pastebin on discord.
https://pastebin.com/Th8FJmCv

I reproduce the list below with some minor formatting tweaks. It's rather long.



    AI War II notes October 10 2018. First time playing, but I have 100+ hours of AIW 1 experience.
Profile creation does not explain what you're picking (portrait and voice?), and those speaker icons should have a "voice sample" tooltip or label.
Scroll bar on the profile menu needs more contrast.
Game defaults to a little window instead of desktop res borderless.
Pablo Vega's music is still awful.
 I don't hear old tracks when selecting the option (original AIW is installed, don't know if this is needed).
There seem to be lots of missing tooltips that look like ~*~.
 Fullscreen resolution picker shows the same res many times (probably different refresh rates that are not being shown).
 Audio settings need sliders, music volume is too sensitive (25 is inaudible).
Button highlighting can flicker near the edge (like below Galaxy Camera in settings, which also highlights from farther than it should).
 "Framerate" in Performance settings is presumably a limit, but it should say so.
 Tooltips have some kind of lazy loading that make them cycle through tips of recently highlighted stuff, this is very weird, looks buggy, more noticeable in Game settings (longer tooltips, maybe a bigger delay).
 Default blue/white selection color combo is not one of the available presets.
"Change Profile" is a profile edit and not a switcher, should be renamed, unless multi-user profiles with more stuff get added (per-user settings, saves, etc).
 Mailing list webpage has a broken image link.
 Main Camera -> Keyboard Move Speed setting is broken?
Alt+Enter stretches the screen instead of changing the window resolution, so from a low res window it becomes very blurry.
Game window is not resizeable by corner drag.
Clicking in Window Width and Window Height leaves blinking cursors visible in both.
 Mouse Zoom Speed setting is broken? Way too many camera sliders.
 Need a hotkey list in-game and on wiki (I remember the V mode from AIW, but I'm playing this blind and haven't looked up the old hotkeys).
  The "Set Control Group" text appearing in the same box as the tutorial text is confusing. <Badger: it would be good if the Tutorial text could be given a box or some extra oomph to make it clear "This is tutorial message">
Tutorial says "units that are rallying have a blue outline", but I don't see it.
 Planets, asteroids, etc keep rotating while game is paused, same for force field animations, makes the pause state less obvious.
It's very hard to get your ships out of auto-mode (V key) when a group is entering a planet or ships are being built quickly, because having a mix of on/off ships selected only lets you toggle auto to ON, so it might be better if auto was a shared setting for ships in a group (set after they rally?) or maybe per-planet.
 Auto kite is off by default, but the tooltip suggests it should be on, and maybe this only works for V mode.
Numbers drawn on top of icons in the build/etc menus are hard to read, and I don't like the build % replacing the stock counts (a separate build % indicator would be better, like a clock-style timer the way DOTA2 ability cooldowns are shown, or a bar that fills up, overlayed on the icon or underneath the list).
 Objectives tab shows +/- next to Beginner tips, but it doesn't hide the Remains Rebuilder tip (only in tutorial, this works in a quick start).
Home Shield Gen starts with brownout (in quick start), and I see why, but this was initially confusing because it's just on a timer and not power-resource related (at least at game start).
 Clicking on different planets quickly in the galaxy view acts like a double-click that opens a planet view, really annoying (need to filter by position so clicking it different places doesn't trigger it).
Galaxy map needs clear indication of what planets you have vision on without having to click on each one.
 Ark ship mechanics are not explained.
Ship icons flicker in random places when a fleet is coming in through a wormhole, sometimes their location is not updated correctly and they arrive in a random place (might be their old coordinates on the other planet).
Ships not pathing around force fields is really annoying, they get stuck and you forget them, and I end up self-destructing them instead of bothering with the micro. Ships can also get stuck under enemy force fields.
 Captured a system with its energy collector positioned outside of reachable space, camera focuses there when I double click the icon, but nothing is visible.
Sometimes ships all stack up in one place (seems to happen with a non-V attack order, where they sort of orbit and all come to rest in the same spot).
Ship icons in motion make a jerky jump after tabbing from galaxy to planet.
I don't like having to babysit units to move them to another planet and attack a specific thing, would prefer to be able to select them, view another planet, and attack target directly, and it keeps throwing me off that you can't order control grouped ships on other planets from the planet view.
  UI takes up a lot of room in general (on 2560x1440 27" monitor), don't need huge numbers, the left ships/build/hack/merc/etc tabs can't be closed.
 Would like an option that restores default view rotation when you zoom way out.
The force strength S icon isn't explained and looks like a resource in unit tooltips, took me a while to find out what it was.
  Time control UI could be better (maybe 2x 5x 10x buttons, or a speedup arrow that cycled speeds), and the red sim-speed number isn't explained.

TagsNo tags attached.

Activities

x4000Bughunter

Oct 11, 2018 12:22 pm

administrator   ~0049860

I've put responses here: https://docs.google.com/document/d/1fvfY6YCwSi3tIkz7_OB-kuAmeK5X1EA5SPy56Z2WlF8/edit?usp=sharing

It was too challenging to try to format that in mantis.

A lot of other mantis topics have been spawned from this one, now, so I'm closing this one. Lots of good stuff. Thanks!

Issue History

Date Modified Username Field Change
Oct 11, 2018 11:08 am BadgerBadger New Issue
Oct 11, 2018 11:08 am BadgerBadger Status new => assigned
Oct 11, 2018 11:08 am BadgerBadger Assigned To => x4000Bughunter
Oct 11, 2018 12:22 pm x4000Bughunter Status assigned => closed
Oct 11, 2018 12:22 pm x4000Bughunter Resolution open => duplicate
Oct 11, 2018 12:22 pm x4000Bughunter Note Added: 0049860