View Issue Details

IDProjectCategoryLast Update
0020418AI War 2[All Projects] Bug - GameplayDec 5, 2018 5:51 pm
ReporterKesselethAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.776 A Legible Galaxy Map 
Fixed in Version0.808 Custom Stacks 
Summary0020418: Carrier Starship not Spawning Drones
DescriptionMy carrier starship fails to spawn any drones whatsoever, plain and simple.

You can test the provided save in the following fashion:

Wait 100 seconds (you can speed it up of course), to ensure any drones on other planets are dead. During that time the AI may send out a couple ships but no drones will appear.

Send the carrier starship to Toda, where there is a reasonable number of enemies and only a few allied turrets. It will be clear to see that no drones spawn.

It is worth noting, however, that RocketAssistedPuffin has no such bug in his game - curious, but it may point to a flaw in only my copy. If it can't be replicated it's probably not worth concerning yourself with.
TagsNo tags attached.
Internal WeightNew

Relationships

related to 0020802 resolvedx4000Bughunter Carrier Spawning Broken 

Activities

Kesseleth

Oct 1, 2018 8:44 pm

reporter  

takingtoda.save (2,449,405 bytes)

RocketAssistedPuffin

Oct 13, 2018 8:38 pm

developer   ~0049947

Is this still occurring now? Maybe it was fixed by freak chance or was a one time fluke.

BadgerBadger

Oct 14, 2018 12:04 pm

manager   ~0049956

The save here still reproduces the problem

BadgerBadger

Oct 14, 2018 12:08 pm

manager   ~0049957

Still reproduces from this save

RocketAssistedPuffin

Oct 14, 2018 12:36 pm

developer   ~0049959

Weird...I still have it work. Even the Starfleet Commander one which I made spawn the same AI drones happily chugs away.

Mckloshiv

Oct 14, 2018 12:41 pm

reporter   ~0049962

The drone ships in my save work fine for me. I hope this helps with finding the cause of this bug.

Dominus Arbitrationis

Oct 14, 2018 12:57 pm

administrator   ~0049970

I was able to reproduce it using the save provided here. No drones are produced. This is on the dev build revision 4316.

BadgerBadger

Dec 5, 2018 5:51 pm

manager   ~0050580

Fixed

Issue History

Date Modified Username Field Change
Oct 1, 2018 8:44 pm Kesseleth New Issue
Oct 1, 2018 8:44 pm Kesseleth File Added: takingtoda.save
Oct 13, 2018 8:38 pm RocketAssistedPuffin Status new => feedback
Oct 13, 2018 8:38 pm RocketAssistedPuffin Note Added: 0049947
Oct 14, 2018 12:04 pm BadgerBadger Note Added: 0049956
Oct 14, 2018 12:08 pm BadgerBadger Assigned To => x4000Bughunter
Oct 14, 2018 12:08 pm BadgerBadger Status feedback => new
Oct 14, 2018 12:08 pm BadgerBadger Note Added: 0049957
Oct 14, 2018 12:09 pm BadgerBadger Status new => assigned
Oct 14, 2018 12:36 pm RocketAssistedPuffin Note Added: 0049959
Oct 14, 2018 12:41 pm Mckloshiv Note Added: 0049962
Oct 14, 2018 12:57 pm Dominus Arbitrationis Note Added: 0049970
Dec 3, 2018 10:52 am Dune Relationship added related to 0020802
Dec 5, 2018 5:51 pm BadgerBadger Status assigned => resolved
Dec 5, 2018 5:51 pm BadgerBadger Resolution open => fixed
Dec 5, 2018 5:51 pm BadgerBadger Fixed in Version => 0.808 Custom Stacks
Dec 5, 2018 5:51 pm BadgerBadger Internal Weight => New
Dec 5, 2018 5:51 pm BadgerBadger Note Added: 0050580