View Issue Details

IDProjectCategoryLast Update
0020326AI War 2[All Projects] Bug - GameplayFeb 11, 2020 5:00 pm
ReporterRocketAssistedPuffinAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.773 Terrorized By An Infinite Loop 
Fixed in VersionBETA 1.327 Hardened Forcefields 
Summary0020326: Units able to get the damage bonus for a target inside a bubble, against the bubble itself.
DescriptionFeels bit hard to explain this...

Planet Mauchly in the save has a Tritium Sniper Starship on it. There's a Forcefield on the far left opposite, with a couple of fleetships in it. The Starship gets a 8x damage modifier against anything with albedo 0.3 or below. Have the Sniper target the Forcefield itself, and then a Fleetship, and watch the damage dealt in the tooltip.

If you target the forcefield itself, the damage is 330, as expected (due to the generators albedo being higher than the requirement for the multiplier). If you target a fleetship inside it however, the bonus damage multiplier comes in, it hits the forcefield, and it has 8x damage against it, even though the forcefield is meant to be immune to this multiplier.

This means things like Stingrays, that get a boost against bubble forcefields, need to be targeting the forcefield itself, and not something inside it.

Dev build!

TagsNo tags attached.

Activities

RocketAssistedPuffin

Sep 18, 2018 5:21 pm

developer  

BubbleDamageOddity.savemet (44 bytes)
BubbleDamageOddity.save (1,061,787 bytes)

Dune

Oct 26, 2018 3:11 pm

administrator   ~0050352

Great catch

RocketAssistedPuffin

Dec 6, 2019 12:53 pm

developer   ~0054862

Last edited: Dec 6, 2019 1:09 pm

View 2 revisions

Relevant to something I'm testing with Tractor Arrays, so here's a new reproduction case. (EDIT: Decided against it. It was slightly weird).

Concussion Corvette targeting Pike Turret under a Forcefield Guard Post. It has a bonus against the Turret, but not the Post.

Simply unpause, then check the damage the Corvette reports (requires weapon activity debug). It'll be reporting a value with the bonus, despite hitting the Forcefield.



BonusTargetUnderForcefield2.save (413,413 bytes)

x4000Bughunter

Feb 11, 2020 4:56 pm

administrator   ~0055967

I can't load either of these saves, for some reason, which is concerning. I'm not sure if these were older versions, but the second one surely should have been viable unless it was made in a dev environment. I'm not having trouble loading other saves, though.

x4000Bughunter

Feb 11, 2020 5:00 pm

administrator   ~0055968

Unable to test it out since I can't load the saves, but should work:

* Completely re-plumbed how forcefields block shots to make the whole thing more efficient, and easier code to read. The essential functionality should remain the same (shooting something under a bubble shield, or the bubble shield itself, hits the bubble visually), but now it should always use the bonuses of the ship against the bubble-emitter and not whatever was underneath it that you were targeting.
** This may fix some other shield-related bugs, but also hasn't been tested much yet.

Thanks!

Issue History

Date Modified Username Field Change
Sep 18, 2018 5:21 pm RocketAssistedPuffin New Issue
Sep 18, 2018 5:21 pm RocketAssistedPuffin File Added: BubbleDamageOddity.save
Sep 18, 2018 5:21 pm RocketAssistedPuffin File Added: BubbleDamageOddity.savemet
Oct 26, 2018 3:11 pm Dune Assigned To => x4000Bughunter
Oct 26, 2018 3:11 pm Dune Status new => assigned
Oct 26, 2018 3:11 pm Dune Note Added: 0050352
Dec 6, 2019 12:53 pm RocketAssistedPuffin File Added: BonusTargetUnderForcefield2.save
Dec 6, 2019 12:53 pm RocketAssistedPuffin Note Added: 0054862
Dec 6, 2019 1:09 pm RocketAssistedPuffin Note Edited: 0054862 View Revisions
Feb 11, 2020 4:56 pm x4000Bughunter Note Added: 0055967
Feb 11, 2020 5:00 pm x4000Bughunter Status assigned => resolved
Feb 11, 2020 5:00 pm x4000Bughunter Resolution open => fixed
Feb 11, 2020 5:00 pm x4000Bughunter Fixed in Version => BETA 1.327 Hardened Forcefields
Feb 11, 2020 5:00 pm x4000Bughunter Note Added: 0055968