View Issue Details

IDProjectCategoryLast Update
0020257AI War 2[All Projects] Bug - GameplaySep 25, 2018 5:33 pm
ReporterHeartHunter7Assigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.768 Golem Rebirth 
Fixed in Version0.775 Unit Stacking 
Summary0020257: Perfomance 49%+ in the 38min+ game
DescriptionGame is not lagging, but have not good perfomance, whitch slow the game.
Btw, save/load helped me.
TagsNo tags attached.

Activities

HeartHunter7

Sep 8, 2018 12:44 pm

reporter  

20180908171321_1.jpg (457,640 bytes)
perfomance1.savemet (50 bytes)
perfomance1.save (1,103,308 bytes)
ArcenDebugLog.txt (1,285,430 bytes)

BadgerBadger

Sep 8, 2018 7:29 pm

manager   ~0049155

What kind of hardware are you running on?

HeartHunter7

Sep 8, 2018 7:34 pm

reporter   ~0049157

Windows 10
Video - Rx 580 8gb
CPU - i5-8400
Ram - 16gb

HeartHunter7

Sep 8, 2018 8:19 pm

reporter   ~0049166

Other game with bad perfomance. Save/load is not helping. In 2-5 minutes i see 58 red %

14.savemet (52 bytes)
14.save (1,841,313 bytes)

HeartHunter7

Sep 9, 2018 10:33 am

reporter   ~0049170

Other example. 8% perfomance.
There is spawning Warden army. Lag will decreased, when all Warden units will on the planet. Its only one army, yes she is big, but thats not maximum. May be decrease cap for Human and AI or something? No idea.

20180909173114_1.jpg (469,382 bytes)
low perfomance and baby sit.savemet (52 bytes)

x4000Bughunter

Sep 9, 2018 8:55 pm

administrator   ~0049174

For that last one, it's missing the actual savegame file (just has the meta). Can you upload that as well?

Thanks for posting your hardware stats, that's useful.

On the current internal build, I'm seeing basically perfect performance on these, but I just made a pretty big set of changes that move some performance-heavy work out of the way of the main simulation. So I'm not sure how much of a bypass of the issue that is causing. The fact that this starts happening over time is the most concerning part.

I am wondering if you've got exceptions happening on background threads, though, particularly because your AI was doing strange things. Can you upload your most recent ArcenDebugLog.txt from after the really slow one? The log from prior to that is clean, so that's probably not it, but it's worth a check.

Thanks!

HeartHunter7

Sep 14, 2018 4:47 pm

reporter   ~0049239

Oh, i did not see this message.
I added save and log.

ArcenDebugLog-2.txt (2,089,755 bytes)
low perfomance and baby sit-2.savemet (52 bytes)

x4000Bughunter

Sep 14, 2018 4:56 pm

administrator   ~0049241

No problem. That's just the meta file again, though -- I do need the .save file. :)

HeartHunter7

Sep 14, 2018 5:02 pm

reporter   ~0049242

lol, he didnot want loading.

low perfomance and baby sit-3.savemet (52 bytes)

HeartHunter7

Sep 14, 2018 5:03 pm

reporter   ~0049243

Again cant

HeartHunter7

Sep 14, 2018 5:04 pm

reporter   ~0049244

He is just not loading with red line, so - https://dropmefiles.com/PWxo9

x4000Bughunter

Sep 14, 2018 5:11 pm

administrator   ~0049245

Thanks for uploading that! And wow, that's a terribly-performing savegame, heh. On the new version it performs even worse, now 10% when I load it and then up to 28% slowly. I will have to do something about the sheer volume of ships it has there, that's just too many for one planet. In AIWC it would combine ships into higher-mark versions and other tricks like that. I think I need to do something similar here.

Frustrating, since all the other savegames perform extremely well now!

HeartHunter7

Sep 14, 2018 5:26 pm

reporter   ~0049247

Yes, and thats not maximum. Warden "Special Master" can showes more and more ships.

x4000Bughunter

Sep 14, 2018 8:10 pm

administrator   ~0049261

Hmm, okay -- thanks for the note.

HeartHunter7

Sep 15, 2018 9:38 am

reporter   ~0049270

Tryed one more time last replay with low 3% perfomance.
A lot of better for me. Was 3%, but right now 40% perfomance and in a few seconds, it will 50, 55, 75 and 100%. Very good.

x4000Bughunter

Sep 16, 2018 3:02 pm

administrator   ~0049290

Excellent!!

For the one that is still very slow, I get 10% on it. It's because of all the riot control starships -- 60 of them!! There are 63 shield generators on a single planet at the moment in that savegame, whereas I had expected a maximum of maybe 5 at the outside. It is a special case I will be looking into more, but now at least I know what the issue is. If I turn off the shield protection logic, then in that savegame I get 75% performance. Still too degraded for my taste, but far better than before.

x4000Bughunter

Sep 25, 2018 5:33 pm

administrator   ~0049486

FINALLY got this completely, thank you!

* It is now possible for AI/NPC units/squads to be "stacked."
** A stack consists of 2+ identical units, with a little marker on them stating how many are in the stack.
** A stack is able to fire at up to 5x its normal attack power, depending on how many units are in the stack (1 unit in a stack = 2x, 5 units = 5x, 5+ is still 5x).
** A stack takes damage just as it would if it were not a stack. When the current item visible from the stack "dies," then the next item pops out and the stack count goes down by one.
*** Damage does not roll over from one unit in the stack to the next, so this makes AOE weapons weaker against stacks, as well as weapons with a lot of overkill.
** If a tractor is grappling a stack, then each stacked entity counts as 1/4 of a tractor target for purposes of the grappling capacity of the tractor beam.
*** This makes tractor beams substantially stronger against stacked enemies.
** The purpose of stacks is performance and visual decluttering. These keep the battles runnning quickly while still being large.
*** Note that ONLY mobile ships/squads can stack. Turrets and whatnot do not stack.
*** Stacks will typically only kick in when there are more than 50 of a single type of unit on a planet, owned by the same AI/NPC faction.
*** However, there is a max_count_per_npc_faction_before_stack flag that can be assigned to entities to make them stack sooner.
**** The various starships and guardians that have bubble forcefields now have a value of 3 for max_count_per_npc_faction_before_stack.
***** This keeps them from absolutely tanking performance if the AI somehow gets a hold of a ludicrous number of mobile shield generators on one planet, which has happened in the past.
** The stacking logic runs on a background thread on the game host only, and sends out orders across the network to cause units to stack when needed.
** It's worth noting that this also makes savegames WAY smaller during certain ginormo-battles.
** Additionally, when there are stacked units on a planet, and there are fewer than half the stacking cap, then stacks start being slowly split apart.
*** That way you don't wind up with a single stack of 50 units as the last entity, it will spread back out, first to two stacks of 25, and so forth and so on.
** Also note that the combining into stacks is done by mark level, so if there are multiple mark levels at a single planet it will not mix and match and change the difficulty on you.
** Thanks to these changes, our test savegames where we had awful things like literally 10% sim speed and 50+ second targeting cycles now run at full speed within 30 seconds of loading, and have quarter-second targeting cycles as well. In the 10% performance savegame's case, it also reduced the savegame file size from 8.6MB to 1.6MB.

Issue History

Date Modified Username Field Change
Sep 8, 2018 12:44 pm HeartHunter7 New Issue
Sep 8, 2018 12:44 pm HeartHunter7 File Added: 20180908171321_1.jpg
Sep 8, 2018 12:44 pm HeartHunter7 File Added: ArcenDebugLog.txt
Sep 8, 2018 12:44 pm HeartHunter7 File Added: perfomance1.save
Sep 8, 2018 12:44 pm HeartHunter7 File Added: perfomance1.savemet
Sep 8, 2018 7:29 pm BadgerBadger Note Added: 0049155
Sep 8, 2018 7:34 pm HeartHunter7 Note Added: 0049157
Sep 8, 2018 8:19 pm HeartHunter7 File Added: 14.save
Sep 8, 2018 8:19 pm HeartHunter7 File Added: 14.savemet
Sep 8, 2018 8:19 pm HeartHunter7 Note Added: 0049166
Sep 9, 2018 10:33 am HeartHunter7 File Added: 20180909173114_1.jpg
Sep 9, 2018 10:33 am HeartHunter7 File Added: low perfomance and baby sit.savemet
Sep 9, 2018 10:33 am HeartHunter7 Note Added: 0049170
Sep 9, 2018 8:55 pm x4000Bughunter Note Added: 0049174
Sep 14, 2018 4:47 pm HeartHunter7 File Added: low perfomance and baby sit-2.savemet
Sep 14, 2018 4:47 pm HeartHunter7 File Added: ArcenDebugLog-2.txt
Sep 14, 2018 4:47 pm HeartHunter7 Note Added: 0049239
Sep 14, 2018 4:56 pm x4000Bughunter Note Added: 0049241
Sep 14, 2018 5:02 pm HeartHunter7 File Added: low perfomance and baby sit-3.savemet
Sep 14, 2018 5:02 pm HeartHunter7 Note Added: 0049242
Sep 14, 2018 5:03 pm HeartHunter7 Note Added: 0049243
Sep 14, 2018 5:04 pm HeartHunter7 Note Added: 0049244
Sep 14, 2018 5:11 pm x4000Bughunter Note Added: 0049245
Sep 14, 2018 5:26 pm HeartHunter7 Note Added: 0049247
Sep 14, 2018 8:10 pm x4000Bughunter Note Added: 0049261
Sep 15, 2018 9:38 am HeartHunter7 Note Added: 0049270
Sep 16, 2018 3:02 pm x4000Bughunter Note Added: 0049290
Sep 25, 2018 5:33 pm x4000Bughunter Assigned To => x4000Bughunter
Sep 25, 2018 5:33 pm x4000Bughunter Status new => resolved
Sep 25, 2018 5:33 pm x4000Bughunter Resolution open => fixed
Sep 25, 2018 5:33 pm x4000Bughunter Fixed in Version => 0.775 Unit Stacking
Sep 25, 2018 5:33 pm x4000Bughunter Note Added: 0049486