View Issue Details

IDProjectCategoryLast Update
0019895AI War 2[All Projects] Graphical BugAug 29, 2018 11:42 am
ReporterHeartHunter7Assigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.758 Release The Warden 
Fixed in Version0.763 Supersized Ship Caps 
Summary0019895: Flash in the window.
DescriptionHello.
I have flash in my window on full screen, if i see a lot of icons(units) in one system. Colour of flash is depend of my or ai colour. For example:system Hatton.
+bonus, ship dance.

I added save game and video.
https://dropmefiles.com/iHhmN - game(i cant load file here, so big size)
https://www.twitch.tv/videos/295654487 - video of this moment
TagsNo tags attached.
Internal Weight

Activities

x4000Bughunter

Aug 11, 2018 2:24 pm

administrator   ~0048229

Thanks for the report -- what OS are you on? I've seen this on outdated OpenGL versions on my Mac, and a few times I saw it on my PC when I had a bug that I had to chase down. This could be a bug, or it could be a case of outdated drivers/OS version on OSX.

I've usually had it glitch out constantly when it was going to do that, though, and not just for a single icon or two, so maybe this is a bit more specific of an issue. If you reload the save after closing the game, is it doing the same thing? Are there any errors in your ArcenDebuggingOutput.log in your PlayerData folder? That could be related, if so.

Last question, does it still do that if you have the game paused? Or is it only seeming to do that kind of in time with ships exploding?

HeartHunter7

Aug 11, 2018 3:44 pm

reporter   ~0048230

Os - windows 10. I have last video driver.

Yes, if i m reloading save, flash is continue. Also, i tryed 3-4 new games games and reload saves. Same flash. I have 0 error in this file.

If my game in pause, i m not see this flash. Game must go on for get this bug.

btw, i have VGA monitor. Is it can be reason too?

x4000Bughunter

Aug 12, 2018 3:56 pm

administrator   ~0048231

Thank you for all the information! I doubt it is because of your VGA monitor. I will have to see what I can see on that.

HeartHunter7

Aug 12, 2018 5:05 pm

reporter   ~0048232

Okay, thank you :D

BadgerBadger

Aug 16, 2018 2:50 pm

manager   ~0048248

I have observed this as well on Linux.

x4000Bughunter

Aug 16, 2018 2:58 pm

administrator   ~0048249

If you have any sort of clue as to what precipitates it, please do let me know.

HeartHunter7

Aug 16, 2018 3:13 pm

reporter   ~0048250

Are you asking, how to make bug faster? Or no?
Just make battle with 140+ power in one system. For example: 100k AI VS 40k player. I see flash almost non stop, without "reload", if battle is really enough big.

x4000Bughunter

Aug 17, 2018 1:11 pm

administrator   ~0048253

Got it -- thanks. I'll have to track that down next week after the next giant build comes out. Savegames won't work from this build to the next one because it's so huge of a change, but we'll get it figured out. :)

RocketAssistedPuffin

Aug 17, 2018 6:02 pm

developer   ~0048254

Looking at the video of it...reminds me I've had flashing too. Yellow though, and in smaller battles. I recall it being...as if certain projectile explosions like flak was supersized into the camera.

This probably doesn't really help, I have nothing else but figure I'd throw it in. If I get it again I'll note things.

x4000Bughunter

Aug 17, 2018 7:22 pm

administrator   ~0048256

Ooh, that helps a lot actually! I have not had any battles with flak in a while, so it may be that's what it is and I'm not running into it because of that.

RocketAssistedPuffin

Aug 17, 2018 8:32 pm

developer   ~0048257

Trying to force it now with larger scale battles - no luck so far. Though I will say flak is performance intensive when multiple shots connect. And they're...kinda a bit too overwhelming as well. Nice feedback, almost too much. Maybe could just make them one super turret per squad, so same output but less explosions, best of both worlds.

RocketAssistedPuffin

Aug 17, 2018 8:35 pm

developer   ~0048258

Scratch that, I'm getting it now. Red flashes confirmed and I think a yellow, even without flak firing. I can spawn a wave and a flash'll occur.

Attached a save, though I've read your version is currently unable to use these I think?

Flashing.savemet (42 bytes)

RocketAssistedPuffin

Aug 17, 2018 8:36 pm

developer   ~0048259

Apologies for the triple post - save didn't attach, too large. Compressed it now.

Flashing.zip (372,068 bytes)

HeartHunter7

Aug 18, 2018 8:02 pm

reporter   ~0048261

Okay.

x4000Bughunter

Aug 29, 2018 11:42 am

administrator   ~0048475

Got it! :D

* FINALLY and definitively fixed the screen flashing bug, which was an issue with the scale of gimbals getting massive on death when their squad would zoom off to ArcenPoint.OutOfRange.
** This is now capped so that the icons can't ever get that huge, and you should just see the icon flash big in the center of your screen if it were to have the issue now (from some other source of the squad zooming off inappropriately).
** But more importantly, we also fixed the underlying issue with the squads zooming off out of range. This was probably the culprit in some other cases, too.

Thank you!

Issue History

Date Modified Username Field Change
Aug 11, 2018 1:43 pm HeartHunter7 New Issue
Aug 11, 2018 2:06 pm BadgerBadger Assigned To => x4000Bughunter
Aug 11, 2018 2:06 pm BadgerBadger Status new => assigned
Aug 11, 2018 2:24 pm x4000Bughunter Note Added: 0048229
Aug 11, 2018 3:44 pm HeartHunter7 Note Added: 0048230
Aug 12, 2018 3:56 pm x4000Bughunter Note Added: 0048231
Aug 12, 2018 5:05 pm HeartHunter7 Note Added: 0048232
Aug 16, 2018 2:50 pm BadgerBadger Note Added: 0048248
Aug 16, 2018 2:58 pm x4000Bughunter Note Added: 0048249
Aug 16, 2018 3:13 pm HeartHunter7 Note Added: 0048250
Aug 17, 2018 1:11 pm x4000Bughunter Note Added: 0048253
Aug 17, 2018 6:02 pm RocketAssistedPuffin Note Added: 0048254
Aug 17, 2018 7:22 pm x4000Bughunter Note Added: 0048256
Aug 17, 2018 8:32 pm RocketAssistedPuffin Note Added: 0048257
Aug 17, 2018 8:35 pm RocketAssistedPuffin File Added: Flashing.savemet
Aug 17, 2018 8:35 pm RocketAssistedPuffin Note Added: 0048258
Aug 17, 2018 8:36 pm RocketAssistedPuffin File Added: Flashing.zip
Aug 17, 2018 8:36 pm RocketAssistedPuffin Note Added: 0048259
Aug 18, 2018 8:02 pm HeartHunter7 Note Added: 0048261
Aug 29, 2018 11:42 am x4000Bughunter Status assigned => resolved
Aug 29, 2018 11:42 am x4000Bughunter Resolution open => fixed
Aug 29, 2018 11:42 am x4000Bughunter Fixed in Version => 0.763 Supersized Ship Caps
Aug 29, 2018 11:42 am x4000Bughunter Note Added: 0048475