View Issue Details

IDProjectCategoryLast Update
0019879AI War 2[All Projects] Bug - GameplaySep 6, 2018 11:37 am
ReporterzeusalmightyAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.757 So...You Like To Read Tooltips? 
Fixed in Version 
Summary0019879: Orchid Ark is cloning itself
DescriptionMy mark II Orchid Ark would continuously make clones of itself, had about 6 before I upgraded to mark III and the behavior ceased.

I have a save for this but I forgot to post it this weekend. I basically don't have access to my home comp during the regular week for work
TagsNo tags attached.

Activities

BadgerBadger

Jul 30, 2018 2:18 pm

manager   ~0048140

What happened when you upgraded to Mark III? Did you keep all the clones?

zeusalmighty

Jul 30, 2018 2:20 pm

reporter   ~0048141

Yes, I kept all the clones but they did not upgrade to mark III except for the "original" (as far as I can tell anyway)

RocketAssistedPuffin

Jul 30, 2018 4:00 pm

developer   ~0048149

I cannot reproduce this seemingly. No Orchid cloning at all.

zeusalmighty

Jul 30, 2018 4:03 pm

reporter   ~0048150

I'll upload my save when possible but it won't be until Friday at the earliest. Not a gamebreaking bug anyway

zeusalmighty

Aug 3, 2018 1:26 pm

reporter   ~0048195

Here is the relevant save data

RocketAssistedPuffin

Aug 3, 2018 3:01 pm

developer   ~0048196

There does not appear to be any save data here.

zeusalmighty

Aug 3, 2018 3:13 pm

reporter   ~0048197

im having trouble uploading my save; my internet connection isn't great for some reason

BadgerBadger

Aug 3, 2018 4:00 pm

manager   ~0048198

Chris' giant rework is going to change all these code paths.

zeusalmighty

Aug 3, 2018 8:17 pm

reporter  

multiple arks.save (5,866,261 bytes)
multiple arks.savemet (51 bytes)

zeusalmighty

Aug 3, 2018 8:17 pm

reporter   ~0048199

Ok, finally able to upload

x4000Bughunter

Sep 6, 2018 11:37 am

administrator   ~0049039

This was almost certainly due to the mark upgrading logic that we used to have, but now that ships don't transform when upgrading this should be impossible to happen again. Thanks!

Issue History

Date Modified Username Field Change
Jul 30, 2018 1:16 pm zeusalmighty New Issue
Jul 30, 2018 2:18 pm BadgerBadger Note Added: 0048140
Jul 30, 2018 2:20 pm zeusalmighty Note Added: 0048141
Jul 30, 2018 4:00 pm RocketAssistedPuffin Note Added: 0048149
Jul 30, 2018 4:03 pm zeusalmighty Note Added: 0048150
Aug 3, 2018 1:26 pm zeusalmighty Note Added: 0048195
Aug 3, 2018 3:01 pm RocketAssistedPuffin Note Added: 0048196
Aug 3, 2018 3:13 pm zeusalmighty Note Added: 0048197
Aug 3, 2018 4:00 pm BadgerBadger Note Added: 0048198
Aug 3, 2018 8:17 pm zeusalmighty File Added: multiple arks.save
Aug 3, 2018 8:17 pm zeusalmighty File Added: multiple arks.savemet
Aug 3, 2018 8:17 pm zeusalmighty Note Added: 0048199
Sep 6, 2018 11:37 am x4000Bughunter Assigned To => x4000Bughunter
Sep 6, 2018 11:37 am x4000Bughunter Status new => resolved
Sep 6, 2018 11:37 am x4000Bughunter Resolution open => fixed
Sep 6, 2018 11:37 am x4000Bughunter Note Added: 0049039