View Issue Details

IDProjectCategoryLast Update
0019762AI War 2[All Projects] Crash/ExceptionAug 7, 2018 12:36 pm
ReporterOvalcircleAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.749 Release The Hounds 
Fixed in Version0.759-0.760 Only The Start of Discovery 
Summary0019762: After loss, the Nanocaust causes a crash
Descriptionif you lose, the Nanocaust tries to find the next planet to attack and when it does so it causes an error because the game thinks the Nanocaust took over the galaxy. When it obviously did not. I don't have a save game because .750 got released and it broke the save due to the new Debug option. But I do have the log. Note that the Nanocaust only had 2 planets.

Well, I don't have the log because it got spammed when I tried to load an old save. I'll post the new log with the "Player does not have debug ships" error.
TagsNo tags attached.

Activities

Ovalcircle

Jul 13, 2018 11:01 pm

reporter  

ArcenDebugLog.txt (1,436,213 bytes)

BadgerBadger

Jul 14, 2018 9:06 am

manager   ~0047879

There are so many crahes in this ArcenDebugLog that I can't tell which one you are referring to! I suggest you delete this file on your machine, then recreate the problem. The file will be automatically recreated on your next game, but it will make it way easier to see which errors you are referring to in the future.

Ovalcircle

Jul 14, 2018 10:53 am

reporter   ~0047884

I don't have the error I wanted to show you because it got spammed with other errors and got replaced by them. I thought that I might as well upload the debug log with the other errors instead of making a new bug report about them. I'll try to reproduce later today. My apologies for being lazy

Ovalcircle

Jul 14, 2018 9:25 pm

reporter   ~0047901

I have the error now. It stealthily showed up in the Debug log. it did not show up during the game.

Look for 7/14/2018 6:42:18 PM

ArcenDebugLog-2.txt (527,618 bytes)

Ovalcircle

Jul 14, 2018 10:46 pm

reporter   ~0047905

I started a new mantis bug report because this one is kind of a mess.

BadgerBadger

Aug 7, 2018 12:36 pm

manager   ~0048206

I redid some some of this logic, so this should no longer be possible

Issue History

Date Modified Username Field Change
Jul 13, 2018 11:01 pm Ovalcircle New Issue
Jul 13, 2018 11:01 pm Ovalcircle File Added: ArcenDebugLog.txt
Jul 13, 2018 11:07 pm Ovalcircle Description Updated View Revisions
Jul 13, 2018 11:08 pm Ovalcircle Description Updated View Revisions
Jul 14, 2018 9:06 am BadgerBadger Note Added: 0047879
Jul 14, 2018 10:53 am Ovalcircle Note Added: 0047884
Jul 14, 2018 9:25 pm Ovalcircle File Added: ArcenDebugLog-2.txt
Jul 14, 2018 9:25 pm Ovalcircle Note Added: 0047901
Jul 14, 2018 10:46 pm Ovalcircle Note Added: 0047905
Aug 7, 2018 12:36 pm BadgerBadger Assigned To => BadgerBadger
Aug 7, 2018 12:36 pm BadgerBadger Status new => resolved
Aug 7, 2018 12:36 pm BadgerBadger Resolution open => fixed
Aug 7, 2018 12:36 pm BadgerBadger Fixed in Version => 0.759-0.760 Only The Start of Discovery
Aug 7, 2018 12:36 pm BadgerBadger Note Added: 0048206