View Issue Details

IDProjectCategoryLast Update
0019760AI War 2[All Projects] Crash/ExceptionJul 19, 2018 10:33 am
ReporterdvAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.749 Release The Hounds 
Fixed in Version0.752 Mathematics Milestone 
Summary0019760: Exception when placing sniper turret after exhausting units
DescriptionI get a FactionDoesNotHaveEnoughCap exception (in a well crafted window) whenever I try to place sniper turret after no more can be placed.

Steps to reproduce:
1. Place all available sniper turrets
2. Attempt to place another sniper turret (after no more sniper turrets can be placed on the planet)
TagsNo tags attached.

Relationships

related to 0019747 resolvedx4000Bughunter Placing a Matter converter gives me an error 

Activities

dv

Jul 13, 2018 1:17 pm

reporter  

ArcenDebugLog.txt (357,562 bytes)

Ovalcircle

Jul 13, 2018 1:27 pm

reporter   ~0047853

That's the "you can't place this because you reached the cap" message. Happens to all buildings. Just ignore it and try to watch the cap. It's goign to look better later.

Ovalcircle

Jul 13, 2018 1:27 pm

reporter   ~0047854

going*

dv

Jul 13, 2018 2:16 pm

reporter   ~0047860

I see. It's a useful message, but it looks too much like a more serious error.

x4000Bughunter

Jul 19, 2018 10:33 am

administrator   ~0047933

Now does a more pleasing popup. :)

Issue History

Date Modified Username Field Change
Jul 13, 2018 1:17 pm dv New Issue
Jul 13, 2018 1:17 pm dv File Added: ArcenDebugLog.txt
Jul 13, 2018 1:27 pm Ovalcircle Note Added: 0047853
Jul 13, 2018 1:27 pm Ovalcircle Relationship added related to 0019747
Jul 13, 2018 1:27 pm Ovalcircle Note Added: 0047854
Jul 13, 2018 2:16 pm dv Note Added: 0047860
Jul 19, 2018 10:33 am x4000Bughunter Assigned To => x4000Bughunter
Jul 19, 2018 10:33 am x4000Bughunter Status new => resolved
Jul 19, 2018 10:33 am x4000Bughunter Resolution open => fixed
Jul 19, 2018 10:33 am x4000Bughunter Fixed in Version => 0.752 Mathematics Milestone
Jul 19, 2018 10:33 am x4000Bughunter Note Added: 0047933