View Issue Details

IDProjectCategoryLast Update
0019686AI War 2[All Projects] Graphical BugSep 5, 2018 8:16 pm
ReporterDevoutHaruhiistAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.747 Improper Handling Of Forcefields 
Fixed in Version0.748 Macrophage Teeth 
Summary0019686: Galaxy Map -- Cannot click on planets
DescriptionHi there. I started playing this recently and have been having some trouble on the galaxy map. It is a sort of inconsistent bug where I cannot seem to ctrl+click on a planet I want to view (e.g. if I want to view my home planet). It seems like I have to click all around in the vicinity of the planet, as if the "hitbox" gets thrown off. (I have never attached a save file for this so please let me know if I attached the wrong thing)
TagsNo tags attached.

Activities

DevoutHaruhiist

Jul 3, 2018 12:34 pm

reporter  

.save (5,119,786 bytes)

x4000Bughunter

Jul 3, 2018 4:01 pm

administrator   ~0047726

Hey there, thanks for this -- if you load up that save, can you reproduce the issue reliably? What resolution are you playing at? I'll try to check that out soon.

DevoutHaruhiist

Jul 3, 2018 4:05 pm

reporter   ~0047727

Yes, I just loaded it up and after tabbing in and out of the galaxy map a few times it seemed like my homeworld's "hitbox" got shifted slightly left. I am playing at 1920x1080. Thanks for looking at this! It has really been slowing down my games.

x4000Bughunter

Jul 3, 2018 4:40 pm

administrator   ~0047728

Thanks!

* The click hitboxes on the galaxy map planets are now much larger, making them easier to click. They're also now properly spherical rather than being an inset rectangle.

Hopefully this does it, but let me know if not.

DevoutHaruhiist

Jul 3, 2018 5:52 pm

reporter   ~0047729

Do I need to start a new game to check if it works? When I went back to my campaign I was still having the same issue after a couple of minutes.

DevoutHaruhiist

Jul 3, 2018 5:54 pm

reporter   ~0047730

As an added note, it seems like the problem is most consistent/prevalent on my home planet (trying to Ctrl+click home planet from galaxy map)

Ovalcircle

Jul 3, 2018 6:15 pm

reporter   ~0047731

He put in in for the next patch of Version 0.748. Just scroll up. https://wiki.arcengames.com/index.php?title=AI_War_2:_The_Pivot#Version_0.747_Improper_Handling_Of_Forcefields

DevoutHaruhiist

Jul 3, 2018 6:16 pm

reporter   ~0047732

Ah ok. I did not understand how it worked. Thank you.

x4000Bughunter

Jul 3, 2018 7:59 pm

administrator   ~0047734

You won't need to start a new campaign once I get the fix out -- it should be tomorrow when I get that out. I was hoping for today but ran out of time for doing a push.

DevoutHaruhiist

Jul 7, 2018 3:47 pm

reporter   ~0047775

I am still (after the patch) having some trouble clicking on one of the planets. See the attached game save. My home planet is "Arden" and when I am on the galaxy map I am having trouble ctrl+clicking on it to zoom back into the gravity well. Thanks!

trouble clicking on Arden.save (4,863,683 bytes)

Ovalcircle

Jul 7, 2018 5:36 pm

reporter   ~0047777

Can confirm this is still here. I downloaded DevoutHaruhiist's save attached to the Mark IV bombers bug report and had trouble clicking on the homeworld after a few minutes. What happened for me was the left half of the planet would not register a click, I had to click on the right half of the planet. I reloaded and it fixed itself.

x4000Bughunter

Jul 9, 2018 9:13 pm

administrator   ~0047794

This MAY be fixed in the next version. I can't duplicate this in 0.749, which is not out yet. I think that the problem might have been related to the physics simulation being turned off, but it's hard to be sure.

x4000Bughunter

Sep 5, 2018 8:16 pm

administrator   ~0048943

Seems like this must be fixed, since nobody has mentioned it in a really long time!

Issue History

Date Modified Username Field Change
Jul 3, 2018 12:34 pm DevoutHaruhiist New Issue
Jul 3, 2018 12:34 pm DevoutHaruhiist File Added: .save
Jul 3, 2018 4:01 pm x4000Bughunter Note Added: 0047726
Jul 3, 2018 4:05 pm DevoutHaruhiist Note Added: 0047727
Jul 3, 2018 4:40 pm x4000Bughunter Assigned To => x4000Bughunter
Jul 3, 2018 4:40 pm x4000Bughunter Status new => resolved
Jul 3, 2018 4:40 pm x4000Bughunter Resolution open => fixed
Jul 3, 2018 4:40 pm x4000Bughunter Fixed in Version => 0.748 Macrophage Teeth
Jul 3, 2018 4:40 pm x4000Bughunter Note Added: 0047728
Jul 3, 2018 5:52 pm DevoutHaruhiist Note Added: 0047729
Jul 3, 2018 5:54 pm DevoutHaruhiist Note Added: 0047730
Jul 3, 2018 6:15 pm Ovalcircle Note Added: 0047731
Jul 3, 2018 6:16 pm DevoutHaruhiist Note Added: 0047732
Jul 3, 2018 7:59 pm x4000Bughunter Note Added: 0047734
Jul 7, 2018 3:47 pm DevoutHaruhiist File Added: trouble clicking on Arden.save
Jul 7, 2018 3:47 pm DevoutHaruhiist Note Added: 0047775
Jul 7, 2018 5:36 pm Ovalcircle Note Added: 0047777
Jul 9, 2018 11:11 am x4000Bughunter Status resolved => assigned
Jul 9, 2018 9:13 pm x4000Bughunter Note Added: 0047794
Sep 5, 2018 8:16 pm x4000Bughunter Status assigned => resolved
Sep 5, 2018 8:16 pm x4000Bughunter Note Added: 0048943