View Issue Details

IDProjectCategoryLast Update
0019626AI War 2[All Projects] Crash/ExceptionMay 8, 2018 11:29 pm
ReporterClasmirAssigned ToBadgerBadger 
Severityblock 
Status resolvedResolutionfixed 
Product Version0.743 Music Blooms 
Fixed in Version 
Summary0019626: Error: table 'MapTypeDataTable' does not have data for the following rows, which were referenced somewhere:
DescriptionI've verified the files via steam "verify integrity of game files". No reported issues. The dialog says "Current content BuildID: 2740214.

The issue is that it crashes on game startup. Shows a dialog with error:

5/2/2018 7:46:46 PM Current directory used: E:/SteamLibrary/steamapps/common/AI War 2/
5/2/2018 7:46:46 PM Process Count = 0 so PlayerDataDirectory used: E:/SteamLibrary/steamapps/common/AI War 2/PlayerData/
5/2/2018 7:46:46 PM Resolution changed to fullscreen 1080x1920
5/2/2018 7:46:46 PM Applied graphics settings:
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
5/2/2018 7:46:46 PM Applied Framerate Type: 120 FPS (vsync: 0 targetFPS:120)
5/2/2018 7:47:15 PM Error: table 'MapTypeDataTable' does not have data for the following rows, which were referenced somewhere:
Nebula
5/2/2018 7:47:15 PM ArcenAssetBundleCache.InstantiatedObjects: 719
5/2/2018 7:47:15 PM Game Version: 0.743
graphicsDeviceType in use: Direct3D11
graphicsDeviceVersion in use: Direct3D 11.0 [level 11.1]
graphicsMultiThreaded: False
graphicsShaderLevel: 50
operatingSystem: Windows 10 (10.0.0) 64bit
graphicsDeviceName: NVIDIA GeForce GTX 1070
graphicsDeviceID: 7041
graphicsDeviceVendor: NVIDIA
graphicsDeviceVendorID: 4318
graphicsDeviceVersion: Direct3D 11.0 [level 11.1]
graphicsMemorySize: 8088
maxTextureSize: 16384
npotSupport: Full
processorType: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz
processorCount: 4
processorFrequency: 3300
systemMemorySize: 16333
supportsImageEffects: True
supportedRenderTargetCount: 8
supportsComputeShaders: True
supportsShadows: True
usesReversedZBuffer: True
5/2/2018 7:47:15 PM
29.6 seconds total load time.

SetDirectoriesToBeUsed (0.3s)
LoadFinalSFXStuff (8.0s)
ExternalIconDictionaryTable (0.6s)
ArcenUIPrefabTable (0.8s)
SpaceboxDefinitionTable (0.6s)
PlanetDefinitionTable (1.3s)
GameEntityTypeDataTable.Initialize (1.4s)
GameEntityTypeDataTable.InitVisualBits (14.2s)

   at System.Environment.get_StackTrace() in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Environment.cs:line 227
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Boolean IncludeStackTrace, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 155
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 116
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 95
   at Arcen.Universal.Engine_Universal+<OnApplicationInitialization>c__Iterator0.MoveNext() in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\Engine_Universal.cs:line 632
   at UnityEngine.SetupCoroutine.InvokeMoveNext(IEnumerator enumerator, IntPtr returnValueAddress)

5/2/2018 7:47:15 PM
Hello Steam user 'Clasmir'

   at System.Environment.get_StackTrace() in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Environment.cs:line 227
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Boolean IncludeStackTrace, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 155
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 116
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 95
   at ArcenGameController.Update() in D:\vclarge\AI_War_2_Ultra\AIW2Unity\Assets\ArcenCode\ArcenGameController.cs:line 77
TagsNo tags attached.

Activities

Clasmir

May 3, 2018 10:36 am

reporter   ~0047537

Picking any menu option that 'should' start the game causes more error exception dialogs to appear.

Clasmir

May 3, 2018 10:37 am

reporter   ~0047538

Also, I've had this error for a while. Not just this version.

BadgerBadger

May 3, 2018 10:41 am

manager   ~0047539

This is a known issue caused by yours truly. I disabled the "Nebula" map type incorrectly. To fix this, open the PlayerData/newsettings.dat file in your installation of AIW2 and replace the line
        LastSetup_MapType="Nebula"
with
        LastSetup_MapType="Realistic"

Clasmir

May 4, 2018 9:31 am

reporter   ~0047541

Ok you can mark this as resolved, please. After making the edit, the game loads without issue.

Thanks.

BadgerBadger

May 4, 2018 9:46 am

manager   ~0047542

A workaround was provided to the user

Clasmir

May 7, 2018 9:15 am

reporter   ~0047544

You should come up with a way to script this fix into a build. Imagine how many people have this issue and don't know how or don't care to create a bug?

BadgerBadger

May 8, 2018 11:29 pm

manager   ~0047545

I have made it so that this is no longer a crash-worthy condition.

Issue History

Date Modified Username Field Change
May 3, 2018 10:34 am Clasmir New Issue
May 3, 2018 10:36 am Clasmir Note Added: 0047537
May 3, 2018 10:37 am Clasmir Note Added: 0047538
May 3, 2018 10:41 am BadgerBadger Note Added: 0047539
May 4, 2018 9:31 am Clasmir Note Added: 0047541
May 4, 2018 9:46 am BadgerBadger Assigned To => BadgerBadger
May 4, 2018 9:46 am BadgerBadger Status new => resolved
May 4, 2018 9:46 am BadgerBadger Resolution open => fixed
May 4, 2018 9:46 am BadgerBadger Note Added: 0047542
May 7, 2018 9:15 am Clasmir Note Added: 0047544
May 8, 2018 11:29 pm BadgerBadger Note Added: 0047545