View Issue Details

IDProjectCategoryLast Update
0019602AI War 2[All Projects] Bug - GameplayApr 25, 2018 12:25 pm
ReporterOvalcircleAssigned ToBadgerBadger 
Severityminor 
Status closedResolutionfixed 
Product Version0.721-0.722 Down The Wormhole 
Fixed in Version0.740 Clean Up That Nebula, Young Man! 
Summary0019602: Marauders disappearing as soon as they spawn
Description Copy and paste from https://forums.arcengames.com/ai-war-ii/ai-war-2-v0-722-released!-'down-the-wormhole'/msg218713/#msg218713
  """""""I decided to put marauders on. I started attacking the planet next to my home-world (lets call it planet 2) when it said "Marauders are attacking Planet 2". Alright, I wait for a bit and nothing happens. Right after that, I get "Marauders are attacking (home-world planet name)". Alright, i wait a little while. Nothing again. Not sure what's up. I don't have a save during this, but I'll see if I can replicate it within the hour.
Edit: Got it. Observed what was happening and will be uploading a save to Mantis now."""""""""
""""""= the original quote
Basically, the marauders are despawning as soon as they spawn in. Got screenshots and a save. It turns out that the marauders are spawning in as allies and warping away.
As for the save, just wait a few seconds for the bug to happen.
Please excuse my butchering of Marauders in the save-file name.
TagsNo tags attached.

Activities

Ovalcircle

Apr 24, 2018 10:44 pm

reporter  

Maurauder bug 1 .jpg (146,752 bytes)
Maurauder bug 1 .jpg (146,752 bytes)
maurarder test.save (1,978,856 bytes)
Maurauder bug 2 .jpg (142,898 bytes)
Maurauder bug 2 .jpg (142,898 bytes)

BadgerBadger

Apr 24, 2018 11:17 pm

manager   ~0047449

Technically the problem is a bit different. The Marauders don't seem to be able to detect what the human defenses are.
I iterate over all the planets and check the following
                Planet planet = galaxy.Planets[i];
                                                                                                                                                                                                                                                                                                                
                PlanetFaction controllingFaction = planet.GetPlanetFactionForFaction( planet.GetControllingFaction() );
                FInt hostileTotalStrength = planet.GetPlanetFactionForFaction( faction ).DataByStance[FactionStance.Hostile].TotalStrength;
                if(controllingFaction.Faction.Type == FactionType.Player && hostileTotalStrength < this.Data.Budget * this.Data.Braveness_Constant )
                 {
                             //This planet is a valid target because it's owned by the player and the hostile strength (aka the human defenders) are less than the budget available to the marauders
                             //unfortunately the hostileTotalStrength always seems to think that it's 0 and I don't know why
                  }

I need to figure out what's going on.

BadgerBadger

Apr 24, 2018 11:58 pm

manager   ~0047450

Fixed some dumb bugs on my part. Thanks for the bug report

Ovalcircle

Apr 25, 2018 12:08 am

reporter   ~0047451

You're welcome!

x4000Bughunter

Apr 25, 2018 12:03 pm

administrator   ~0047458

Badger, I wonder if the "disappearing as soon as they spawn" bit might also be related to what the nanocaust stuff is doing? Appear, fire off a shot, disappear. Suddenly there are nanocaust ships on the other planet, unexpectedly.

BadgerBadger

Apr 25, 2018 12:15 pm

manager   ~0047460

Completely unrelated. This bug was because I had messed up the logic in figuring out which planets marauders should attack, and also the conditions under which the marauders should leave. These were just dumb mistakes in basic functionality. The Nanocaust stuff is a much more complex and interesting bug, which is conveniently not in the Nanocaust code ;-)

x4000Bughunter

Apr 25, 2018 12:25 pm

administrator   ~0047463

10-4. Thanks!

Issue History

Date Modified Username Field Change
Apr 24, 2018 10:40 pm Ovalcircle New Issue
Apr 24, 2018 10:40 pm Ovalcircle File Added: maurarder test.save
Apr 24, 2018 10:40 pm Ovalcircle File Added: Maurauder bug (1).jpg
Apr 24, 2018 10:40 pm Ovalcircle File Added: Maurauder bug (2).jpg
Apr 24, 2018 10:41 pm Ovalcircle Description Updated View Revisions
Apr 24, 2018 10:43 pm Ovalcircle File Deleted: Maurauder bug (2).jpg
Apr 24, 2018 10:43 pm Ovalcircle File Deleted: Maurauder bug (1).jpg
Apr 24, 2018 10:43 pm Ovalcircle File Deleted: maurarder test.save
Apr 24, 2018 10:44 pm Ovalcircle File Added: Maurauder bug 1 .jpg
Apr 24, 2018 10:44 pm Ovalcircle File Added: Maurauder bug 2 .jpg
Apr 24, 2018 10:44 pm Ovalcircle File Added: maurarder test.save
Apr 24, 2018 11:17 pm BadgerBadger Note Added: 0047449
Apr 24, 2018 11:58 pm BadgerBadger Assigned To => BadgerBadger
Apr 24, 2018 11:58 pm BadgerBadger Status new => closed
Apr 24, 2018 11:58 pm BadgerBadger Resolution open => fixed
Apr 24, 2018 11:58 pm BadgerBadger Fixed in Version => 0.740 Clean Up That Nebula, Young Man!
Apr 24, 2018 11:58 pm BadgerBadger Note Added: 0047450
Apr 25, 2018 12:08 am Ovalcircle Note Added: 0047451
Apr 25, 2018 12:03 pm x4000Bughunter Note Added: 0047458
Apr 25, 2018 12:15 pm BadgerBadger Note Added: 0047460
Apr 25, 2018 12:25 pm x4000Bughunter Note Added: 0047463