View Issue Details

IDProjectCategoryLast Update
0019601AI War 2[All Projects] Bug - GameplayJun 28, 2018 7:15 pm
ReporterOvalcircleAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.721-0.722 Down The Wormhole 
Fixed in Version0.745 A Pivot And A Leap Forward 
Summary0019601: The ghost for placing a turret disappears near a certain wormhole
Description^ For some reason, when I try to place down a turret, the ghost with the range indicator that you're supposed to get disappears near a certain wormhole. Can't post pics because its invisible, but the other wormhole is fine. It's the one at the bottom next to my home-world.
Not sure if not having a name will impact the save, but I want to upload it now before I inevitably accidentally close the window and lose all this text. Will replace with a name in a few minutes.

Edit*: Nevermind. I loaded the save so I could name it and it fixed itself. Must be one of those types of bugs. Might not show up in the save I posted, then.
TagsNo tags attached.

Activities

Ovalcircle

Apr 24, 2018 8:39 pm

reporter  

.save (2,050,033 bytes)

x4000Bughunter

Apr 25, 2018 11:59 am

administrator   ~0047456

Does zooming in and out as you're near the wormhole make any difference?

Ovalcircle

Apr 25, 2018 12:47 pm

reporter   ~0047465

Nope. I forgot to mention that all the turrets there don't get selected when you hover over them. So if a Needler turret was there, if I hover over, I still get the Star-ship constructor tool tip because That's the last thing I hovered over that was out of range of the "dead zone". the only way I could select them was with the click and drag box. I could still place turrets, though. Unfortunately, I didn't check if ships there were affected, because I rationalized that i need to keep them away from it so i don't inconvenience myself if the AI attacked that wormhole, Also: After I reloaded, after some time, the issue came back again. I then reloaded and it was fine.

x4000Bughunter

Apr 25, 2018 1:23 pm

administrator   ~0047467

Blah! If you see any way of reproducing it, please do let me know.

Ovalcircle

Apr 25, 2018 1:48 pm

reporter   ~0047468

Will do.

Ovalcircle

Apr 26, 2018 9:42 pm

reporter   ~0047482

Okay it happened again. Can't really give specifics, but I was spamming all different types of turrets on a planet and it happened. This time by my controller which is nowhere near a wormhole.

Ovalcircle

Apr 26, 2018 10:43 pm

reporter   ~0047488

Tried it again and it didn't work. I honestly have no idea how it happens. It just "does".

x4000Bughunter

Apr 29, 2018 11:29 am

administrator   ~0047499

So basically, sometimes it goes into "I am blocked" mode and just stops working, period?

Do you think maybe you're out of power or something like that? Maybe this is just the GUI not being very helpful in telling you why you can't place the thing.

Ovalcircle

Apr 29, 2018 12:37 pm

reporter   ~0047506

I'm not out of power because I can still place turrets down in the blocked area or wherever i want.

x4000Bughunter

Apr 29, 2018 1:00 pm

administrator   ~0047508

Oh, wait -- so it SHOWS as blocked but still places?

Ovalcircle

Apr 29, 2018 1:37 pm

reporter   ~0047512

Well, in a sense. It's not blocked as in it shows you can't build. It's more like a dead zone. A dead zone where anything involving hovering the mouse without clicking just doesn't work. I can select anything in the "dead zone" with the click and drag box, other than that it doesn't work. I can't hover over ships or turrets in the area. This area also doesn't take up the whole planet. It's a circle that takes up about 1/7th -1/5th (working from memory) of the planet. It's happened at a wormhole and a planetary controller, though the controller was in a a game where an error occurred. I'm 99% sure there were no errors on the first one though (the wormhole), because that was the game where the direct waves had no warnings and I went to complain on the forums. Now that I think about it, they seem to have occurred on the starting home world planet, despite however many planets i took.

x4000Bughunter

Apr 29, 2018 1:40 pm

administrator   ~0047514

Humm... my main thought is a collider getting in the way of raycasts, but I'd have to see an error log to be sure. If you see it again, can you let me know and also upload your ArcenDebugLog from the PlayerData subfolder in your game folder? Right now it wouldn't help much, but it would be something for if you see it again. Hopefully this is purely a downstream issue, because otherwise it's a pretty strange one!

Ovalcircle

Apr 29, 2018 1:58 pm

reporter   ~0047517

Will do.

hawk

Apr 29, 2018 2:57 pm

reporter   ~0047519

Just FYI, I have experienced this as well. It just didn't click in my mind until comment -0047512 by Ovalcircle.
If I see it again before it's solved, I'll do the above.

BadgerBadger

Apr 29, 2018 3:43 pm

manager   ~0047520

Here's a save game with a variant of this issue (the tooltip gets really confused and displays tooltips even when its not hovering over a ship, or it thinks it's hovering over a ship when it isn't).

Load this save game. Don't bother to unpause it. Go to the planet "Lampson" and move the cursor around. Then go to the planet Mistral (where my large fleet is) and move the cursor around through empty space and you'll see some weird effects. You dno't need to move the screen at all, just move the cursor around, This is quite consistent for me.

goforBotnet.savemet (47 bytes)
goforBotnet.save (2,983,297 bytes)

hawk

Apr 29, 2018 4:26 pm

reporter   ~0047522

This might be it... or related ... or something different, but:
In the attached save game, the Starship Contractor has an extremely large select range. This removes the ghost pre-placement of objects and the ability to click on other units.

I threw in the kitchen sink just in case.

Star Con Select Area.savemet (39 bytes)
ArcenDebugLog.txt (883,426 bytes)
Star Con Select Area.save (1,999,783 bytes)
ErrorsReportedByEngine.txt (2,990 bytes)
4/25/2018 10:23:44 PM (0.722) Mem: 404,582,400 Mode: Host Plat:WindowsPlayer
-----------------------------------ErrorsReportedByEngine-----------------------------------
-----------
NullReferenceException: Object reference not set to an instance of an object
Stack Trace: ArcenShot.Activate (Arcen.AIW2.Core.ArcenGameObjectResourcePool fromPool, Arcen.AIW2.Core.GameEntity RelatedTo, Arcen.AIW2.Core.GameEntityTypeData RelatedTypeData, Arcen.AIW2.Core.EntityTypeFactionVisualData FactionVisualData) (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Visualization/src/ShipDisplayCode/ArcenShot.cs:59)
Arcen.AIW2.Core.ArcenGameObjectResourcePool.GetAndActivateIVisualObject (Arcen.AIW2.Core.GameEntity RelatedEntity, Arcen.AIW2.Core.GameEntityTypeData RelatedTypeData, Arcen.AIW2.Core.EntityTypeFactionVisualData FactionVisualData) (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Core/src/Presentation/ArcenGameObjectResourcePool.cs:192)
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.HandleVisualObjectAddRequests ()
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.RunPlanetUpdateTree ()
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.RunUpdate ()
ArcenMainGameVisuals.Update () (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Visualization/src/ShipDisplayCode/ArcenMainGameVisuals.cs:79)



4/25/2018 10:54:39 PM (0.722) Mem: 446,734,336 Mode: Host Plat:WindowsPlayer
-----------------------------------ErrorsReportedByEngine-----------------------------------
-----------
Exception: window: Window_ResourceBar
System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.External.Window_ResourceBar+tArkOnAIPlanetNotice+<GetShouldBeHidden>c__AnonStorey0.<>m__0 (Arcen.AIW2.Core.GameEntity entity) [0x00000] in <filename unknown>:0 
  at Arcen.AIW2.Core.EntityCollection.DoForEntities (EntityRollupType Rollup, Arcen.AIW2.Core.ProcessorDelegate Processor) [0x0003d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\GameState\GameEntity\EntityCollection.cs:397 
  at Arcen.AIW2.External.Window_ResourceBar+tArkOnAIPlanetNotice.GetShouldBeHidden () [0x00000] in <filename unknown>:0 
  at Arcen.Universal.ArcenUI_Element.UpdateFromUI (Single DeltaTime) [0x0003a] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Element.cs:358 
  at Arcen.Universal.ArcenUI_Window.OnUpdate (Single DeltaTime) [0x00155] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Window.cs:118 
  at Arcen.Universal.ArcenUI.OnUpdateFromMainThread () [0x0007e] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI.cs:311 
Stack Trace: Arcen.Universal.ArcenUI.OnUpdateFromMainThread () (at D:/vclarge/AI_War_2_Ultra/ArcenUniversal/src/ArcenUI/ArcenUI.cs:315)
Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () (at D:/vclarge/AI_War_2_Ultra/ArcenUniversal/src/Engine_Universal.cs:1025)
ArcenGameController.Update () (at D:/vclarge/AI_War_2_Ultra/AIW2Unity/Assets/ArcenCode/ArcenGameController.cs:59)



hawk

Apr 29, 2018 6:05 pm

reporter   ~0047523

Possibly related. In the attached save game, if the unclaimed Sniper Flagship on Korn is in screen at all (or even slightly outside), it is the only thing you can click select. This includes when you are fully zoomed out. In this case, the select window for it is everywhere except outside the asteroid belt.

The Experimental Fleetship Lab on the same planet also has a too-large select range if the Sniper Flagship is sufficiently outside a zoomed in screen.

ErrorsReportedByEngine-2.txt (2,990 bytes)
4/25/2018 10:23:44 PM (0.722) Mem: 404,582,400 Mode: Host Plat:WindowsPlayer
-----------------------------------ErrorsReportedByEngine-----------------------------------
-----------
NullReferenceException: Object reference not set to an instance of an object
Stack Trace: ArcenShot.Activate (Arcen.AIW2.Core.ArcenGameObjectResourcePool fromPool, Arcen.AIW2.Core.GameEntity RelatedTo, Arcen.AIW2.Core.GameEntityTypeData RelatedTypeData, Arcen.AIW2.Core.EntityTypeFactionVisualData FactionVisualData) (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Visualization/src/ShipDisplayCode/ArcenShot.cs:59)
Arcen.AIW2.Core.ArcenGameObjectResourcePool.GetAndActivateIVisualObject (Arcen.AIW2.Core.GameEntity RelatedEntity, Arcen.AIW2.Core.GameEntityTypeData RelatedTypeData, Arcen.AIW2.Core.EntityTypeFactionVisualData FactionVisualData) (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Core/src/Presentation/ArcenGameObjectResourcePool.cs:192)
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.HandleVisualObjectAddRequests ()
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.RunPlanetUpdateTree ()
Arcen.AIW2.ExternalVisualization.BattlefieldVisualSingleton.RunUpdate ()
ArcenMainGameVisuals.Update () (at D:/vclarge/AI_War_2_Ultra/ArcenAIW2Visualization/src/ShipDisplayCode/ArcenMainGameVisuals.cs:79)



4/25/2018 10:54:39 PM (0.722) Mem: 446,734,336 Mode: Host Plat:WindowsPlayer
-----------------------------------ErrorsReportedByEngine-----------------------------------
-----------
Exception: window: Window_ResourceBar
System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.External.Window_ResourceBar+tArkOnAIPlanetNotice+<GetShouldBeHidden>c__AnonStorey0.<>m__0 (Arcen.AIW2.Core.GameEntity entity) [0x00000] in <filename unknown>:0 
  at Arcen.AIW2.Core.EntityCollection.DoForEntities (EntityRollupType Rollup, Arcen.AIW2.Core.ProcessorDelegate Processor) [0x0003d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\GameState\GameEntity\EntityCollection.cs:397 
  at Arcen.AIW2.External.Window_ResourceBar+tArkOnAIPlanetNotice.GetShouldBeHidden () [0x00000] in <filename unknown>:0 
  at Arcen.Universal.ArcenUI_Element.UpdateFromUI (Single DeltaTime) [0x0003a] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Element.cs:358 
  at Arcen.Universal.ArcenUI_Window.OnUpdate (Single DeltaTime) [0x00155] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Window.cs:118 
  at Arcen.Universal.ArcenUI.OnUpdateFromMainThread () [0x0007e] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI.cs:311 
Stack Trace: Arcen.Universal.ArcenUI.OnUpdateFromMainThread () (at D:/vclarge/AI_War_2_Ultra/ArcenUniversal/src/ArcenUI/ArcenUI.cs:315)
Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () (at D:/vclarge/AI_War_2_Ultra/ArcenUniversal/src/Engine_Universal.cs:1025)
ArcenGameController.Update () (at D:/vclarge/AI_War_2_Ultra/AIW2Unity/Assets/ArcenCode/ArcenGameController.cs:59)



Sniper Flagship Select.savemet (40 bytes)
Sniper Flagship Select.save (2,142,308 bytes)
ArcenDebugLog-2.txt (895,065 bytes)

Ovalcircle

Apr 29, 2018 6:11 pm

reporter   ~0047524

Yes! hawk, this is exactly the issue I reported in my other mantis issue: https://bugtracker.arcengames.com/view.php?id=19611&nbn=3#bugnotes I had an error before each issue due to disabling waves, so I thought that was the problem. But I guess in this case, correlation does not imply causation.

hawk

Apr 29, 2018 6:22 pm

reporter   ~0047525

Sweet! Possibly two birds with one stone!

x4000Bughunter

Apr 29, 2018 8:21 pm

administrator   ~0047527

Wonderful, thank you!! This is probably a data issue, then. I will investigate. :)

x4000Bughunter

Jun 28, 2018 7:15 pm

administrator   ~0047616

The offending unit is gone now, with new units being added back in their place, so this is effectively fixed now. If we see something like this again, we'll know what it is, though -- thanks!

Issue History

Date Modified Username Field Change
Apr 24, 2018 8:39 pm Ovalcircle New Issue
Apr 24, 2018 8:39 pm Ovalcircle File Added: .save
Apr 24, 2018 8:44 pm Ovalcircle Description Updated View Revisions
Apr 25, 2018 11:59 am x4000Bughunter Assigned To => x4000Bughunter
Apr 25, 2018 11:59 am x4000Bughunter Status new => assigned
Apr 25, 2018 11:59 am x4000Bughunter Note Added: 0047456
Apr 25, 2018 12:47 pm Ovalcircle Note Added: 0047465
Apr 25, 2018 1:23 pm x4000Bughunter Note Added: 0047467
Apr 25, 2018 1:48 pm Ovalcircle Note Added: 0047468
Apr 26, 2018 9:42 pm Ovalcircle Note Added: 0047482
Apr 26, 2018 10:43 pm Ovalcircle Note Added: 0047488
Apr 29, 2018 11:29 am x4000Bughunter Note Added: 0047499
Apr 29, 2018 12:37 pm Ovalcircle Note Added: 0047506
Apr 29, 2018 1:00 pm x4000Bughunter Note Added: 0047508
Apr 29, 2018 1:09 pm x4000Bughunter Status assigned => resolved
Apr 29, 2018 1:09 pm x4000Bughunter Resolution open => fixed
Apr 29, 2018 1:37 pm Ovalcircle Note Added: 0047512
Apr 29, 2018 1:40 pm x4000Bughunter Note Added: 0047514
Apr 29, 2018 1:40 pm x4000Bughunter Status resolved => assigned
Apr 29, 2018 1:58 pm Ovalcircle Note Added: 0047517
Apr 29, 2018 2:57 pm hawk Note Added: 0047519
Apr 29, 2018 3:43 pm BadgerBadger File Added: goforBotnet.savemet
Apr 29, 2018 3:43 pm BadgerBadger File Added: goforBotnet.save
Apr 29, 2018 3:43 pm BadgerBadger Note Added: 0047520
Apr 29, 2018 4:26 pm hawk File Added: Star Con Select Area.save
Apr 29, 2018 4:26 pm hawk File Added: Star Con Select Area.savemet
Apr 29, 2018 4:26 pm hawk File Added: ArcenDebugLog.txt
Apr 29, 2018 4:26 pm hawk File Added: ErrorsReportedByEngine.txt
Apr 29, 2018 4:26 pm hawk Note Added: 0047522
Apr 29, 2018 6:05 pm hawk File Added: Sniper Flagship Select.save
Apr 29, 2018 6:05 pm hawk File Added: Sniper Flagship Select.savemet
Apr 29, 2018 6:05 pm hawk File Added: ArcenDebugLog-2.txt
Apr 29, 2018 6:05 pm hawk File Added: ErrorsReportedByEngine-2.txt
Apr 29, 2018 6:05 pm hawk Note Added: 0047523
Apr 29, 2018 6:11 pm Ovalcircle Note Added: 0047524
Apr 29, 2018 6:22 pm hawk Note Added: 0047525
Apr 29, 2018 8:21 pm x4000Bughunter Note Added: 0047527
Jun 28, 2018 7:15 pm x4000Bughunter Status assigned => resolved
Jun 28, 2018 7:15 pm x4000Bughunter Fixed in Version => 0.745 A Pivot And A Leap Forward
Jun 28, 2018 7:15 pm x4000Bughunter Note Added: 0047616