View Issue Details

IDProjectCategoryLast Update
0019427AI War 2[All Projects] Gameplay IssueMar 21, 2018 12:49 pm
ReporterBummeriAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.706 
Fixed in Version0.715 
Summary0019427: While zoomed out, mouse cursor snap is detrimental to precision
DescriptionWhen zooming and moving the mouse around on the zoom levels where you are able to see the whole gravity well, the mouse loses precision due to snapping to some xy-grid system. The large distances between the snaps cause the cursor to lose precision.

The image shows how large the distances between the snaps can be. This means it can be impossible to tell ships to interact with wormholes.
TagsNo tags attached.

Activities

Bummeri

Feb 10, 2018 10:37 am

reporter  

20180210173448_1.jpg (6,658 bytes)
20180210173448_1.jpg (6,658 bytes)

Dune

Feb 10, 2018 10:55 am

administrator   ~0046956

Tello card added for this to be reviewed with other GUI concerns.

x4000Bughunter

Feb 11, 2018 5:29 pm

administrator   ~0046961

Can you retest this with 0.706? I think I may have fixed this as part of another change.

Thanks for the reports!

Bummeri

Feb 17, 2018 7:07 pm

reporter   ~0046995

0.706 is still having this issue.

Bummeri

Feb 18, 2018 6:48 pm

reporter   ~0047004

And 0.707

x4000Bughunter

Mar 21, 2018 12:49 pm

administrator   ~0047258

Thanks!


* Fixed the snapping problem with the cursor at far zooms. It turns out it was a precision problem caused by the near clip plane of the cameras being set to a value less than 1.
** Useful info: https://forum.unity.com/threads/solved-increasingly-inaccurate-results-of-screenpointtoray-as-transform-size-increase-choppy.459818/

Issue History

Date Modified Username Field Change
Feb 10, 2018 10:37 am Bummeri New Issue
Feb 10, 2018 10:37 am Bummeri File Added: 20180210173448_1.jpg
Feb 10, 2018 10:37 am Bummeri Severity minor => major
Feb 10, 2018 10:55 am Dune Assigned To => keith.lamothe
Feb 10, 2018 10:55 am Dune Status new => considering
Feb 10, 2018 10:55 am Dune Note Added: 0046956
Feb 11, 2018 5:29 pm x4000Bughunter Note Added: 0046961
Feb 11, 2018 5:29 pm x4000Bughunter Assigned To keith.lamothe => x4000Bughunter
Feb 11, 2018 5:29 pm x4000Bughunter Status considering => feedback
Feb 17, 2018 7:07 pm Bummeri Note Added: 0046995
Feb 17, 2018 7:07 pm Bummeri Status feedback => assigned
Feb 18, 2018 6:48 pm Bummeri Note Added: 0047004
Mar 21, 2018 12:49 pm x4000Bughunter Status assigned => resolved
Mar 21, 2018 12:49 pm x4000Bughunter Resolution open => fixed
Mar 21, 2018 12:49 pm x4000Bughunter Fixed in Version => 0.715
Mar 21, 2018 12:49 pm x4000Bughunter Note Added: 0047258