View Issue Details

IDProjectCategoryLast Update
0019287AI War 2[All Projects] Gameplay IssueNov 11, 2017 12:48 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.601 
Fixed in Version0.604 
Summary0019287: Can't build anything while fixing golems
DescriptionI have captured a planet. There's a golem on it I want to reclaim, as well as the Science/Metal/Fuel generators. Unfortunately, the Ark/Controller/Flagships have decided to repair the golem first, which means they will continue to just repair the golem until it's at 100% (which might take minutes on end, when capturing the science generator would take a few seconds. The only way around this is to send the Golem to another planet.

This is a symptom of a larger problem; how to really control economic expenses. In AIWC I could finagle much of this via engineers (since the default build rate w/o engineers was quite slow).

I can give save games if desired. But really we need a mechanism to say "don't Build/Rebuild/Repair X right now, I need my metal elsewhere"
TagsNo tags attached.

Activities

keith.lamothe

Nov 7, 2017 8:03 am

administrator   ~0046583

A save game would be useful, as it makes it much easier to diagnose why it's spending what on which things. Depending on the circumstances the intended behavior might be "repair the cheaper things first" or "repair the golem and a resource-collector at the same time".

I hear you about the need to control repair costs.

BadgerBadger

Nov 7, 2017 9:17 am

reporter   ~0046588

I don't have a save game, but I can just tell you what I've observed. This is most annoying if I have a damaged golem as part of my fleet and I take a new planet. The game seems to prioritize healing your damaged ships over capturing new things. Which is fine for fleetships, but not so much for golems.

BadgerBadger

Nov 7, 2017 9:20 am

reporter   ~0046589

Okay, I lied. Here's a saved game where I am repairing a golem instead of capturing an ARS. I'd like to be able to say "Please capture the ARS first" at least in this case.

GolemOverARS~#OC#23911617#763#ARStest#Vanilla#Normal.save (1,654,700 bytes)

BadgerBadger

Nov 7, 2017 9:23 am

reporter   ~0046590

Here's a save where I'm repairing my damaged golem over capturing science/metal/fuel on a planet.

repairGolemOverNewCapture~#OC#23911617#1117#ARStest#Vanilla#Normal.save (1,663,782 bytes)

keith.lamothe

Nov 11, 2017 12:48 pm

administrator   ~0046598

For 0.604:

* Now when you have multiple claimable units at once, the cheaper ones are reclaimed first, to avoid a golem stalling capture of a planet's resources.

Both test cases pass now. I think in general this is the behavior people will want, but I'm thinking through a good model for giving the player input without requiring lots of extra clicks.

Thanks :)

Issue History

Date Modified Username Field Change
Nov 5, 2017 1:26 am BadgerBadger New Issue
Nov 7, 2017 8:03 am keith.lamothe Assigned To => keith.lamothe
Nov 7, 2017 8:03 am keith.lamothe Status new => feedback
Nov 7, 2017 8:03 am keith.lamothe Note Added: 0046583
Nov 7, 2017 9:17 am BadgerBadger Note Added: 0046588
Nov 7, 2017 9:17 am BadgerBadger Status feedback => assigned
Nov 7, 2017 9:20 am BadgerBadger File Added: GolemOverARS~#OC#23911617#763#ARStest#Vanilla#Normal.save
Nov 7, 2017 9:20 am BadgerBadger Note Added: 0046589
Nov 7, 2017 9:23 am BadgerBadger File Added: repairGolemOverNewCapture~#OC#23911617#1117#ARStest#Vanilla#Normal.save
Nov 7, 2017 9:23 am BadgerBadger Note Added: 0046590
Nov 11, 2017 12:48 pm keith.lamothe Status assigned => resolved
Nov 11, 2017 12:48 pm keith.lamothe Resolution open => fixed
Nov 11, 2017 12:48 pm keith.lamothe Fixed in Version => 0.604
Nov 11, 2017 12:48 pm keith.lamothe Note Added: 0046598