View Issue Details

IDProjectCategoryLast Update
0019229AI War 2[All Projects] Crash/ExceptionSep 8, 2017 7:52 am
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.516 
Fixed in Version0.517 
Summary0019229: Deserialization error on load game
DescriptionI tried to load a game about 40 minutes in. The Nanocaust was active. I hit the following crash:

Exception occurred during world deserialization:FormatException
Will now log details in WorldDeserializationErrors.txt

  at Arcen.Universal.ArcenDeserializationBuffer.TryReadInt32 (System.Boolean& WasSuccessful, Boolean ThrowExceptionOnFailure) [0x00248] in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\ArcenBuffers\ArcenDeserializationBuffer.cs:175
  at Arcen.Universal.ArcenDeserializationBuffer.ReadInt32 () [0x00005] in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\ArcenBuffers\ArcenDeserializationBuffer.cs:70
  at Arcen.AIW2.Core.GameEntity.DeserializeFrom (Arcen.AIW2.Core.CombatEncounter Combat, Arcen.AIW2.Core.CombatSide Side, Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x0037f] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\GameEntity\GameEntity.cs:449
  at Arcen.AIW2.Core.CombatSide.DeserializeFrom (Arcen.AIW2.Core.WorldSide WorldSide, Arcen.AIW2.Core.CombatEncounter Combat, Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x0005b] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\CombatEncounter\CombatSide.cs:95
  at Arcen.AIW2.Core.CombatEncounter.DeserializeFrom (Arcen.AIW2.Core.Planet ForPlanet, Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x00030] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\CombatEncounter\CombatEncounter.cs:68
  at Arcen.AIW2.Core.Planet.DeserializeFrom (Arcen.AIW2.Core.Galaxy ForGalaxy, Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x00047] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\Mapping\Planet.cs:245
  at Arcen.AIW2.Core.Galaxy.DeserializeFrom (Arcen.AIW2.Core.SetOfGalaxies ForSet, Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x00026] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\Mapping\Galaxy.cs:51
  at Arcen.AIW2.Core.SetOfGalaxies.DeserializeFrom (Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x0001f] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\Mapping\SetOfGalaxies.cs:129
  at Arcen.AIW2.Core.World_AIW2.DeserializeFrom (Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion DeserializingGameVersion) [0x00138] in C:\vcprojs\arcengames_aiw_ultra\ArcenAIW2Core\src\Logic\GameState\World_AIW2.cs:145
  at Arcen.Universal.World.DeserializeFrom (Arcen.Universal.ArcenDeserializationBuffer Buffer, Boolean IsLoadingFromNetwork, Arcen.Universal.GameVersion& DeserializingGameVersion) [0x00185] in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Logic\GameState\World.cs:122
  at Arcen.Universal.World.LoadWorldFromDiskInner (System.String SaveName, System.String Text) [0x0002a] in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Logic\GameState\World.cs:419
  at Arcen.Universal.World.LoadWorldFromDisk (System.String SaveName) [0x00050] in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Logic\GameState\World.cs:357

   at System.Environment.get_StackTrace() in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Environment.cs:line 227
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Boolean IncludeStackTrace, Verbosity Verbosity) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 140
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Verbosity Verbosity) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 109
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, Verbosity Verbosity) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 88
   at Arcen.Universal.World.LoadWorldExceptionHandling(System.Exception e) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Logic\GameState\World.cs:line 382
   at Arcen.Universal.World.LoadWorldFromDisk(System.String SaveName) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Logic\GameState\World.cs:line 373
   at Arcen.Universal.Engine_Universal.LoadGame(System.String SaveName) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\Engine_Universal.cs:line 1478
   at Arcen.AIW2.External.Window_LoadGameMenu+bLoadGameButton.HandleClick()
   at Arcen.Universal.ArcenUI_Button.OnClick(UnityEngine.EventSystems.PointerEventData eventData) in C:\vcprojs\arcengames_aiw_ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Button.cs:line 141

The DeserializationLog was larger than the max file size to upload so I have compressed it.
TagsNo tags attached.

Activities

BadgerBadger

Sep 6, 2017 10:34 pm

reporter  

WorldDeserializationErrors.txt.gz (229,710 bytes)

BadgerBadger

Sep 6, 2017 10:42 pm

reporter   ~0046451

I can reproduce this on a game w/o any special factions enabled, saving the game at about 10 seconds in. It just seems to be flat out busted. I replicated this problem (open AI War 2. Start a new game. Save immediately. Then quit to the main screen and try to reload it) also with all default settings, so it's not that.

BadgerBadger

Sep 6, 2017 11:01 pm

reporter   ~0046452

I can successfully load games from previous versions, just not the current version.

Issue History

Date Modified Username Field Change
Sep 6, 2017 10:34 pm BadgerBadger New Issue
Sep 6, 2017 10:34 pm BadgerBadger File Added: WorldDeserializationErrors.txt.gz
Sep 6, 2017 10:42 pm BadgerBadger Note Added: 0046451
Sep 6, 2017 11:01 pm BadgerBadger Note Added: 0046452
Sep 8, 2017 7:52 am keith.lamothe Assigned To => keith.lamothe
Sep 8, 2017 7:52 am keith.lamothe Status new => resolved
Sep 8, 2017 7:52 am keith.lamothe Resolution open => fixed
Sep 8, 2017 7:52 am keith.lamothe Fixed in Version => 0.517