View Issue Details

IDProjectCategoryLast Update
0019222AI War 2[All Projects] Crash/ExceptionAug 15, 2017 1:34 pm
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.509 Player Targets What? 
Fixed in Version0.510 Hotfix 
Summary0019222: array index out of range in shipIconButton.UpdateContent
DescriptionI started a new game. When I tried to open the build menu I hit
8/14/2017 8:08:38 PM Successfully opened host socket
8/14/2017 8:08:47 PM
Error occurred in sim planning context executionContext
System.IndexOutOfRangeException: Array index is out of range.
  at Arcen.AIW2.External.ShipIconButton.UpdateContent (Arcen.Universal.ArcenUIWrapperedUnityImage Image, .SubImage[] SubImages, Arcen.Universal.SubText[] SubTexts) [0x00000] in <filename unknow\
n>:0
  at Arcen.Universal.ArcenUI_ImageButton.OnSimStableUpdate () [0x000a6] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_ImageButton.cs:190
  at Arcen.Universal.ArcenUI_Window.OnSimStableUpdate () [0x00071] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Window.cs:87
  at Arcen.Universal.ArcenUI.OnSimStableUpdate () [0x00033] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI.cs:174
  at Arcen.AIW2.Core.SimExecution.Execute () [0x000aa] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimExecution\SimExecution.cs:41
  at Arcen.AIW2.Core.ArcenSimPlanningContext.InnerRun () [0x0002d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:82

   at System.Environment.get_StackTrace() in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Environment.cs:line 227
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Boolean IncludeStackTrace, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniv\
ersal\src\UtilityLibraries\ArcenDebugging.cs:line 140
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\\
ArcenDebugging.cs:line 109
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 88
   at Arcen.AIW2.Core.ArcenSimPlanningContext.InnerRun() in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:line 86
   at Arcen.AIW2.Core.ArcenExecutionContext.InnerRun() in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:line 223

TagsNo tags attached.

Activities

BadgerBadger

Aug 14, 2017 8:10 pm

reporter   ~0046429

Here's another simlar one

Error occurred in sim planning context executionContext
System.IndexOutOfRangeException: Array index is out of range.
  at Arcen.AIW2.External.ShipIconButton.UpdateContent (Arcen.Universal.ArcenUIWrapperedUnityImage Image, .SubImage[] SubImages, Arcen.Universal.SubText[] SubTexts) [0x00000] in <filename unknow\
n>:0
  at Arcen.AIW2.External.Window_InGameBuildQueueMenu+bQueueItem.UpdateContent (Arcen.Universal.ArcenUIWrapperedUnityImage Image, .SubImage[] SubImages, Arcen.Universal.SubText[] SubTexts) [0x00\
000] in <filename unknown>:0
  at Arcen.Universal.ArcenUI_ImageButton.OnSimStableUpdate () [0x000a6] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_ImageButton.cs:190
  at Arcen.Universal.ArcenUI_Window.OnSimStableUpdate () [0x00071] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Window.cs:87
  at Arcen.Universal.ArcenUI.OnSimStableUpdate () [0x00033] in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI.cs:174
  at Arcen.AIW2.Core.SimExecution.Execute () [0x000aa] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimExecution\SimExecution.cs:41
  at Arcen.AIW2.Core.ArcenSimPlanningContext.InnerRun () [0x0002d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:82

   at System.Environment.get_StackTrace() in /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Environment.cs:line 227
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Boolean IncludeStackTrace, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniv\
ersal\src\UtilityLibraries\ArcenDebugging.cs:line 140
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, DebugLogDestination Destination, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\\
ArcenDebugging.cs:line 109
   at Arcen.Universal.ArcenDebugging.ArcenDebugLog(System.String Message, Verbosity Verbosity) in D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:line 88
   at Arcen.AIW2.Core.ArcenSimPlanningContext.InnerRun() in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:line 86
   at Arcen.AIW2.Core.ArcenExecutionContext.InnerRun() in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:line 223

BadgerBadger

Aug 14, 2017 8:12 pm

reporter   ~0046430

100% reproduction rate opening the Ark build menu

BadgerBadger

Aug 14, 2017 8:24 pm

reporter   ~0046431

Also I hit this when opening the Tech Menu. I think .509 is Dead On Arrival and unplayable, and would recommend noone try to use it.

x4000Bughunter

Aug 15, 2017 12:19 pm

administrator   ~0046432

Thanks!

* Previously, there were cases where we had one prefab referencing another prefab inside the modding and gui project. This was convenient!
** However, it turns out that when the child prefab is updated, it doesn't flag the parent as also updated, and no amount of fiddling makes it trigger that flag.
*** That, in turn, means that the child of the parent winds up not being properly sent to players via the build.
** To get around that, we're no longer referencing one prefab from another within the asset bundles themselves.
*** Instead we're creating those linkages in our own prefab xml setup using the new xml tags has_child_prefab, child_prefab_bundle, and child_prefab_filename.
*** Note that this doesn't have any effect on prefabs like the Dropdown, which reference elements INSIDE their own existing .prefab file. That's perfectly fine. The problem was when one .prefab file was referencing some completely other .prefab file.
** This is what was causing the mysterious index out of range exceptions in the prior version.

BadgerBadger

Aug 15, 2017 1:32 pm

reporter   ~0046433

Ugh, that sounds like an awful problem to debug. Glad you figured it out!

x4000Bughunter

Aug 15, 2017 1:34 pm

administrator   ~0046434

I was lucky that I immediately knew what the problem was from past experience, so that took a lot of the time away from it. But then figuring out what to do about it was bad enough!

Issue History

Date Modified Username Field Change
Aug 14, 2017 8:09 pm BadgerBadger New Issue
Aug 14, 2017 8:10 pm BadgerBadger Note Added: 0046429
Aug 14, 2017 8:12 pm BadgerBadger Severity minor => major
Aug 14, 2017 8:12 pm BadgerBadger Note Added: 0046430
Aug 14, 2017 8:24 pm BadgerBadger Note Added: 0046431
Aug 15, 2017 12:19 pm x4000Bughunter Assigned To => x4000Bughunter
Aug 15, 2017 12:19 pm x4000Bughunter Status new => resolved
Aug 15, 2017 12:19 pm x4000Bughunter Resolution open => fixed
Aug 15, 2017 12:19 pm x4000Bughunter Fixed in Version => 0.510 Hotfix
Aug 15, 2017 12:19 pm x4000Bughunter Note Added: 0046432
Aug 15, 2017 1:32 pm BadgerBadger Note Added: 0046433
Aug 15, 2017 1:34 pm x4000Bughunter Note Added: 0046434