View Issue Details

IDProjectCategoryLast Update
0019204AI War 2[All Projects] Bug - GameplayAug 8, 2017 11:27 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.501 Test And Revise Pass #1 
Fixed in Version 
Summary0019204: Negative time for Next AI Wave
DescriptionWhen you go to the debug menu and click "Spawn AI Wave", a wave does not actually spawn and the timer for "next wave" becomes negative.

Here is a picture and a saved game
TagsNo tags attached.

Activities

BadgerBadger

Jul 11, 2017 1:13 pm

reporter  

negativeWave~#NB#923522605#92#Negative#Vanilla#Normal.save (1,183,076 bytes)

BadgerBadger

Jul 11, 2017 1:13 pm

reporter  

next_wave_negative_time.png (1,083,942 bytes)

keith.lamothe

Aug 7, 2017 4:25 pm

administrator   ~0046419

No longer able to reproduce this. Not sure what changed, but both "natural" and debug-caused waves seem to be working fine now :)

BadgerBadger

Aug 7, 2017 4:32 pm

reporter   ~0046420

Bizarre. It was definitely happening on .506, and none of the changes currently in for .507 look like they could have influenced this... But hey, never look a gift horse in the mouth!

BadgerBadger

Aug 8, 2017 5:12 pm

reporter   ~0046421

I hit this one in .507 again. Here's a save game

negativeWaves~#CI#157286921#935#negativeWave#Vanilla#Normal.save (1,158,812 bytes)

BadgerBadger

Aug 8, 2017 5:18 pm

reporter   ~0046422

On further reflection, I think this only reproduces when you have player mods from the ~/AIWar2/XMLData directory.

BadgerBadger

Aug 8, 2017 6:23 pm

reporter   ~0046423

Upon even further reflection I am now hitting the problem all the time again. Very strange. Does it happen for you on my saved games?

BadgerBadger

Aug 8, 2017 6:31 pm

reporter   ~0046424

Okay, I think I finally figured this one out (again!) This only seems to reproduce if "Start with first planet" is set to "Yes". Try reproducing with that.

BadgerBadger

Aug 8, 2017 11:27 pm

reporter   ~0046426

I've seen a few instances where the AI Wave counter is messed up. The "side.StoredStrengthByBudget" for the AIBudgetType.Wave winds up being > the threshhold.

So it will show things like "Next wave in -50s(3000/1500)" which should be impossible since the AI Wave budget is > the threshold to send a new wave.

Issue History

Date Modified Username Field Change
Jul 11, 2017 1:13 pm BadgerBadger New Issue
Jul 11, 2017 1:13 pm BadgerBadger File Added: negativeWave~#NB#923522605#92#Negative#Vanilla#Normal.save
Jul 11, 2017 1:13 pm BadgerBadger File Added: next_wave_negative_time.png
Aug 7, 2017 4:25 pm keith.lamothe Assigned To => keith.lamothe
Aug 7, 2017 4:25 pm keith.lamothe Status new => resolved
Aug 7, 2017 4:25 pm keith.lamothe Resolution open => fixed
Aug 7, 2017 4:25 pm keith.lamothe Note Added: 0046419
Aug 7, 2017 4:32 pm BadgerBadger Note Added: 0046420
Aug 8, 2017 5:12 pm BadgerBadger File Added: negativeWaves~#CI#157286921#935#negativeWave#Vanilla#Normal.save
Aug 8, 2017 5:12 pm BadgerBadger Note Added: 0046421
Aug 8, 2017 5:18 pm BadgerBadger Note Added: 0046422
Aug 8, 2017 6:23 pm BadgerBadger Note Added: 0046423
Aug 8, 2017 6:31 pm BadgerBadger Note Added: 0046424
Aug 8, 2017 11:27 pm BadgerBadger Note Added: 0046426