View Issue Details

IDProjectCategoryLast Update
0019179AI War 2[All Projects] Gameplay IssueJun 15, 2017 11:04 am
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionno change required 
Product Version0.401 Ship Batch 6 of 7, And Gimbal Perfoooormance! 
Fixed in Version 
Summary0019179: Modifying hotkeys in KDL_InputActions.xml doesn't seem to work
DescriptionI tried changing the hotkey for pause thusly:
  <input_action name="TogglePause"
              display_name="Pause"
              description="~*~"
              dll_name="AIWarExternalCode"
              type_name="Arcen.AIW2.External.Input_MainHandler"
              default_key="L" <=== This was "P" before
  >

Then I closed and reopened the game. However, the change doesn't seem to do anything. "P" still works for pause, and L doesn't do anything. Am I missing something?
TagsNo tags attached.

Activities

x4000Bughunter

Jun 15, 2017 10:31 am

administrator   ~0046287

Yep -- you're modifying the defaults, not your personal keybindings. Your personal keybindings are in the PlayerData folder, and since those are already populated that means that changing the defaults does nothing (by design). If you delete your personal settings, then the defaults would properly apply.

Most games don't let you adjust the defaults like this, hence the confusion. but if you're just looking for personal keybindings to be the way you want, you should edit the stuff in PlayerData and not mod the defaults of the game in order to get what you want.

BadgerBadger

Jun 15, 2017 10:34 am

reporter   ~0046288

Great, thanks! I'll give that a try later

x4000Bughunter

Jun 15, 2017 11:04 am

administrator   ~0046289

Sure thing!

Issue History

Date Modified Username Field Change
Jun 15, 2017 10:11 am BadgerBadger New Issue
Jun 15, 2017 10:31 am x4000Bughunter Note Added: 0046287
Jun 15, 2017 10:31 am x4000Bughunter Status new => closed
Jun 15, 2017 10:31 am x4000Bughunter Assigned To => x4000Bughunter
Jun 15, 2017 10:31 am x4000Bughunter Resolution open => no change required
Jun 15, 2017 10:34 am BadgerBadger Note Added: 0046288
Jun 15, 2017 11:04 am x4000Bughunter Note Added: 0046289