View Issue Details

IDProjectCategoryLast Update
0019175AI War 2[All Projects] GUIAug 3, 2017 8:20 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.401 Ship Batch 6 of 7, And Gimbal Perfoooormance! 
Fixed in Version0.505 Tooltips And Build Menu 
Summary0019175: Confusingly overlapping menus
DescriptionIf you have one menu open and then open another one, you get a strange overlay of menu items on top of each other. An example: I have the build menu for the Starship Constructor open. I then click to open the Tech menu. Now I have elements of the tech menu on top of the build menu, and there's no obvious distinction between them. It looks like Mark1 Shield Starship is something I could research.

Suggested fixes off the top of my head: auto close existing menus when a new one is opened.
Have a different button font for "this menu element is in the background".
TagsNo tags attached.

Activities

BadgerBadger

Jun 13, 2017 11:01 am

reporter  

overlapping_menus.png (1,244,046 bytes)

BadgerBadger

Jul 8, 2017 1:23 am

reporter   ~0046382

I think this one might have been fixed in .501 (or something between .401 and .501). If I spot it again I'll comment with clearer reproduction instructions. Otherwise go ahead and close.

x4000Bughunter

Aug 3, 2017 8:20 pm

administrator   ~0046406

Should be all fixed now, thanks!

Issue History

Date Modified Username Field Change
Jun 13, 2017 11:01 am BadgerBadger New Issue
Jun 13, 2017 11:01 am BadgerBadger File Added: overlapping_menus.png
Jun 19, 2017 8:37 pm x4000Bughunter Assigned To => keith.lamothe
Jun 19, 2017 8:37 pm x4000Bughunter Status new => assigned
Jul 8, 2017 1:23 am BadgerBadger Note Added: 0046382
Aug 3, 2017 8:20 pm x4000Bughunter Status assigned => resolved
Aug 3, 2017 8:20 pm x4000Bughunter Resolution open => fixed
Aug 3, 2017 8:20 pm x4000Bughunter Fixed in Version => 0.505 Tooltips And Build Menu
Aug 3, 2017 8:20 pm x4000Bughunter Note Added: 0046406