View Issue Details

IDProjectCategoryLast Update
0019113AI War 2[All Projects] Graphical BugJan 27, 2018 11:50 am
ReporterBadgerBadgerAssigned To 
Severityminor 
Status closedResolutionduplicate 
Product Version0.200 Decisive Battle 
Fixed in Version0.703 
Summary0019113: Can't see any objects on planet
DescriptionI had conquered this planet a bit ago, then moved my fleet on. When I look back at this planet, I don't see any objects at all! No wormholes, no nothing. As soon as I brought ships back to it though, it came back and seemed to be fine (and the planet was neutral).

Here is a saved game and a picture. Note in the picture there is nothing visible, but if you use the saved game to take my fleet back to the planet you will then be able to see wormholes again.

Some mods (extra strong ark, bonus starting techs) are in use.
TagsNo tags attached.

Relationships

duplicate of 0019358 closedBadgerBadger Sidebar shows me enemy ships even when I can't see them. 
related to 0019359 assignedx4000Bughunter Should still be able to see all NaturalObject items and ships on planets with no intel. 

Activities

BadgerBadger

May 18, 2017 8:16 am

manager  

No structures at all visible on planet.png (1,312,730 bytes)

BadgerBadger

May 18, 2017 8:16 am

manager  

NewSave_10.save (1,183,569 bytes)

BadgerBadger

Oct 3, 2017 4:14 pm

manager   ~0046481

This is still an issue on .522. Here's a saved game showing it (go to planet Pausch and you won't see anything).

cantSeePausch~#GR#536705799#1070#cantSee#Vanilla#Normal.save (1,550,357 bytes)

BadgerBadger

Oct 3, 2017 4:16 pm

manager   ~0046482

This may be a valuable clue. On Loading the saved game cantSeePausch, you won't be able to view anything on the planet. However, if you take the Ark and move it into a planet adjacent to Pausch (Ward, for example), the ships on Pausch will immediately become visible.

BadgerBadger

Oct 9, 2017 12:19 pm

manager   ~0046513

You know, I think from the description in the tutorial about sensors, this is actually working as designed. If so then there needs to be some sort of improvement to the UI to make it clear that you shouldn't be able to see what's on the planet. Right now it feels like a weird bug.

x4000Bughunter

Jan 26, 2018 1:01 pm

administrator   ~0046737

Do you think that you could make a little GUI window that shows up in the center of the screen saying "NO INTEL AVAILABLE" large, and then "All Sensors Out Of Range" under that? Not nearly so large as the You Lose text, but still a think. For that matter, after the "You Lose" text is gone (the fiery part), then having this same sort of window that has a more small and calm "You Lose" message would be good. Two birds with one stone, really.

BadgerBadger

Jan 26, 2018 2:18 pm

manager   ~0046747

If we had an in-game message window then both such messages could be put there (the "no vision" message should be large and distinctive)

x4000Bughunter

Jan 26, 2018 4:19 pm

administrator   ~0046752

The main thing about an in-game message window is that ideally everything in that window is temporary. Chat messages that go by, etc. For things like this, I'd see this as being an ongoing central message.

Heck, for planets where there is attrition going on and people are wondering "why is this glowing and I'm taking damage?" it would be helpful to have that sort of central message, too. Basically this would be an upper-center "general status at the moment" message place. Blank most of the time.

Issue History

Date Modified Username Field Change
May 18, 2017 8:16 am BadgerBadger New Issue
May 18, 2017 8:16 am BadgerBadger File Added: No structures at all visible on planet.png
May 18, 2017 8:16 am BadgerBadger File Added: NewSave_10.save
May 18, 2017 4:11 pm x4000Bughunter Assigned To => keith.lamothe
May 18, 2017 4:11 pm x4000Bughunter Status new => assigned
Oct 3, 2017 4:14 pm BadgerBadger File Added: cantSeePausch~#GR#536705799#1070#cantSee#Vanilla#Normal.save
Oct 3, 2017 4:14 pm BadgerBadger Note Added: 0046481
Oct 3, 2017 4:16 pm BadgerBadger Note Added: 0046482
Oct 9, 2017 12:19 pm BadgerBadger Note Added: 0046513
Jan 26, 2018 1:01 pm x4000Bughunter Note Added: 0046737
Jan 26, 2018 1:04 pm x4000Bughunter Relationship added related to 0019359
Jan 26, 2018 2:18 pm BadgerBadger Note Added: 0046747
Jan 26, 2018 4:19 pm x4000Bughunter Note Added: 0046752
Jan 27, 2018 11:50 am BadgerBadger Assigned To keith.lamothe =>
Jan 27, 2018 11:50 am BadgerBadger Status assigned => closed
Jan 27, 2018 11:50 am BadgerBadger Resolution open => duplicate
Jan 27, 2018 11:50 am BadgerBadger Fixed in Version => 0.703
Jan 27, 2018 11:50 am BadgerBadger Relationship added duplicate of 0019358