View Issue Details

IDProjectCategoryLast Update
0019109AI War 2[All Projects] Gameplay IssueMay 18, 2017 3:28 pm
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.200 Decisive Battle 
Fixed in Version0.201 Bugfixes and Optimizations 
Summary0019109: Fabricator reports 0 engine power
DescriptionWhen I moused over an experimental fabricator, I note it has 0 engines. I wasn't aware that the AI was equipping its fabricators with engines. I definitely can't move it.

We probably don't want to show the Engine strength on structures
TagsNo tags attached.

Activities

BadgerBadger

May 17, 2017 7:38 pm

reporter  

Fab without engines.png (1,603,310 bytes)

BadgerBadger

May 17, 2017 7:38 pm

reporter  

NewSave_1.save (1,223,642 bytes)

x4000Bughunter

May 18, 2017 3:28 pm

administrator   ~0046177

Thanks!

* Apparently it was possible for ships to lose engine health without even having engine health, and then they would start showing up as not having any engine health.
** Fixed the display issue, although the issue of engine health going down when no max engine health is untouched. Not really sure from the code how that could possibly happen.

Issue History

Date Modified Username Field Change
May 17, 2017 7:38 pm BadgerBadger New Issue
May 17, 2017 7:38 pm BadgerBadger File Added: Fab without engines.png
May 17, 2017 7:38 pm BadgerBadger File Added: NewSave_1.save
May 18, 2017 3:28 pm x4000Bughunter Note Added: 0046177
May 18, 2017 3:28 pm x4000Bughunter Status new => resolved
May 18, 2017 3:28 pm x4000Bughunter Fixed in Version => 0.201 Bugfixes and Optimizations
May 18, 2017 3:28 pm x4000Bughunter Resolution open => fixed
May 18, 2017 3:28 pm x4000Bughunter Assigned To => x4000Bughunter