View Issue Details

IDProjectCategoryLast Update
0019092AI War 2[All Projects] SuggestionFeb 15, 2018 4:25 pm
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.122 Ship Batch 3 of 7: 14 Ships! 
Fixed in Version0.707 
Summary0019092: Wormhole name not visible under ship icons
DescriptionI built a big fleet and put it right next to a wormhole. The icons of the ship made the planet name unreadable. I feel like it would be better to make sure the wormhole name was visible.

TagsNo tags attached.

Activities

BadgerBadger

May 3, 2017 8:19 pm

manager  

Wormhole name not visible under icons.jpg (446,646 bytes)

x4000Bughunter

May 4, 2017 9:53 am

administrator   ~0046106

This is basically by design -- it's doing proper depth sorting, etc, since otherwise it looks pretty odd or can get in the way of seeing things depending on your view angle.

But being able to see it pop to the front when holding Ctrl or something (since that's the interact with wormholes button) would make sense, I think.

BadgerBadger

May 4, 2017 10:03 am

manager   ~0046109

I think having Ctrl make the names pop over my fleet would be a fine solution.

BadgerBadger

May 19, 2017 7:53 pm

manager   ~0046189

This is one of those "quality of life" improvements that would be really nice before early access goes out.

BadgerBadger

Feb 1, 2018 10:33 am

manager   ~0046812

I'm having trouble figuring out how to actually make a wormhole name be the "Highest thing" in the visual stack (so it will go over icons, etc). Any advice?

x4000Bughunter

Feb 1, 2018 11:17 am

administrator   ~0046813

That's not really possible, at present. It's a 3D object being drawn like any other 3D object, and it's located where it's located. In the shader for it, I could turn off z depth checking and z writing, but there's still no guarantee it would be shown absolutely on top. There's also another approach where we fake add a certain amount of z offset in the shader, or switch this to a different shader batch queue, like overlay, which I don't think I'm using at the moment. A more extreme solution would be to use a secondary camera, which is both easier but also more resource-wasteful. In that case we'd just switch the layer of the gameobject of the text, and have two separate layers that are drawn by different cameras.

Now, that secondary "extreme" solution would be a heck of a lot more flexible and future-proof, as well as letting us "pull things in front of everything else except the GUI" whenever we felt like it just by changing the layer of the object. That would probably have some general usefulness for us and for modders, so the extra expense of the second camera layer is probably worth it. That extra expense, on new hardware, is honestly unlikely make people drop even a single fps, so "expense" is relative.

BadgerBadger

Feb 1, 2018 11:58 am

manager   ~0046814

There are a couple places where we need to put one layer explicitly over another (for example, tooltips from the resource bar should hover over the right hand sidebar as well).

x4000Bughunter

Feb 1, 2018 12:31 pm

administrator   ~0046816

The GUI is a different beast, because it's not operating in camera space at all, but rather is in ui overlay space. So that would work differently, but Keith would have notes on how to do that.

x4000Bughunter

Feb 15, 2018 4:25 pm

administrator   ~0046988

* If you are holding down Ctrl (or whatever button is configured to send you through wormholes on left-click), then the wormhole names now pop forward above everything else for you to view them.
** As part of this, there's new code demonstrating that any unity GameObject that is set to have its layer as 24 will now be drawn by a new overlay camera that is higher than everything but the GUI.

Issue History

Date Modified Username Field Change
May 3, 2017 8:19 pm BadgerBadger New Issue
May 3, 2017 8:19 pm BadgerBadger File Added: Wormhole name not visible under icons.jpg
May 4, 2017 9:53 am x4000Bughunter Note Added: 0046106
May 4, 2017 10:03 am BadgerBadger Note Added: 0046109
May 19, 2017 7:53 pm BadgerBadger Note Added: 0046189
Jun 19, 2017 8:58 pm x4000Bughunter Assigned To => x4000Bughunter
Jun 19, 2017 8:58 pm x4000Bughunter Status new => assigned
Dec 22, 2017 10:07 pm BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Feb 1, 2018 10:33 am BadgerBadger Note Added: 0046812
Feb 1, 2018 11:17 am x4000Bughunter Note Added: 0046813
Feb 1, 2018 11:58 am BadgerBadger Note Added: 0046814
Feb 1, 2018 12:31 pm x4000Bughunter Note Added: 0046816
Feb 2, 2018 11:59 am x4000Bughunter Assigned To BadgerBadger => x4000Bughunter
Feb 15, 2018 4:25 pm x4000Bughunter Status assigned => resolved
Feb 15, 2018 4:25 pm x4000Bughunter Resolution open => fixed
Feb 15, 2018 4:25 pm x4000Bughunter Fixed in Version => 0.707
Feb 15, 2018 4:25 pm x4000Bughunter Note Added: 0046988