View Issue Details

IDProjectCategoryLast Update
0019084AI War 2[All Projects] Graphical BugMay 8, 2018 11:32 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionreopened 
Product Version0.120 Bugfixes 
Fixed in Version0.745 A Pivot And A Leap Forward 
Summary0019084: Ship models oscillate quickly back and forth
DescriptionI have noticed a couple times that I'll get into a fight and I can see enemy ship models oscillate very rapidly back and forth. By this I mean the models will jump very rapidly between the possible placements for ships in the squad. I have observed this most readily with ships that don't have official painted models yet. I know I've seen this twice with Raiders. I'm not sure how to capture debug data for this, given that I don't have an efficient means of capturing video for this.

No errors in logs have correlated with this. This has only been visible once half (or so) the ships in the squad have been destroyed.
TagsNo tags attached.

Activities

x4000Bughunter

May 9, 2017 10:27 pm

administrator   ~0046125

This _should_ be fixed now, as part of some other fixes we did. Fingers crossed!

BadgerBadger

May 10, 2017 12:23 pm

manager   ~0046138

Nope, still reproduces. Check out this image with the autocannons; the ship models are shuttling back and forth along the flame trails repeatedly.

BadgerBadger

May 10, 2017 12:23 pm

manager  

Funky Autocannons.jpg (527,768 bytes)

x4000Bughunter

May 10, 2017 12:32 pm

administrator   ~0046140

Savegame?

BadgerBadger

May 10, 2017 12:52 pm

manager   ~0046143

Last edited: May 10, 2017 3:30 pm

View 3 revisions

Take a look at the battle on Rabin; there are a number of ship groups near the enemy shield wall exhibiting this behaviour.

Whelp, on second thought the save game is too large to upload (3.5 MB). I can try to reproduce again, or you can suggest another mechanism for sending it to you.

Edit: uploaded the file gzipped

x4000Bughunter

May 10, 2017 12:53 pm

administrator   ~0046145

Thanks again! :)

BadgerBadger

May 10, 2017 3:30 pm

manager  

NewSave_1.save.gz (176,569 bytes)

BadgerBadger

May 18, 2017 11:39 am

manager   ~0046175

This still happens on .200

BadgerBadger

Jul 10, 2017 12:28 am

manager   ~0046391

You can reproduce this problem sometimes by taking a game and turning the speed up significantly. This saved game does it for me. Load the game then turn the speed up a bunch.

WobbleReproducer~#CO#923522605#28#wobbly#Vanilla#Normal.save (1,159,104 bytes)

x4000Bughunter

Oct 3, 2017 11:38 am

administrator   ~0046475

Maybe fixed recently?

BadgerBadger

Oct 9, 2017 12:16 pm

manager   ~0046512

It seems to be fixed for normal speeds (I haven't observed it recently), but if you turn the game speed up then you definitely still see it.

x4000Bughunter

Oct 9, 2017 2:47 pm

administrator   ~0046514

Thanks for the update!

x4000Bughunter

Feb 26, 2018 2:29 pm

administrator   ~0047079

Still a thing on higher speeds?

BadgerBadger

Feb 26, 2018 2:31 pm

manager   ~0047084

Yup. Reproduction scenario: start a new game with your ark auto-queued to build ships. Turn up the speed (both + and ctl-+). You will observe the problem.

x4000Bughunter

Feb 26, 2018 2:36 pm

administrator   ~0047086

Thanks for checking. If you have a chance at some point, could you run a debug check on that if you get a chance and see if the oscillation exists in the sim layer, or if it's just a vis-layer glitch? Somehow I have the feeling it's the former. But if it's the latter, then this is a problem for either you or I, not Keith.

BadgerBadger

Feb 28, 2018 12:07 pm

manager   ~0047098

I threw some logging into the Vis layer and I can see the selfT.position for squads wobbling back and forth. As far as I know, the Vis layer doesn't change the selfT.position, that's set in the Sim code.

Also, this only occurs if you are using the Coarse sim steps. If you speed the game up using just "+" then it's fine. You only see it when using ctl-+.

x4000Bughunter

Feb 28, 2018 12:13 pm

administrator   ~0047099

Sounds like a sim thing, then, yes -- thanks for that!

BadgerBadger

May 8, 2018 11:32 pm

manager   ~0047546

Fixed in .744 by Keith

Issue History

Date Modified Username Field Change
Apr 25, 2017 10:56 pm BadgerBadger New Issue
May 9, 2017 10:27 pm x4000Bughunter Note Added: 0046125
May 9, 2017 10:27 pm x4000Bughunter Status new => resolved
May 9, 2017 10:27 pm x4000Bughunter Fixed in Version => 0.123 Ship Batch 4 of 7, And A Metric Ton of Improvements
May 9, 2017 10:27 pm x4000Bughunter Resolution open => fixed
May 9, 2017 10:27 pm x4000Bughunter Assigned To => x4000Bughunter
May 10, 2017 12:23 pm BadgerBadger Note Added: 0046138
May 10, 2017 12:23 pm BadgerBadger File Added: Funky Autocannons.jpg
May 10, 2017 12:32 pm x4000Bughunter Note Added: 0046140
May 10, 2017 12:32 pm x4000Bughunter Status resolved => feedback
May 10, 2017 12:32 pm x4000Bughunter Resolution fixed => reopened
May 10, 2017 12:52 pm BadgerBadger Note Added: 0046143
May 10, 2017 12:52 pm BadgerBadger Status feedback => assigned
May 10, 2017 12:53 pm x4000Bughunter Note Added: 0046145
May 10, 2017 12:53 pm BadgerBadger Note Edited: 0046143 View Revisions
May 10, 2017 3:30 pm BadgerBadger File Added: NewSave_1.save.gz
May 10, 2017 3:30 pm BadgerBadger Note Edited: 0046143 View Revisions
May 18, 2017 11:39 am BadgerBadger Note Added: 0046175
Jul 10, 2017 12:28 am BadgerBadger File Added: WobbleReproducer~#CO#923522605#28#wobbly#Vanilla#Normal.save
Jul 10, 2017 12:28 am BadgerBadger Note Added: 0046391
Oct 3, 2017 11:38 am x4000Bughunter Note Added: 0046475
Oct 3, 2017 11:38 am x4000Bughunter Assigned To x4000Bughunter => keith.lamothe
Oct 9, 2017 12:16 pm BadgerBadger Note Added: 0046512
Oct 9, 2017 2:47 pm x4000Bughunter Note Added: 0046514
Feb 26, 2018 2:29 pm x4000Bughunter Status assigned => feedback
Feb 26, 2018 2:29 pm x4000Bughunter Note Added: 0047079
Feb 26, 2018 2:31 pm BadgerBadger Note Added: 0047084
Feb 26, 2018 2:31 pm BadgerBadger Status feedback => assigned
Feb 26, 2018 2:36 pm x4000Bughunter Note Added: 0047086
Feb 28, 2018 12:07 pm BadgerBadger Note Added: 0047098
Feb 28, 2018 12:13 pm x4000Bughunter Note Added: 0047099
May 8, 2018 11:32 pm BadgerBadger Status assigned => resolved
May 8, 2018 11:32 pm BadgerBadger Fixed in Version 0.123 Ship Batch 4 of 7, And A Metric Ton of Improvements => 0.745 A Pivot And A Leap Forward
May 8, 2018 11:32 pm BadgerBadger Note Added: 0047546