View Issue Details

IDProjectCategoryLast Update
0018983AI War 2[All Projects] SuggestionJan 11, 2018 12:39 pm
ReporterdfinlayAssigned Tokeith.lamothe 
Severityminor 
Status closedResolutionfixed 
Product Version0.102 
Fixed in Version0.612 
Summary0018983: Starting in Combat doesn't seem like the best idea
DescriptionI'm not sure if this is intended to be in the final release or not, but starting in combat doesn't seem great. The game is intimidating enough for new players (and even people who aren't new) without immediately being thrown into combat. A bit of time to check over your empire, figure out the controls, tweak your build queues (I know build queues are already set up but still) and figure out how you want to play is good before being thrown into combat. If the issue is that the early game wasn't actiony enough, you could have it set up to have an incoming wave in 5 mins or so right from the start, but I feel like starting in combat just doesn't feel great.
TagsNo tags attached.

Activities

keith.lamothe

Mar 2, 2017 1:45 pm

administrator   ~0045837

I'm leaning towards having it be this way, yes, and some players like the idea. Feel free to discuss it in the forums.

x4000Bughunter

May 9, 2017 11:05 pm

administrator   ~0046134

One of my thoughts is simply having the starting world barren of enemy combatants. So you can choose to capture the planet or not (thus incurring an AIP cost or not), but you don't have a fight right away.

Of course, for testing it's super useful having the fight right away, so having a lobby option or whatever for that would be nice. :)

BadgerBadger

Jan 11, 2018 12:39 pm

manager   ~0046665

You no longer start the game in combat

Issue History

Date Modified Username Field Change
Mar 2, 2017 1:16 pm dfinlay New Issue
Mar 2, 2017 1:45 pm keith.lamothe Note Added: 0045837
Mar 2, 2017 1:45 pm keith.lamothe Category Gameplay Issue => Suggestion
Mar 2, 2017 1:47 pm keith.lamothe Assigned To => keith.lamothe
Mar 2, 2017 1:47 pm keith.lamothe Status new => acknowledged
May 9, 2017 11:05 pm x4000Bughunter Note Added: 0046134
Jan 11, 2018 12:39 pm BadgerBadger Status acknowledged => closed
Jan 11, 2018 12:39 pm BadgerBadger Resolution open => fixed
Jan 11, 2018 12:39 pm BadgerBadger Fixed in Version => 0.612
Jan 11, 2018 12:39 pm BadgerBadger Note Added: 0046665