View Issue Details

IDProjectCategoryLast Update
0015638AI War[All Projects] Bug - OtherAug 9, 2014 4:13 pm
ReporterAdamMilAssigned To 
Severityminor 
Status newResolutionopen 
Product Version7.055 
Fixed in Version 
Summary0015638: planet-specific auto build engineers (etc) builds the wrong number
DescriptionIf I set the global auto build settings to build 2 Mk I engineers and the per-planet setting to build 1 Mk I engineer, it instead builds 3 (2+1). If I set the global setting to 1 and the per-planet setting to 5, it builds 6 (1+5).

This makes it impossible to have per-planet settings lower than the global settings. It didn't used to be like this (?).

This problem also happens with rebuilders.
TagsNo tags attached.
Internal Weight

Relationships

duplicate of 0000899 consideringx4000Bughunter Allow per planet settings to (completely) override galaxy-wide auto construction options. 

Activities

AdamMil

Aug 9, 2014 4:13 pm

reporter   ~0038935

I've implemented an experimental version of this in a mod: http://www.arcengames.com/forums/index.php/topic,16085.0.html

Hopefully the devs will eventually include it in the base game.

Issue History

Date Modified Username Field Change
Aug 7, 2014 3:36 am AdamMil New Issue
Aug 7, 2014 3:36 am AdamMil Description Updated View Revisions
Aug 7, 2014 3:48 am AdamMil Summary planet-specific auto build engineers (etc?) builds the wrong number => planet-specific auto build engineers (etc) builds the wrong number
Aug 7, 2014 3:48 am AdamMil Description Updated View Revisions
Aug 7, 2014 5:34 am AdamMil Relationship added duplicate of 0000899
Aug 7, 2014 5:38 am AdamMil Description Updated View Revisions
Aug 9, 2014 4:13 pm AdamMil Note Added: 0038935