View Issue Details

IDProjectCategoryLast Update
0007649AVWW[All Projects] SuggestionMay 8, 2012 9:12 pm
ReporterBluddyAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionwon't fix 
Product Version1.010 
Fixed in Version 
Summary0007649: Removing the focus from missions
DescriptionOK so I don't mind if you close this right away. I just want to give my honest opinion of changes that IMO would really help the game. I'm already including the strategy elements that I assume you want to bring back in this plan.

I recently had a chance to play a long stretch of the game, which I hadn't had in a long time. This, coupled with the fact that the store makes it very easy to upgrade your characters, meant that I could really get a sense of the macro game. My reaction after playing several missions was: "Seriously, you're going to force me to repeat this mission thing 15 times?"

IMO the strength of the game is in targeted exploration (not so much open exploration which the randomness of the game is currently unable to support well) and killing enemies. These two things are really fun and the game does them well. You choose what you want to get, and you go find it, killing monsters along the way, and maybe getting a little distracted. The problem is that the current game structure emphasizes missions as the focus of the game rather than the fun part of the game.

Missions are self-enclosed mini-games rather than being fully integrated into the structure of the game, and even though they provide variety, the player doesn't want to be forced to repeat these mini-games over and over. As mini-games, they don't have the strength and structure of the main game and they never can. They should not be the focal point IMO.

There's another, more minor issue -- the current structure allows you (and somewhat encourages you) to breeze through the missions, since you get rewards through missions. This can quickly get you in trouble (as happened to Tom Chick). Missions are simply emphasized too much currently.

This is where my suggestion comes in. Remember, this includes the strategy component: there needs to be something that advances time as in the old strategy gameplay where we you clicked to make time flow. The missions are a step in the right direction from that perspective: rather than being something orthogonal and disconnected from the gameplay, you advance time by doing something active in the game world. That's a good thing. But my suggestion is that rather than have missions be forced on the player, they should be optional. Missions (mini-games) are always best when they're optional -- when they're something the player can choose to do if he's tired of the other gameplay elements and wants a little change. But the main structure of the game should emphasize the game's strengths.

Currently, missions give you tier orbs and guardian scrolls, which are essential to the rationing of the game, and resources, which IMO send the wrong message. You only get a certain number of tier orbs to upgrade your spells with, which is the rationing that's essential to the strategy of the game. This rationing is tied in to the tiers advancing, and therefore (with the strategy element, once that's put in) to the enemy's actions in the world. Why not separate out this part -- the part of making time progress and giving tier orbs/guardian scrolls? This could be done by using 'time crystals' which have to be destroyed.

Destroying a time crystal would not be such a fancy thing. It would be in a random chunk, and would thus benefit from the randomness of the rest of the game. Sometimes it could be abandoned. Other times it could have a mini-boss defending it. The key is, it's also a part of the targeted exploration that the game does so well. And it can't be too difficult, because it's just a similar mechanism to the way time was advanced in the old strategy model. More importantly, you don't feel like you're forced to do an onerous task like a discrete mission.

The next time crystals would always be in up to 3 places on the map. Advancing time (and allowing enemy progress) would involve destroying a time crystal, an action which would net you tier orbs/guardian scrolls + time units. This decouples missions from tier orbs, making missions more optional. A time crystal could have 1-3 time units, and tier orbs + guardian scrolls that add up to a corresponding 1-3. This random multiplicity is there to reduce the feeling of grind, in case someone just wants time to progress quickly. Once you get time units, a player with time master privileges can advance the time in the game through some interface. Also, as soon as you have time units, all other time crystals disappear, to prevent hoarding and manipulation.

Another advantage is that you don't send the message that it's ok to just race to the highest tier. Since you only get tier orbs or guardian scrolls from time crystals, you're virtually powerless without the resources to utilize those things.

The resources are obtained from caves, buildings and missions as they are now. Missions would give rare resources, which would also be available alternatively at very deep (and dangerous) cavern levels. This makes missions a truly optional (and thus fun) part of the game. You do missions because it's something interesting that the game allows you and they're a nice shortcut to other things -- not because the game shoves them down your throat. The focus is on the strengths of the game, and missions are really cool side things to do that make your time in the game more fun. It also allows you to focus more on balancing the game itself rather than the mini-games inside it.
TagsNo tags attached.
Internal WeightNew

Activities

Bluddy

May 8, 2012 1:23 pm

reporter   ~0023768

Oh also, if it wasn't obvious, the time crystals would be the ones advancing CP, not the missions. This would take away the penalty from the main missions that causes everybody to look for secret missions and avoid the main missions. In fact, main missions would just be missions highlighted to the player for ease of use. Secret missions could perhaps sometimes offer more rewards at higher risk, so they'd be worth seeking out.

The player now has several ways to collect rare resources: he can do the map missions, or he can try to find the slightly better but harder secret missions, or he can go very deep in caves and just ignore missions altogether if he wants to. It'd be nice if he could go into deep buildings as well to get some technological resources for buildings too, but those resources aren't in the game as of right now.

GauHelldragon

May 8, 2012 2:46 pm

reporter   ~0023775

I definitely like the idea of deep caves being an alternate means of getting crafting ingredients. You do make a good point about how the missions are more like 'minigames'.

I'm not so sure about the time crystals thing though... maybe if it was something more tied into the 'main' plot of the game: the overlords and the lieutenants? Or maybe even something to do with the windstorms.

Bluddy

May 8, 2012 2:53 pm

reporter   ~0023776

The time crystals are just Macguffins. They can take the form of any narrative device, such as magical wind locations or time vortices or whatever.

The point is that
1. They are fairly easy to attain (with some variety due to the game's innate randomness).
2. They prevent the missions from being the focus of the game and make them optional.
3. They remove the negative penalties from doing missions (ie CP).
4. Once the strategy layer is back, they will allow time to flow and the enemy to do stuff without overwhelming players (which would happen if realtime is used).
5. They center the game on what it does best -- 'targeted exploration'.

khadgar

May 8, 2012 3:12 pm

reporter   ~0023779

I still don't know how I feel about this drastic gameflow change, but I am completely supportive of decoupling missions & CP. It's my CP and I'll advance it when I want to. I shouldn't feel like I have to avoid all missions (I sure ain't ranking up my continent yet, I'm not ready!) like I do at present. What are they there for if not to be completed?

Penumbra

May 8, 2012 3:28 pm

reporter   ~0023781

Linking CP and Tier orbs is good, that's part of the progression. I agree that the story reasons behind it needs some fleshing out. I want to understand _why_ my doing a mission makes the CP raise.

But, there is supposed to be a connection between CP and resources, as well. That's why missions give so many more resources that the hidden ones, it's the "tough choice." You want that Wilkin Gel? Well, you're going to gain CP doing so. You need to spread out the resource choice, and there are only so many.

You could go searching for the hidden ones, but it won't be as fast, and it's what you do when you have no options.

I think the issue is that there are so many buildings and no mission gives both buildings and resources. You almost feel penalized for getting buildings instead. What if each mission gave 3 Tier orbs and 1 building of your choice. Then, you could go back to picking the mission/resource choice which is actually fun and challenging.

Bluddy

May 8, 2012 3:58 pm

reporter   ~0023783

See, Penumbra, I also like that resource choice of resources vs CP, but I currently don't find it that effective. It strongly pushes towards grinding secret missions, which is what most people do, so you're really getting as many rare gems as you want -- you essentially have unlimited resources other than tier orbs. And honestly, I'm going to get sick of all the missions really fast. I don't want to be forced to do so many of them. I want to HAVE to do the meat of the game, which is the exploration, finding resources and fighting monsters. If the missions are optional, I can choose when to do them and that'll be fun. But if I'm forced to do them as a central activity, that's going to get old fast. And when I say 'I', I *think* I'm referring to the sentiment the average player will have over time.

The important thing to conserve is the number of tier orbs, since this is the only limited resource in the game, and that's what the 'time crystals' do (together with time units, which are not yet in the game).

x4000Bughunter

May 8, 2012 4:22 pm

administrator   ~0023784

Last edited: May 8, 2012 4:22 pm

View 2 revisions

Opinion noted -- however, missions basically are the framework for everything we like best about what we can do with the game. They provide the strategic interplay as well as a concept of "time" and and "opportunity cost" that has nothing to do with times or turn (that would be referring to CP and tier orbs).

As some reviewers have noted, the missions are at the core of what makes this game better than your average sandbox. The fact that you're getting tired of the existing mission types doesn't mean missions need to go away -- that's like saying that because there are too few monster types we should just get rid of monsters.

Rather, what we need are a lot more mission types. And those are coming, it's just a matter of the workload we have right now. There are players who want something completely unstructured, and those who want something very structured; right now the game kind of splits the difference with both some structure as well as some completely-unstructured bits.

That said, being able to get some arcane ingredients through some non-mission fashions might be an interesting thing to pursue at some point before too long.

I understand where you're coming from, and I agree that repetition isn't the best thing, but tossing out the mission structure would actually make that worse: there is only so much you can do in the form of freeform exploration that will ultimately feel unique. With missions we have an opportunity to make instance-based challenges that can be anything under the sun that we can think up, and if we have a hundred types of missions instead of 13 or 14 I don't think you'd feel the same about wanting them removed, is really what it is.

My focus is more on getting to that huge number of missions that are actually unique and interesting, rather than on trying to rework the framework again. The bones are good. We just need more meat on them bones!

x4000Bughunter

May 8, 2012 4:24 pm

administrator   ~0023785

Also, Penumbra hit it pretty well on the head with the whole tough choices bit. It's like the choice to take one planet versus the next with AI War. Only it's a lot more forgiving in this game since it isn't a full-out strategy game.

Bluddy

May 8, 2012 5:53 pm

reporter   ~0023792

Well, I'm of the opinion that the missions aren't the strongest parts of the game. I'd much rather you tried to bring back the strategy elements and have that + exploration be the main focus, rather than spend time making 100 mission types. Mind you, the missions are fun and I really do like some of them, but IMO they're most fun when they're optional. They're like the taxi driving or police car driving missions in GTA3 -- something different to do when you want it.

Also, when I finish a main mission and I get a notice that the tier went up or I got more CP, I get a feeling in the pit of my stomach of of 'oh crap -- why did I get lazy and take that main mission? Why didn't I scour the map for secret missions?' It's a silly thought but it's a natural reaction to the incentives in the game. It's a system where you have a 'tough choice' of either getting penalized or grinding secret missions. That's not a good choice IMO.

Why not, for example, have every tier allow you to pick up a certain amount of rare ingredients in whichever way before advancing -- via finding in deep caves (giving deep cave a purpose) or main missions or secret missions. What would be the advantage of secret missions then? Well, since you can only have X ingredients, and main missions give you more ingredients, main missions are actually worse because they don't give you exactly what you want. Secret missions give you fewer ingredients, and as such they allow you to hunt for exactly the things you want before the tier goes up.

x4000Bughunter

May 8, 2012 6:41 pm

administrator   ~0023795

Well -- I'm open to refinements, but now really isn't the time for discussing them. Nothing is terribly clear about all that right now because:

a) We need more missions.
b) Other parts of the game are in much more need of attention, such as needing lots more monsters asap.

So that's where my head is at. In terms of removing missions, I think there's pretty much a 0% chance of that happening. And the way that the strategic elements were done previously was pretty universally hated by anyone outside the strategy genre. I also didn't like the way it was implemented. My focus is on making players make strategic decisions in the course of their normal gameplay; without making it so punishing that they can't recover from a past mistake. Unrecoverable mistakes just aren't cool with people in a game with this mix of genres, it seems clear.

Anyway, like I said, I could see some balance improvements needing to be made, and various other changes. But missions are here to stay as a general concept (and they aren't even that novel in some respects if you consider "instances" in basically every MMO or "battles" in Final Fantasy Tactics as a way of advancing, etc). I was thinking more FFT when originally designing these, but they turned out MMO-like even though I've never played any MMO.

But the fact remains that there are vastly bigger fish to fry in the short term, and this discussion can't really be had with any clarity until some other things settle down more.

By the way, side note: I don't view the missions as being like the stuff in GTA that you mention. In one sense they are, sure, but that's only when you have a really low-limited number of them. I look at missions as being more like levels in a traditional platformer game. SMB level 2-1 is the water-themed level, for instance. SMB 1-2 is underground, SMB 1-1 is basic aboveground. 1-3 is high in the sky, 1-4 is the castle levels with certain kinds of challenges. To me, I look at the missions as being like discrete levels that can have any sort of special rules that we want, and which can vary to a larger or a smaller degree depending on how the mission is set up.

That's my conceptual model for them, anyhow. Taking them out just doesn't make any sense to me, because that means we can't have specialized areas where suddenly we 1) explain some new rules to you 2) potentially disable some of your stuff and/or give you some new abilities 3) let you try a given challenge over and over, but make you complete the whole thing in one burst rather than letting you whittle it down over time.

Back before missions, a Rare Commodity Tower was lame because you could go in, fight one boss, win or die, and then leave and heal. Then come back, take the next boss, etc. With the mission structure, we know exactly what the challenge is, and we can control how big of a time investment it is, and we can be assured that you can't trade your time (running back to town for healing constantly) in exchange for a cheap win on it.

Boy, missions were just the smartest thing we ever did with this game -- the litany of reasons to keep them from a game design standpoint is just incredibly immense. All of the potential for sustained interest from players comes from pretty much missions and guardian powers, I think. Just randomly exploring gets old eventually no matter what is out there. Missions let us have "levels" in a very traditional sense in the middle of a very non-traditional game, and that's just so important.

What you're really talking about is a suggested revision to the reward structure, and I get that, but I don't see changing anything core about the missions themselves as being a part of that.

khadgar

May 8, 2012 8:42 pm

reporter   ~0023804

I'll toss in one idea that reading all this made me think of.

Perhaps at some time, long in AVWW's future, we might see missions able to be procedurally integrated with the environment, as opposed to (or in addition to) being an instance of their own. So, instead of going to the mission entrance doorway that magically appears in a place it never was before on the first chunk in the surface dungeon, what if the tower itself just appeared there? Mostly a cosmetic change, as when you hit the top, you explode the tower and it's now gone. Lava escape from building spawns a tall building, you escape the building, it "burns down".

Actually, when I re-read this, I don't think that what I am saying is related in any way shape or form, but... well here it is.

x4000Bughunter

May 8, 2012 8:49 pm

administrator   ~0023805

It's a possibility. I can't really think that far out at the moment, though. Right now what I'm hearing, from just listening to aggregated feedback from many sources (and based on my instincts from 3 years of AI War) is that we're toeing a dangerous line with a structure-less game.

Not to say I want to abandon free-roaming or any of that; but I want it to be about 50% of your playtime, not higher, for an average player on an average session (obviously results will vary).

Bluddy

May 8, 2012 8:52 pm

reporter   ~0023806

Khadgar, I actually do think it's related, since it involves making missions less isolated from the rest of the game. I was thinking (along the same line but not as grandiose) that missions would be generated in rooms that you were initially locked out of, buildings you couldn't initially access, or caves that were blocked off.

So the boss tower would be there from the beginning, but it would be inaccessible until you had the mission. Or an assassination would take place in a building that was blocked off. The chunks would still be accessible later if you just wanted to stroll through the area where the mission took place -- enemies might later spawn there as if it was a regular area. It would give the feeling that the missions are really a part of the world.

x4000Bughunter

May 8, 2012 8:54 pm

administrator   ~0023807

Bluddy: two problems with that.

1. Exponential continent growth like we had once before. Missions being instance-based solved our need to sink continents into the sea to keep world folders at all reasonably sized. And still they are routinely 50mb and growing.

2. You lose the ability to make it something that you can retry if failed, and/or the ability to make it something that has to be one all in one go. See my notes on why the older style of boss towers (which work as you describe) were comparably lame to their mission counterparts in my opinion.

Bluddy

May 8, 2012 9:07 pm

reporter   ~0023808

I think there are ways to solve both problems.

1. If missions areas are left as they are, it's only to give you the ability to stroll through them a little while later. It lets you feel like they're real places. But you don't need to keep them for long. The tower can be destroyed (literally become a ruin) after a while.

BTW Just to clarify, the idea here is that you're seeding areas with lots of places that are locked: locked buildings, locked doors, caves blocked off by rocks etc.These can be filled with missions later as needed. So you still have missions, but they're part of the world.

2. There are ways to make even the old style boss towers work. The doors can be blocked off once you enter until you defeat the boss, or you can just heal/resurrect the bosses once you leave. ie. there are no limitations that really exist on having boss towers vs discrete missions -- it just wasn't done with the old boss towers for various reasons that existed at the time. I'm not saying that the missions shouldn't exist, just that they would feel more organic if they was part of the landscape as opposed to a virtual world you get whisked off to.

Regardless, my original suggestion above was never to trash missions. It was simply to make them more optional and remove the secret mission grind.

x4000Bughunter

May 8, 2012 9:12 pm

administrator   ~0023809

We'll see how things evolve; right now there's really not much more I can say on it, to be honest, because there's so many things that need to happen first before I could even begin to make a decision like this. Clarity tends to emerge as data accumulates, and right now I have very little data and what data there is is clouded with other issues that need to be resolved in either case. So for now I focus on those issues.

Issue History

Date Modified Username Field Change
May 8, 2012 11:59 am Bluddy New Issue
May 8, 2012 1:23 pm Bluddy Note Added: 0023768
May 8, 2012 2:32 pm Bluddy Description Updated View Revisions
May 8, 2012 2:46 pm GauHelldragon Note Added: 0023775
May 8, 2012 2:53 pm Bluddy Note Added: 0023776
May 8, 2012 3:12 pm khadgar Note Added: 0023779
May 8, 2012 3:28 pm Penumbra Note Added: 0023781
May 8, 2012 3:58 pm Bluddy Note Added: 0023783
May 8, 2012 4:22 pm x4000Bughunter Internal Weight => New
May 8, 2012 4:22 pm x4000Bughunter Note Added: 0023784
May 8, 2012 4:22 pm x4000Bughunter Status new => closed
May 8, 2012 4:22 pm x4000Bughunter Assigned To => x4000Bughunter
May 8, 2012 4:22 pm x4000Bughunter Resolution open => won't fix
May 8, 2012 4:22 pm x4000Bughunter Note Edited: 0023784 View Revisions
May 8, 2012 4:24 pm x4000Bughunter Note Added: 0023785
May 8, 2012 5:53 pm Bluddy Note Added: 0023792
May 8, 2012 6:41 pm x4000Bughunter Note Added: 0023795
May 8, 2012 8:42 pm khadgar Note Added: 0023804
May 8, 2012 8:49 pm x4000Bughunter Note Added: 0023805
May 8, 2012 8:52 pm Bluddy Note Added: 0023806
May 8, 2012 8:54 pm x4000Bughunter Note Added: 0023807
May 8, 2012 9:07 pm Bluddy Note Added: 0023808
May 8, 2012 9:12 pm x4000Bughunter Note Added: 0023809
Apr 14, 2014 9:28 am x4000Bughunter Category Suggestion - General Idea => Suggestion - General
Apr 14, 2014 9:30 am x4000Bughunter Category Suggestion - General => Suggestion