View Issue Details

IDProjectCategoryLast Update
0026091AI War 2Bug - GameplayJan 13, 2022 7:48 pm
Reporterpheonix89 Assigned Tox4000Bughunter  
Severityminor 
Status resolvedResolutionreopened 
Product VersionBeta 3.781 Tachyon Healing Reversal 
Fixed in VersionBeta 3.784 Tractor Recursion 
Summary0026091: Ambush carriers don't ever recloak
DescriptionAmbush carriers are getting the decloaked debuff and then it rolls over into the negative duration and keeps going "down" and they aren't recloaking.
TagsNo tags attached.

Activities

x4000Bughunter

Jan 9, 2022 9:43 pm

administrator   ~0063729

Thanks!

* Fixed a bug where units were losing way more than their max cloaking points, making it impossible for them to ever reasonably recover and cloak again.
** If any units still don't recloak, please let us know and send a savegame with it. This will fix the main issue, which was them getting infinite negative cloaking power.

Kleenex_1

Jan 12, 2022 9:04 pm

reporter   ~0063754

Re-cloaking seems to be broken. Steps to reproduce:

Start a new game with a cloaking fleet
Move cloaking flagship to a world where it will be decloaked
Move it back home
Watch as the "Already Decloaked! Regen:" timer ticks down to 0, and then into the negatives forever.

I'm on the [current_beta] branch, main screen says version 3.783
regen in negatives.save (177,862 bytes)
regen in negatives.savemet (111 bytes)   
UK
139035508
70
aaa
<color=#66ffce>Easier </color> Full Ensemble
Difficulty 5
0
<color=#318ce7>Pancakes</color>
regen in negatives.savemet (111 bytes)   
Player.log (7,139 bytes)   
Mono path[0] = 'D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Managed'
Mono config path = 'D:/Slow Steam/steamapps/common/AI War 2/MonoBleedingEdge/etc'
Initialize engine version: 2020.3.21f1 (a38c86f6690f)
[Subsystems] Discovering subsystems at path D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/UnitySubsystems
Forcing GfxDevice: Direct3D 11
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 11.1]
    Renderer: NVIDIA GeForce GTX 1080 (ID=0x1b80)
    Vendor:   
    VRAM:     8079 MB
    Driver:   30.0.14.9729
Begin MonoManager ReloadAssembly
- Completed reload, in  0.157 seconds
<RI> Initializing input.

<RI> Input initialized.

<RI> Initialized touch support.

Invalid stride 1 for Compute Buffer - must be greater than 0, less or equal to 2048 and a multiple of 4.
UnloadTime: 0.668900 ms
Fallback handler could not load library D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Mono/data-000001BD5247D040.dll
Fallback handler could not load library D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Mono/data-000001BD52776040.dll
Fallback handler could not load library D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Mono/data-000001BD5C01E020.dll
Particle System is trying to spawn on a mesh with zero surface area
Fallback handler could not load library D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Mono/data-000001BD5C291D20.dll
Fallback handler could not load library D:/Slow Steam/steamapps/common/AI War 2/AIWar2_Data/Mono/data-000001BE399B8080.dll
Setting up 1 worker threads for Enlighten.
  Thread -> id: 8d8 -> priority: 1 
NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

NullReferenceException
  at (wrapper managed-to-native) UnityEngine.Material.GetFloatImpl(UnityEngine.Material,int)
  at UnityEngine.Material.GetFloat (System.String name) [0x00008] in <7e08fded3f3149c083ffda003fccce04>:0 
  at TMPro.TMP_SubMeshUI.UpdateMaterial () [0x0002c] in <7435aa3e618242e082286b882f32101f>:0 
  at TMPro.TMP_SubMeshUI.SetMaterialDirty () [0x00007] in <7435aa3e618242e082286b882f32101f>:0 
  at UnityEngine.UI.MaskableGraphic.OnDisable () [0x0000d] in <6c742b63882e4028831fefcd3ee9f3da>:0 
  at TMPro.TMP_SubMeshUI.OnDisable () [0x00000] in <7435aa3e618242e082286b882f32101f>:0 

Player.log (7,139 bytes)   

x4000Bughunter

Jan 13, 2022 7:48 pm

administrator   ~0063778

Thank you!

* In a "how did this ever work?" moment, there was essentially no code around for units to ever re-cloak. I can only really speculate that I broke that during the giant refactor, because it obviously did historically work. It's possible I broke it a lot more recently, when I improved the tachyon code, but I don't feel like that logic should have been over there, so... either way, it's fixed now!

Issue History

Date Modified Username Field Change
Jan 9, 2022 11:46 am pheonix89 New Issue
Jan 9, 2022 9:43 pm x4000Bughunter Assigned To => x4000Bughunter
Jan 9, 2022 9:43 pm x4000Bughunter Status new => resolved
Jan 9, 2022 9:43 pm x4000Bughunter Resolution open => fixed
Jan 9, 2022 9:43 pm x4000Bughunter Fixed in Version => Beta 3.782 Smooth Reloading
Jan 9, 2022 9:43 pm x4000Bughunter Note Added: 0063729
Jan 12, 2022 9:04 pm Kleenex_1 Note Added: 0063754
Jan 12, 2022 9:04 pm Kleenex_1 File Added: regen in negatives.save
Jan 12, 2022 9:04 pm Kleenex_1 File Added: regen in negatives.savemet
Jan 12, 2022 9:04 pm Kleenex_1 File Added: Player.log
Jan 12, 2022 11:28 pm Kleenex_1 Status resolved => new
Jan 12, 2022 11:28 pm Kleenex_1 Resolution fixed => reopened
Jan 13, 2022 7:48 pm x4000Bughunter Status new => resolved
Jan 13, 2022 7:48 pm x4000Bughunter Fixed in Version Beta 3.782 Smooth Reloading => Beta 3.784 Tractor Recursion
Jan 13, 2022 7:48 pm x4000Bughunter Note Added: 0063778