View Issue Details

IDProjectCategoryLast Update
0025601AI War 2Crash/ExceptionOct 1, 2021 6:18 pm
Reporterx4000Bughunter Assigned ToBadgerBadger  
Severityminor 
Status resolvedResolutionduplicate 
Product VersionBeta 3.704 Unexpected Turbo Sim Speed 
Fixed in VersionBeta 3.704 Unexpected Turbo Sim Speed 
Summary0025601: Exception in the Dark Zenith when running for a while.
DescriptionThis is the error I get: "Hit exception in HandleTerminiiAndEpistyles code 350 System.Exception: Dark Zenith Epistyle #70360 on Don't Try This doesn't have HasBag set.
  at Arcen.AIW2.External.DarkZenithFactionDeepInfoRoot.HandleTerminiiAndEpistyles (Arcen.AIW2.Core.ArcenHostOnlySimContext Context) [0x0049c] in <700b9c2b59754f0ca0c149013caa6be5>:0 "

I am not entirely sure how to deal with this error, because it's something you are throwing intentionally because the data is not in the state you want, versus it being just a more general translation error.

Please note: the savegame I have attached will only work on svn revision 14382. Or simply remove the changes from 14383 in order to make it work again in a future build.
TagsNo tags attached.

Relationships

duplicate of 0025595 resolvedBadgerBadger Svikari Error Log Item 

Activities

x4000Bughunter

Oct 1, 2021 11:00 am

administrator  

errors.save (440,017 bytes)
errors.savemet (115 bytes)   
UK
2064106307
2232
test
<color=#66ffce>Easier </color> One-Way Doormaster
Difficulty 8
0
<color=#ffba00>-8-</color>
errors.savemet (115 bytes)   

x4000Bughunter

Oct 1, 2021 11:38 am

administrator   ~0062869

Correction: this save will work on svn version 14382 only. Svn version 14383 breaks it, but has a note on how to un-break it.

BadgerBadger

Oct 1, 2021 4:45 pm

manager   ~0062883

So this is weird. This Epistyle has DarkZenithPerUnitData as if it was a Terminus. When I look at the data structure initialization code it looks unchanged, so I'm suspicious that we either have a bug in serialize/deserialize, or in the pooling code. I note that the DZ Per Unit Data Cleanup() doesn't seem to reset the ConversionBag or ConversionList, so I bet we have stale data in a reused DarkZenithPerUnitData

Chris, I'm reassigning this to you for your opinion. If you think this sounds like a reasonable conclusion then just let me know and I'll make the changes.

x4000Bughunter

Oct 1, 2021 5:17 pm

administrator   ~0062884

Pooling not properly clearing it sounds reasonable.

BadgerBadger

Oct 1, 2021 6:18 pm

manager   ~0062886

Fixed

Issue History

Date Modified Username Field Change
Oct 1, 2021 11:00 am x4000Bughunter New Issue
Oct 1, 2021 11:00 am x4000Bughunter Status new => assigned
Oct 1, 2021 11:00 am x4000Bughunter Assigned To => BadgerBadger
Oct 1, 2021 11:00 am x4000Bughunter File Added: errors.save
Oct 1, 2021 11:00 am x4000Bughunter File Added: errors.savemet
Oct 1, 2021 11:38 am x4000Bughunter Note Added: 0062869
Oct 1, 2021 11:38 am x4000Bughunter Description Updated
Oct 1, 2021 2:01 pm x4000Bughunter Relationship added duplicate of 0025595
Oct 1, 2021 4:45 pm BadgerBadger Note Added: 0062883
Oct 1, 2021 4:45 pm BadgerBadger Assigned To BadgerBadger => x4000Bughunter
Oct 1, 2021 5:17 pm x4000Bughunter Note Added: 0062884
Oct 1, 2021 6:18 pm BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Oct 1, 2021 6:18 pm BadgerBadger Status assigned => resolved
Oct 1, 2021 6:18 pm BadgerBadger Resolution open => duplicate
Oct 1, 2021 6:18 pm BadgerBadger Fixed in Version => Beta 3.704 Unexpected Turbo Sim Speed
Oct 1, 2021 6:18 pm BadgerBadger Note Added: 0062886