View Issue Details

IDProjectCategoryLast Update
0024612AI War 2[All Projects] Crash/ExceptionMar 30, 2021 2:49 pm
ReporterSigma7Assigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.764 Command Station Hotfix 
Fixed in VersionBeta 2.765 The Hunt For Frigates And Civilians 
Summary0024612: ArgumentOutOfRangeException - moving across systems
DescriptionI encountered this exception when I was trying to bulk-move a number of fleets to a planet (basically trying to intercept one of the attack surges.)

I can't reproduce it, and I think it's another race condition. Maybe it gets called while one of the infamous ClearOrders doing its job?

3/26/2021 5:53:45 PM 2.764 SINGLEP Exception in DoPerSimStepLogic_OnMainThreadAndPartOfSim for faction Sigma7(Index 6), so will not run any more of those until a reload of the save.
System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
  at System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) [0x00029] in <9577ac7a62ef43179789031239ba8798>:0
  at System.ThrowHelper.ThrowArgumentOutOfRangeException () [0x00000] in <9577ac7a62ef43179789031239ba8798>:0
  at Arcen.AIW2.Core.GameEntity_Squad.GetDestinationPlanet (Arcen.AIW2.Core.ProjectedMultiPathData newLookup) [0x000c4] in <b94cbedd712f4d2e86b6547ccbfc8faa>:0
  at Arcen.AIW2.External.SpecialFaction_Human+<>c__DisplayClass89_0.<NonSim_PopulatePathToCurrentHoverPlanet>b__0 (Arcen.AIW2.Core.GameEntity_Squad selected) [0x00028] in <530e5f0408bb463da28b713b904d5d16>:0
  at Arcen.AIW2.Core.Engine_AIW2.DoForSelected (Arcen.AIW2.Core.SelectionCommandScope Scope, Arcen.AIW2.Core.GameEntity_Squad+ProcessorDelegate Processor) [0x00129] in <b94cbedd712f4d2e86b6547ccbfc8faa>:0
  at Arcen.AIW2.External.SpecialFaction_Human.NonSim_PopulatePathToCurrentHoverPlanet (Arcen.AIW2.Core.Faction faction, Arcen.AIW2.Core.ProjectedMultiPathData newLookup, System.Boolean additiveSelection, Arcen.AIW2.Core.ArcenSimContext Context) [0x00069] in <530e5f0408bb463da28b713b904d5d16>:0
  at Arcen.AIW2.External.SpecialFaction_Human.DoPerSimStepLogic_OnMainThreadAndPartOfSim (Arcen.AIW2.Core.Faction faction, Arcen.AIW2.Core.ArcenSimContext Context) [0x00076] in <530e5f0408bb463da28b713b904d5d16>:0
  at Arcen.AIW2.Core.Faction.Safe_DoPerSimStepLogic_OnMainThreadAndPartOfSim (Arcen.AIW2.Core.ArcenSimContext Context) [0x00024] in <b94cbedd712f4d2e86b6547ccbfc8faa>:0
3/26/2021 5:53:45 PM 2.764 SINGLEP Unknown Exception in DoPerSimStepLogic_OnMainThreadAndPartOfSim for faction Sigma7(Index 6), so will not run any more of those until a reload of the save. Check error log to see prior recorded exception.

Save files: The autosave is the pre-exception, and the named file is just after the exception.
TagsNo tags attached.

Relationships

related to 0024625 resolvedx4000Bughunter Faction Crashed. 

Activities

Sigma7

Mar 26, 2021 7:33 pm

reporter  

OutOfRange.zip (3,597,336 bytes)

x4000Bughunter

Mar 30, 2021 2:49 pm

administrator   ~0060970

Thanks!

* Fixed a couple of places in the squad class where cross-threading issues could crop up with index out of range exceptions looking at unit orders. The side benefit of this is that it also makes this code a bit faster to run, because fewer array indices are happening.

Issue History

Date Modified Username Field Change
Mar 26, 2021 7:33 pm Sigma7 New Issue
Mar 26, 2021 7:33 pm Sigma7 File Added: OutOfRange.zip
Mar 28, 2021 2:55 pm Sigma7 Relationship added related to 0024625
Mar 30, 2021 2:49 pm x4000Bughunter Assigned To => x4000Bughunter
Mar 30, 2021 2:49 pm x4000Bughunter Status new => resolved
Mar 30, 2021 2:49 pm x4000Bughunter Resolution open => fixed
Mar 30, 2021 2:49 pm x4000Bughunter Fixed in Version => Beta 2.765 The Hunt For Frigates And Civilians
Mar 30, 2021 2:49 pm x4000Bughunter Note Added: 0060970