View Issue Details

IDProjectCategoryLast Update
0024611AI War 2Crash/ExceptionMar 26, 2021 6:14 pm
Reporterkmunoz Assigned Tox4000Bughunter  
Severityblock 
Status closedResolutionno change required 
Product VersionBeta 2.764 Command Station Hotfix 
Summary0024611: Game fails to load past approx. 36 seconds on loading timer
DescriptionAs per title. The game fails to load past roughly 36 seconds on the load timer (35.3, 36.4 on my two tests). Hangs, does not crash. Reproducible on OpenGL and Metal.

System:

macOS Big Sur
MacBook Air M1

This issue is new as of at least 2.764, possibly 2.763 (did not attempt to run the game on 2.763).
TagsNo tags attached.

Activities

BadgerBadger

Mar 26, 2021 4:42 pm

manager   ~0060914

Are the M1 macs supported?

BadgerBadger

Mar 26, 2021 4:42 pm

manager   ~0060915

Also, can you provide the ArcenDebugLog and the Unity Player.log

kmunoz

Mar 26, 2021 4:56 pm

reporter   ~0060916

M1 Macs should be supported...? I've been running the beta fine up to now. I'll get the debug logs uploaded shortly.

kmunoz

Mar 26, 2021 4:59 pm

reporter   ~0060917

Can you point to me where the logs will be found on a Mac filesystem? They are not in Documents and they don't appear to be in the game directory or ~/Library/Application Support.

kmunoz

Mar 26, 2021 5:09 pm

reporter   ~0060918

Ok, here's the ArcenDebugLog.txt

Still looking for the Unity Player log.
ArcenDebugLog.txt (527,613 bytes)

kmunoz

Mar 26, 2021 5:10 pm

reporter   ~0060919

It looks like it hangs right after the completion of the load, before switching to the lobby UI.

x4000Bughunter

Mar 26, 2021 5:50 pm

administrator   ~0060920

Yep, there are no errors in there, and you are correct that it is just past the point of actually loading everything and now should be to the main menu.

At right around this time, it should be trying to write a thing to disk, and that might be problematic. Sometimes that's a Gatekeeper problem on Mac, where you need to make sure the directory of the game is writeable. From the look of things, I don't think that your game is corrupt or anything.

M1/silicon macs are not officially supported by the game (or really any game) yet, but they should work fine via Rosetta, which is what I assume you're doing. The official native support in the unity platform looks like it will arrive within the year, but the only real benefit from that should be speed, not compatibility or features.

x4000Bughunter

Mar 26, 2021 5:51 pm

administrator   ~0060921

Player log should be here, and would have the crash info:

macOS: ~/Library/Logs/Arcen Games, LLC/AIWar2/Player.log

kmunoz

Mar 26, 2021 6:05 pm

reporter   ~0060922

Ok here's the player log.

The beta was running fine up until at least 2.762 (the last one I tested - I didn't get to look at 2.763 as 2.764 dropped before I got to it).
Player.log (19,736 bytes)

x4000Bughunter

Mar 26, 2021 6:10 pm

administrator   ~0060923

Last edited: Mar 26, 2021 6:11 pm

So the only interesting things in there are this:

WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
[S_API] SteamAPI_Init(): Loaded '/Users/user/Library/Application Support/Steam/Steam.AppBundle/Steam/Contents/MacOS/steamclient.dylib' OK.

The first thing happens a lot, and is just macOS not being able to use the compression format that is more advanced, so uncompressing it. If you run the Metal version of the game, that might work better. It seems that you're running the OpenGL version.

The second thing is the game actually trying to init its hook with Steam. Steam did have some updates recently, and I wonder if they broke something? A way to test that would be to exit steam (make sure it is really and truly off) and then run AIWar2.app from Finder. If it loads up just fine, then a bug report to Steam would be in order, probably an M1 compatibility thing on their end.

It is a little bit suspicious the timing that the log cuts off, because right after Steam Init it basically dies. Steam does a hook in for their overlay, so I wonder if that's going awry. There again, using Metal instead of OpenGL might give you a different result.

x4000Bughunter

Mar 26, 2021 6:14 pm

administrator   ~0060924

From kmunoz:

Ding ding ding we have a winner. Running outside Steam, it works. Testing without overlay next.
Runs with overlay turned off too

Issue History

Date Modified Username Field Change
Mar 26, 2021 4:10 pm kmunoz New Issue
Mar 26, 2021 4:42 pm BadgerBadger Note Added: 0060914
Mar 26, 2021 4:42 pm BadgerBadger Note Added: 0060915
Mar 26, 2021 4:55 pm kmunoz Summary Game fails to load past 0000107:0000036 seconds on loading timer => Game fails to load past approx. 36 seconds on loading timer
Mar 26, 2021 4:56 pm kmunoz Note Added: 0060916
Mar 26, 2021 4:59 pm kmunoz Note Added: 0060917
Mar 26, 2021 5:09 pm kmunoz File Added: ArcenDebugLog.txt
Mar 26, 2021 5:09 pm kmunoz Note Added: 0060918
Mar 26, 2021 5:10 pm kmunoz Note Added: 0060919
Mar 26, 2021 5:50 pm x4000Bughunter Note Added: 0060920
Mar 26, 2021 5:51 pm x4000Bughunter Note Added: 0060921
Mar 26, 2021 6:05 pm kmunoz File Added: Player.log
Mar 26, 2021 6:05 pm kmunoz Note Added: 0060922
Mar 26, 2021 6:10 pm x4000Bughunter Note Added: 0060923
Mar 26, 2021 6:11 pm x4000Bughunter Note Edited: 0060923
Mar 26, 2021 6:14 pm x4000Bughunter Assigned To => x4000Bughunter
Mar 26, 2021 6:14 pm x4000Bughunter Status new => closed
Mar 26, 2021 6:14 pm x4000Bughunter Resolution open => no change required
Mar 26, 2021 6:14 pm x4000Bughunter Note Added: 0060924