View Issue Details

IDProjectCategoryLast Update
0023342AI War 2[All Projects] Bug - OtherJun 29, 2020 11:34 am
ReporterLord Of NothingAssigned Tox4000Bughunter 
Severitytweak 
Status resolvedResolutionfixed 
Product VersionBeta 2.084 Freedom From The Compiler 
Fixed in VersionBeta 2.086 Tell Me About The Zenith, Voice Lady 
Summary0023342: Off-By-Default Included Mod ... Not included.
DescriptionPer Beta 2.078 Mod and Expansion Prepping patch notes:

First Off-By-Default Included Mod: The Spire Railgun Shop by Lord of Nothing
The Spire Railgun Shop mod by Lord of Nothing is now included with the game by default (with permission), but disabled.
This lets people simply enable the mod by clicking a button in the settings menu, rather than having to find and download the mod from elsewhere.
Full description of the mod is included in the tooltips in the game.

The only thing is, as far as I can tell, it isn't? I'm guessing it should be here, in the attached picture? You can see both expansions in their appropriate state, and you can see my copy of the mod, but not any sign of the included-by-default copy. I initially wondered if it was an issue caused by me already having a copy, but from https://forums.arcengames.com/ai-war-ii-modding/spire-railgun-shop/msg222668/#msg222668 it seems not?
TagsNo tags attached.

Activities

Lord Of Nothing

Jun 27, 2020 7:43 am

reporter  

AI War bug 5.png (679,102 bytes)

x4000Bughunter

Jun 27, 2020 10:55 am

administrator   ~0057442

This is probably an oversight on my part -- thanks for the catch. I will deal with it on monday and get it out properly!

x4000Bughunter

Jun 29, 2020 11:34 am

administrator   ~0057452

Thanks! It was a problem with my release scripts.

* Fixed a bug where off-by-default mods that were supposed to be auto-included were not actually being included.

Issue History

Date Modified Username Field Change
Jun 27, 2020 7:43 am Lord Of Nothing New Issue
Jun 27, 2020 7:43 am Lord Of Nothing File Added: AI War bug 5.png
Jun 27, 2020 10:55 am x4000Bughunter Note Added: 0057442
Jun 27, 2020 10:55 am x4000Bughunter Assigned To => x4000Bughunter
Jun 27, 2020 10:55 am x4000Bughunter Status new => assigned
Jun 29, 2020 11:34 am x4000Bughunter Status assigned => resolved
Jun 29, 2020 11:34 am x4000Bughunter Resolution open => fixed
Jun 29, 2020 11:34 am x4000Bughunter Fixed in Version => Beta 2.086 Tell Me About The Zenith, Voice Lady
Jun 29, 2020 11:34 am x4000Bughunter Note Added: 0057452