View Issue Details

IDProjectCategoryLast Update
0021804AI War 2[All Projects] SuggestionJan 11, 2021 5:14 pm
ReporterdarkarchonAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.900 Custom Fleets With Empty Slots 
Fixed in Version2.715 Unload Queuing 
Summary0021804: Fleet Load-Move-(Unload) move order
DescriptionI find myself often do the same old "load, wait until fleet is loaded, move to a different system, unload" mechanism with the fleets involved, since this is the fastest and best way of travel. All of that is basically micromanagement when it could be possible to just select fleets, right click on a different planet and have them load, move there and unload automatically.

It could be an option in the fleet management to be set per fleet.
One could think to provide following options via drop-down:
- Move alone [current default]
- Load, move, unload
- Load, move

One could also add a "minimum hops" for the Load, move, (unload) movement so for example that it doesn't get triggered when there is only 1 hop for the move order.

Functionality-wise this could work as follows
I am a Centerpiece, I get the order to move X hops
If I have the Load-Move-Unload or Load-Move order and I have unloaded ships on the current planet, I start to load all ships on the planet
I wait until the ships are loaded (check if unloaded non-stationary fleetships on planet > 0)
I move X hops
If I have the Load-Move-Unload order I unload the ships
TagsNo tags attached.

Activities

BadgerBadger

Oct 14, 2019 1:07 pm

manager   ~0053649

I bet a "Fleet should load before moving planets" mode (analagous to the "Centerpiece shouldn't follow pursuit orders" mode) might make this possible

x4000Bughunter

Oct 14, 2019 4:37 pm

administrator   ~0053664

I have a plan in mind for making this work... ish. The problem is going to come in with units on other planets, or units that are stunned or whatever. The "wait for everyone to load" case is actually really complicated because what if someone is trapped or far away and you want to just GO? I can think of a few fleet-level toggles that we could work on either as very final polish pre 1.0 (if there's time) or right after 1.0.

The "unload after these other orders have happened" case is way easier, thankfully.

darkarchon

Oct 14, 2019 5:12 pm

reporter   ~0053666

Wouldn't it be possible to ignore all fleetships not on the current planet and that are not stunned or trapped in some way?

BadgerBadger

Oct 14, 2019 5:35 pm

manager   ~0053669

I don't think that's desirable.... I just went to a non-trivial amount of effort to get ships on remote planets to honour Load mode and try to find the flagship.

I would recommend just putting in a "Gather all units that don't have a movement-impairing status effect", and assume that the player wants to wait for everything else to arrive.

x4000Bughunter

Oct 14, 2019 5:46 pm

administrator   ~0053670

How impaired would we care about? We could check to see that the calculated speed is > 0 for purposes of that frame, and that would basically still wait for things that are hit by spiders but not completely overwhelmed by them. But it would ignore paralyzed stuff and stuff in tractor beams.

Otherwise we get a bit more complicated in terms of deciding what is "impaired enough" to count here. But yeah, this is something we could do.

BadgerBadger

Oct 14, 2019 5:59 pm

manager   ~0053675

Last edited: Oct 14, 2019 6:00 pm

View 3 revisions

So there are a few basic cases for this to my mind. The first is "I'm taking my fleet away from defending my home planets and heading out to fight", in which case stuck units aren't an issue (but I might want to wait for ships that were on Murdoch and Old Murdoch repelling a waves).

The second case is where I'm in a battle and realize I need to get away. For this case, I think https://www.youtube.com/watch?v=lcE1u2fAkRY sums it up best. If you're stuck, we leave you.

There's also the case where maybe I forgot a unit someplace, and it was heading toward me but ran into some enemies and got stuck, and for this case we should also leave them.

So basically, yes if your calculated speed is 0 then leave them behind.

x4000Bughunter

Oct 14, 2019 6:42 pm

administrator   ~0053678

Ahahaha, excellent use of a clip. Agreed.

x4000Bughunter

Jan 11, 2021 5:14 pm

administrator   ~0060285

Thanks!

* Something we had thought was not really going to be possible in the game, now is implemented: the queuing of some certain kinds of orders after movement, attack, traverse-wormhole, or whatever.
** The new commands that are supported basically use any of the existing buttons or hotkeys as usual, but you hold shift to append them to the end of the commands you already have in place. If you have no commands queued up already, then it will just do the thing immediately.
** Unload Transport
*** So for instance, give a some move orders to a distant planet, and at the end of that keep holding shift and press U (or click the interface button. The transport will unload when it gets there.
*** Note that Load Transport is NOT supported. This requires all of the ships to actually get loaded properly in, potentially from other planets, and the checking for that is both really complicated and also hopefully a far less common case.
** Set Pursuit Mode on or off
** Set Attack-Move Mode on or off
** Set Stop-To-Shoot Mode on or of
** So, for instance you can give some regular move orders to one side of a planet, then give a regular attack order, then have it turn on (or off) attack-move mode.
*** We can't think of any use cases for turning off a mode like this at a destination, but it is possible.
*** We also can't really think of any use cases for turning ON a mode like this at a destination, because ships will follow your direct move and attack orders even when in attack-move mode, which is functionally identical to the use case here. But it does exist now, in cases it's useful.
** The ability to unload transports at the destination is a big deal, at any rate, since there was no way to have that happen in an automated fashion before.

Issue History

Date Modified Username Field Change
Oct 14, 2019 1:01 pm darkarchon New Issue
Oct 14, 2019 1:07 pm BadgerBadger Note Added: 0053649
Oct 14, 2019 4:37 pm x4000Bughunter Note Added: 0053664
Oct 14, 2019 5:12 pm darkarchon Note Added: 0053666
Oct 14, 2019 5:35 pm BadgerBadger Note Added: 0053669
Oct 14, 2019 5:46 pm x4000Bughunter Note Added: 0053670
Oct 14, 2019 5:59 pm BadgerBadger Note Added: 0053675
Oct 14, 2019 5:59 pm BadgerBadger Note Edited: 0053675 View Revisions
Oct 14, 2019 6:00 pm BadgerBadger Note Edited: 0053675 View Revisions
Oct 14, 2019 6:42 pm x4000Bughunter Note Added: 0053678
Oct 14, 2019 6:42 pm x4000Bughunter Assigned To => x4000Bughunter
Oct 14, 2019 6:42 pm x4000Bughunter Status new => assigned
Jan 11, 2021 5:14 pm x4000Bughunter Status assigned => resolved
Jan 11, 2021 5:14 pm x4000Bughunter Resolution open => fixed
Jan 11, 2021 5:14 pm x4000Bughunter Fixed in Version => 2.715 Unload Queuing
Jan 11, 2021 5:14 pm x4000Bughunter Note Added: 0060285