View Issue Details

IDProjectCategoryLast Update
0021394AI War 2[All Projects] Crash/ExceptionJul 13, 2019 12:59 am
ReportertrillioneyesAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.875 Counterattacks You Can Taste 
Fixed in Version0.876 Counterattacks Ate My Waves 
Summary0021394: WriteFleetTooltip null reference exception
DescriptionAs usual, the exception doesn't interfere with my playing. Save attached.

7/12/2019 8:30:13 PM
WriteFleetTooltip exception at stage 200:System.NullReferenceException: Object reference not set to an instance of an object.
  at Arcen.AIW2.Core.Planet.GetCountOfPlayerFleetsAtPlanetWithCenterpiece () [0x00015] in <20d26a7e1535415d8721c1f342114a99>:0
  at Arcen.AIW2.External.Window_InGameSidebarFleets+btnFleet.WriteFleetTooltip (Arcen.AIW2.Core.Fleet fleet, Arcen.Universal.ArcenDoubleCharacterBuffer buffer) [0x00196] in <a933a1dd5d0348a3bab21ed19cedb057>:0

  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.AIW2.External.Window_InGameSidebarFleets+btnFleet.WriteFleetTooltip (Arcen.AIW2.Core.Fleet fleet, Arcen.Universal.ArcenDoubleCharacterBuffer buffer) [0x00000] in <a933a1dd5d0348a3bab21ed19cedb057>:0
  at Arcen.AIW2.External.Window_InGameSidebarFleets+btnFleet.HandleMouseover () [0x00000] in <a933a1dd5d0348a3bab21ed19cedb057>:0
  at Arcen.Universal.ArcenUI_Element.UpdateFromUI (System.Single DeltaTime) [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.Universal.ArcenUI_Window.OnUpdate (System.Single DeltaTime) [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.Universal.ArcenUI.OnUpdateFromMainThread () [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () [0x00000] in <2611ee7d34864d33a117e3b38c3062dd>:0
  at ArcenGameController.Update () [0x00000] in <3f44926ddd434aeeab645aa250c75454>:0

TagsNo tags attached.

Activities

trillioneyes

Jul 13, 2019 12:22 am

reporter  

bug.savemet (59 bytes)
bug.save (527,677 bytes)

BadgerBadger

Jul 13, 2019 12:59 am

manager   ~0052219

I couldn't reproduce your problem from your save but I've added some defensive coding, so hopefully this won't happen anymore.

Issue History

Date Modified Username Field Change
Jul 13, 2019 12:22 am trillioneyes New Issue
Jul 13, 2019 12:22 am trillioneyes File Added: bug.savemet
Jul 13, 2019 12:22 am trillioneyes File Added: bug.save
Jul 13, 2019 12:59 am BadgerBadger Assigned To => BadgerBadger
Jul 13, 2019 12:59 am BadgerBadger Status new => resolved
Jul 13, 2019 12:59 am BadgerBadger Resolution open => fixed
Jul 13, 2019 12:59 am BadgerBadger Fixed in Version => 0.876 Counterattacks Ate My Waves
Jul 13, 2019 12:59 am BadgerBadger Note Added: 0052219