View Issue Details

IDProjectCategoryLast Update
0020677AI War 2[All Projects] Bug - GameplayMay 17, 2019 1:19 am
ReporterHeartHunter7Assigned ToBadgerBadger 
Severityminor 
Status closedResolutionunable to reproduce 
Product Version0.804 Hack Me Quickly 
Fixed in VersionBETA 0.860 The Lobby Ate My Factions?? 
Summary0020677: Dark spire takes the army from the air after reload the game
DescriptionPlanet Algol. After reloading this save or save from future, i had epic Dark Spire reinforcment with 65k+ Spire power. 0-1% perfomance, and game was stuck, and i see, that from time to time, after reloading save, Dark Spire making a lot of army, i cant undestand this Dark Spire logic anyway.
Screen 1,2. Its happing in Algol batte, but how you can see, we have not so many Golems.
Screen 3. Thats real Golems Graveyard, but i dont remember something about lags and epic Dark Spire army, so, its seems very randomly.
TagsNo tags attached.

Activities

HeartHunter7

Oct 23, 2018 6:32 am

reporter  

22.save (3,568,591 bytes)
20181022232816_1.jpg (630,006 bytes)
20181022223202_1.jpg (467,786 bytes)
22.savemet (41 bytes)
20181022223501_1.jpg (374,078 bytes)

HeartHunter7

Oct 23, 2018 6:35 am

reporter   ~0050242

Regen Golem is making Golem bug, ever more epic.

HeartHunter7

Oct 23, 2018 8:21 am

reporter   ~0050245

After restart game and load new save, i got it.

36.savemet (41 bytes)
20181023151853_1.jpg (394,543 bytes)
36.save (3,657,375 bytes)

RocketAssistedPuffin

Oct 23, 2018 8:21 am

developer   ~0050246

So the Regenerator Golem is worth 25125 Strength in the game files. Dark Spire has a 1.3x multiplier while killing, so that's 32500. Then the generator has a conversion ratio of...uh, 500%, so that one Golem is causing 150000 strength of Dark Spire, and you're losing multiple...the default threshold for the Spire to spawn something is 2000 energy.

So you losing *one* Regenerator Golem is...uhm, causing 70 Dark Spire spawns. Which then in turn increases the conversion ratio...which means you quickly get to 140 Dark Spire spawns...if I understood how they work.

Stop breaking the game man!

More seriously, part of this is the Golem duplicating bug.

RocketAssistedPuffin

Oct 23, 2018 8:23 am

developer   ~0050247

Though...this is with Super Units and Mark 7 stuff dying on a Vengeance planet very often, this isn't...at all common. You could lose 4 Pike Corvettes and probably get a spawn...

RocketAssistedPuffin

Oct 30, 2018 5:50 pm

developer   ~0050387

Please say if this seems any...better.

HeartHunter7

Nov 1, 2018 11:19 am

reporter   ~0050409

I see 0 Dark Spire army on the map or after reload save i see normal/a little army from one Vengeance attack on my side.

HeartHunter7

Nov 3, 2018 4:32 am

reporter   ~0050423

nope, still here, just need load game.
I see a lot of army, but only from one Vengeance Generator, after it i have 0% perfomance. 21k power.
Usually i have minus Vengeance attack, but after reload game, i have big chance for launch Vengeance Attack, and get this army. For reproduce this situaion, you need restart game, not restart save, thats not enough.

62.savemet (51 bytes)
62.save (5,626,331 bytes)
20181103112237_1.jpg (457,239 bytes)

HeartHunter7

Nov 3, 2018 4:36 am

reporter   ~0050424

Also, i see, that in the fight, that Dark Spire dont getting energy. You can see screenshot from battle and 0 energy. But if you restart game with this situation, you will get big army again and 0% perfomance.

20181102220029_1.jpg (498,561 bytes)
dark spire units7.savemet (51 bytes)
dark spire units7.save (5,264,699 bytes)

BadgerBadger

Nov 3, 2018 11:53 am

manager   ~0050429

This sounds very much like a thread gets stuck

BadgerBadger

May 17, 2019 1:19 am

manager   ~0051657

A great deal of this logic has changes since this bug was opened. Please open if you see similar problems in the future.

Issue History

Date Modified Username Field Change
Oct 23, 2018 6:32 am HeartHunter7 New Issue
Oct 23, 2018 6:32 am HeartHunter7 File Added: 22.save
Oct 23, 2018 6:32 am HeartHunter7 File Added: 22.savemet
Oct 23, 2018 6:32 am HeartHunter7 File Added: 20181022223501_1.jpg
Oct 23, 2018 6:32 am HeartHunter7 File Added: 20181022223202_1.jpg
Oct 23, 2018 6:32 am HeartHunter7 File Added: 20181022232816_1.jpg
Oct 23, 2018 6:35 am HeartHunter7 Note Added: 0050242
Oct 23, 2018 8:21 am HeartHunter7 File Added: 20181023151853_1.jpg
Oct 23, 2018 8:21 am HeartHunter7 File Added: 36.save
Oct 23, 2018 8:21 am HeartHunter7 File Added: 36.savemet
Oct 23, 2018 8:21 am HeartHunter7 Note Added: 0050245
Oct 23, 2018 8:21 am RocketAssistedPuffin Note Added: 0050246
Oct 23, 2018 8:23 am RocketAssistedPuffin Note Added: 0050247
Oct 23, 2018 10:31 am Dune Assigned To => RocketAssistedPuffin
Oct 23, 2018 10:31 am Dune Status new => assigned
Oct 30, 2018 5:50 pm RocketAssistedPuffin Status assigned => feedback
Oct 30, 2018 5:50 pm RocketAssistedPuffin Note Added: 0050387
Nov 1, 2018 11:19 am HeartHunter7 Note Added: 0050409
Nov 1, 2018 11:19 am HeartHunter7 Status feedback => assigned
Nov 3, 2018 4:32 am HeartHunter7 File Added: 62.save
Nov 3, 2018 4:32 am HeartHunter7 File Added: 62.savemet
Nov 3, 2018 4:32 am HeartHunter7 File Added: 20181103112237_1.jpg
Nov 3, 2018 4:32 am HeartHunter7 Note Added: 0050423
Nov 3, 2018 4:36 am HeartHunter7 File Added: 20181102220029_1.jpg
Nov 3, 2018 4:36 am HeartHunter7 File Added: dark spire units7.save
Nov 3, 2018 4:36 am HeartHunter7 File Added: dark spire units7.savemet
Nov 3, 2018 4:36 am HeartHunter7 Note Added: 0050424
Nov 3, 2018 11:53 am BadgerBadger Note Added: 0050429
May 17, 2019 1:19 am BadgerBadger Assigned To RocketAssistedPuffin => BadgerBadger
May 17, 2019 1:19 am BadgerBadger Status assigned => closed
May 17, 2019 1:19 am BadgerBadger Resolution open => unable to reproduce
May 17, 2019 1:19 am BadgerBadger Fixed in Version => BETA 0.860 The Lobby Ate My Factions??
May 17, 2019 1:19 am BadgerBadger Note Added: 0051657