View Issue Details

IDProjectCategoryLast Update
0020674AI War 2[All Projects] Bug - GameplayApr 19, 2019 1:42 pm
Reporterwm46Assigned Tox4000Bughunter 
Severityminor 
Status closedResolutionunable to reproduce 
Product Version0.804 Hack Me Quickly 
Fixed in VersionBETA 0.850 The Arrival of Fleets 
Summary0020674: Selection bug upon scrapping unit
DescriptionI scrapped one of my scouts that was deep into AI territory. I then went back to my home planet and attempted to select my group of scouts, but noticed I only had 51/52 selected.

Moving my scout ball showed one scout that was highlighted as if it were selected but could not be moved and didn't count towards my selection. Clicking off of the units to unselect all didn't make the selection circle go away on that scout, double clicking on the scout would select all other scouts like normal. The only way to unselect the scout and return it to normal behavior was to alt+right click.

I had made a save when I noticed the bug occurring, but the save doesn't seem to save what units you have currently selected, so reloading the save means everything is fine. I have a picture of the bug as it occurred here: https://steamcommunity.com/sharedfiles/filedetails/?id=1545826601
TagsGUI, selection

Activities

Dune

Oct 22, 2018 10:20 pm

administrator   ~0050235

Thank you for the bug report and the screenshot!

x4000Bughunter

Apr 19, 2019 1:42 pm

administrator   ~0051198

If you can repro this in the new builds, that would be awesome! Hopefully it is fixed already, though.

Issue History

Date Modified Username Field Change
Oct 22, 2018 7:31 pm wm46 New Issue
Oct 22, 2018 7:33 pm wm46 Tag Attached: GUI
Oct 22, 2018 7:33 pm wm46 Tag Attached: selection
Oct 22, 2018 10:20 pm Dune Assigned To => x4000Bughunter
Oct 22, 2018 10:20 pm Dune Status new => acknowledged
Oct 22, 2018 10:20 pm Dune Note Added: 0050235
Apr 19, 2019 1:42 pm x4000Bughunter Status acknowledged => closed
Apr 19, 2019 1:42 pm x4000Bughunter Resolution open => unable to reproduce
Apr 19, 2019 1:42 pm x4000Bughunter Fixed in Version => BETA 0.850 The Arrival of Fleets
Apr 19, 2019 1:42 pm x4000Bughunter Note Added: 0051198