View Issue Details

IDProjectCategoryLast Update
0019241Starward Rogue[All Projects] Crash/ExceptionFeb 7, 2018 4:23 pm
ReporterShaggyMooseAssigned Tox4000Bughunter 
Severitycrash 
Status resolvedResolutionfixed 
Product Version1.507 (Difficulty Smoothing) 
Fixed in Version2.001 (Die A Fiery Death, Audio Crash) 
Summary0019241: Crash on entering boss door, level 1 (not repeatable)
DescriptionSummary says it all...
TagsNo tags attached.

Activities

ShaggyMoose

Oct 4, 2017 6:48 am

reporter  

2017-10-04_210818.zip (40,351 bytes)

x4000Bughunter

Feb 5, 2018 10:03 am

administrator   ~0046864

Okay, the word I have back from unity on this at the moment is as follows:

----------------

- I have checked the video of the crash in one of your cases, right before the crash, the graphics seems to glitch out.
- A screenshot of R6025 pure virtual function call error makes me think the crash is caused by graphics device drivers.
- All the users who had crashes are using older graphics card driver versions.

For now, could you inform your users who have these crashes to update their graphics card drivers?

If these crashes happen again with new drivers, contact me again and send me the new log files and crash dump files.

x4000Bughunter

Feb 7, 2018 4:23 pm

administrator   ~0046906

* FINALLY fixed the longstanding super-infrequent crashing that was happening for some-but-not-all players. This has been a thorn in our side for two years now, but we finally got some excellent help from Unity's engine developers themselves, and it turns out that we were triggering a crash bug somewhere deep in the engine via calls to WWW.audio.GetAudioClip().
** That's now on their list to investigate and fix, but in our case now that we know what the problem actually is, we've switched approaches to no longer use that method at all, instead baking the music and voice tracks into the game itself.
** We do still have to use this method for the SoundsFromMods optional folder, but that's just for modders who want to add sounds, and it should limit any crashes to on-startup only, not during gameplay. And in those instances it would only be if you're playing with some mods on, and even then only rarely if ever. For everyone currently playing the game that we are aware of, you won't have a crash from this piece. If you have a crash, that would be something else instead.
** Incidentally, the reason that the game was crashing after killing enemies or during room switches is... drumroll... because those are times when music tracks change. We were looking for so many other pieces of code that might be a problem during that time that we never thought to look at music. This is the same music code we've used since 2010 in every other title of ours prior to this one, so whatever the problem is with the underlying engine is must have been introduced in Unity 5 or thereabouts.

Issue History

Date Modified Username Field Change
Oct 4, 2017 6:48 am ShaggyMoose New Issue
Oct 4, 2017 6:48 am ShaggyMoose File Added: 2017-10-04_210818.zip
Feb 5, 2018 10:03 am x4000Bughunter Note Added: 0046864
Feb 7, 2018 4:23 pm x4000Bughunter Assigned To => x4000Bughunter
Feb 7, 2018 4:23 pm x4000Bughunter Status new => resolved
Feb 7, 2018 4:23 pm x4000Bughunter Resolution open => fixed
Feb 7, 2018 4:23 pm x4000Bughunter Fixed in Version => 2.001 (Die A Fiery Death, Audio Crash)
Feb 7, 2018 4:23 pm x4000Bughunter Note Added: 0046906