View Issue Details

IDProjectCategoryLast Update
0019066Starward Rogue[All Projects] Gameplay IssueApr 18, 2017 1:54 pm
ReporterlogorougeAssigned ToPepisolo 
Severitymajor 
Status resolvedResolutionopen 
Product Version1.507 (Difficulty Smoothing) 
Fixed in Version1.508 
Summary0019066: Medical Emergency + Living Hull problem
DescriptionMedical Emergency damage you on entering new rooms, without killing you (disabled on 1HP). But Living Hull doubles the damage and skip from 2 to 0HP, killing you instantly when entering the next room. "this cannot kill you" needs to be true regardless I think.

Example from LP: https://youtu.be/b9JgUviad-w?t=10m45s
TagsNo tags attached.

Activities

Pepisolo

Apr 18, 2017 12:52 pm

developer   ~0046055

Last edited: Apr 18, 2017 12:53 pm

View 2 revisions

OK, so I've managed to fix this, albeit with a hack. The problem is that when using the effect type ChangeCurrentHullHealth, it appears to be typed as Ballistic damage. I'm not sure it should even have a damage type, or perhaps it should have its own damage type. Or perhaps when using ChangeCurrentHullHealth you should be able to set the damage type. I'm not sure what the ideal solution is, but I don't think the effect should have a ballistic damage type.

In any case, my hack was to set the damage of the Medical Emergency for each room entered to 0.5, which then rounds up to 1. So, now with Living Hull, which multiplies all damage taken by 2, the damage taken is now 0.5x2, so it's still 1. This seems to have fixed the problem with no issues, although I'm not really happy with the hacky nature of it. I'll try and get Keith to take a look at the problem.

Issue History

Date Modified Username Field Change
Apr 15, 2017 10:30 am logorouge New Issue
Apr 18, 2017 12:52 pm Pepisolo Note Added: 0046055
Apr 18, 2017 12:53 pm Pepisolo Note Edited: 0046055 View Revisions
Apr 18, 2017 1:54 pm Pepisolo Assigned To => Pepisolo
Apr 18, 2017 1:54 pm Pepisolo Status new => resolved
Apr 18, 2017 1:54 pm Pepisolo Fixed in Version => 1.508